octave-level-set_0.3.0-6_amd64.deb


Advertisement

Description

octave-level-set - level-set toolbox for Octave

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename octave-level-set_0.3.0-6_amd64.deb
Package name octave-level-set
Package version 0.3.0
Package release 6
Package architecture amd64
Package type deb
Category universe/math
Homepage https://octave.sourceforge.io/level-set/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 166.20 KB
Installed size 941.00 KB
This package contains routines for calculating the time-evolution of
the level-set equation and extracting geometric information from the
level-set function in Octave, a scientific computation software.
This Octave add-on package is part of the Octave-Forge project.

Alternatives

Package Version Architecture Repository
octave-level-set_0.3.0-6_i386.deb 0.3.0 i386 Ubuntu Universe
octave-level-set - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
liboctave6 -
libstdc++6 >= 5.2
octave >= 4.4.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package octave-level-set_0.3.0-6_amd64.deb
Source Package octave-level-set

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install octave-level-set deb package:
    # sudo apt-get install octave-level-set

Files

Path
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_geomBoundary.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_geomElements.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_geomGamma.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_internal_fastmarching.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_internal_init_narrowband.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_internal_mesh.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_nbFromGeom.oct
/usr/lib/x86_64-linux-gnu/octave/packages/level-set-0.3.0/x86_64-pc-linux-gnu-api-v52/__levelset_upwindGrad.oct
/usr/share/doc/octave-level-set/NEWS
/usr/share/doc/octave-level-set/changelog.Debian.gz
/usr/share/doc/octave-level-set/copyright
/usr/share/octave/packages/level-set-0.3.0/doc-cache
/usr/share/octave/packages/level-set-0.3.0/fastmarching.m
/usr/share/octave/packages/level-set-0.3.0/ls_absolute_geom.m
/usr/share/octave/packages/level-set-0.3.0/ls_animate_evolution.m
/usr/share/octave/packages/level-set-0.3.0/ls_build_mesh.m
/usr/share/octave/packages/level-set-0.3.0/ls_check.m
/usr/share/octave/packages/level-set-0.3.0/ls_complement.m
/usr/share/octave/packages/level-set-0.3.0/ls_disjoint.m
/usr/share/octave/packages/level-set-0.3.0/ls_distance_fcn.m
/usr/share/octave/packages/level-set-0.3.0/ls_enforce.m
/usr/share/octave/packages/level-set-0.3.0/ls_enforce_speed.m
/usr/share/octave/packages/level-set-0.3.0/ls_equal.m
/usr/share/octave/packages/level-set-0.3.0/ls_extract_solution.m
/usr/share/octave/packages/level-set-0.3.0/ls_find_geometry.m
/usr/share/octave/packages/level-set-0.3.0/ls_genbasic.m
/usr/share/octave/packages/level-set-0.3.0/ls_get_tests.m
/usr/share/octave/packages/level-set-0.3.0/ls_hausdorff_dist.m
/usr/share/octave/packages/level-set-0.3.0/ls_init_narrowband.m
/usr/share/octave/packages/level-set-0.3.0/ls_inside.m
/usr/share/octave/packages/level-set-0.3.0/ls_intersect.m
/usr/share/octave/packages/level-set-0.3.0/ls_isempty.m
/usr/share/octave/packages/level-set-0.3.0/ls_issubset.m
/usr/share/octave/packages/level-set-0.3.0/ls_nb_from_geom.m
/usr/share/octave/packages/level-set-0.3.0/ls_normalise.m
/usr/share/octave/packages/level-set-0.3.0/ls_setdiff.m
/usr/share/octave/packages/level-set-0.3.0/ls_setxor.m
/usr/share/octave/packages/level-set-0.3.0/ls_sign_colourmap.m
/usr/share/octave/packages/level-set-0.3.0/ls_signed_distance.m
/usr/share/octave/packages/level-set-0.3.0/ls_solve_stationary.m
/usr/share/octave/packages/level-set-0.3.0/ls_time_step.m
/usr/share/octave/packages/level-set-0.3.0/ls_union.m
/usr/share/octave/packages/level-set-0.3.0/maze.png
/usr/share/octave/packages/level-set-0.3.0/so_example_problem.m
/usr/share/octave/packages/level-set-0.3.0/so_explore_descent.m
/usr/share/octave/packages/level-set-0.3.0/so_init_params.m
/usr/share/octave/packages/level-set-0.3.0/so_replay_descent.m
/usr/share/octave/packages/level-set-0.3.0/so_run_descent.m
/usr/share/octave/packages/level-set-0.3.0/so_save_descent.m
/usr/share/octave/packages/level-set-0.3.0/so_step_armijo.m
/usr/share/octave/packages/level-set-0.3.0/upwind_gradient_norm.m
/usr/share/octave/packages/level-set-0.3.0/packinfo/CITATION
/usr/share/octave/packages/level-set-0.3.0/packinfo/DESCRIPTION
/usr/share/octave/packages/level-set-0.3.0/packinfo/INDEX
/usr/share/octave/packages/level-set-0.3.0/packinfo/NEWS
/usr/share/octave/packages/level-set-0.3.0/private/ls_copy_sign.m
/usr/share/octave/packages/level-set-0.3.0/private/ls_union_intersect.m
/usr/share/octave/packages/level-set-0.3.0/private/so_load_compressed.m

Changelog

2019-01-02 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-6) unstable; urgency=medium
* d/control:
+ Bump Standards-Version to 4.3.0 (no changes needed)
+ Bump to debhelper compat level 12
* Build-depend on debhelper-compat instead of using d/compat
2018-08-29 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-5) unstable; urgency=medium
* Reupload to unstable
2018-08-28 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-4) unstable; urgency=medium
* d/p/xtest-fastmarching.patch: New patch
2018-08-27 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-3) unstable; urgency=medium
* d/control:
+ Bump Standards-Version to 4.2.1 (no changes needed)
+ Demote octave-parallel from Depends to Suggests
* d/p/skip-unit-tests-if-no-parallel-pkg.patch: New patch
2018-08-24 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-2) unstable; urgency=medium
* d/control:
+ Add Rules-Requires-Root: no
+ Bump Standards-Version to 4.2.0
+ Add dependency on octave-paralllel
2018-06-30 - Rafael Laboissiere <rafael@debian.org>
octave-level-set (0.3.0-1) unstable; urgency=low
* Initial release (closes: #899225)

See Also

Package Description
octave-linear-algebra_2.2.2-7_amd64.deb additional linear-algebra functions for Octave
octave-lssa_0.1.3-2_amd64.deb least squares spectral analysis for Octave
octave-ltfat-common_2.3.1+dfsg-2_all.deb Large Time/Frequency Analysis Toolbox (arch-indep files)
octave-ltfat_2.3.1+dfsg-2_amd64.deb Large Time/Frequency Analysis Toolbox
octave-mapping_1.2.1-4_amd64.deb geographical mapping functions for Octave
octave-miscellaneous_1.2.1-5_amd64.deb miscellaneous tools for Octave
octave-missing-functions_1.0.2-8_all.deb finds functions that are in Matlab but not in Octave
octave-mpi_1.2.0-6_amd64.deb Octave toolbox for parallel computing using MPI
octave-msh_1.0.10-7_amd64.deb create and manage meshes for FE or FV solvers in Octave
octave-mvn_1.1.0-2_all.deb multivariate normal distribution clustering for Octave
octave-nan_3.1.4-5_amd64.deb handles data with and without missing values in Octave
octave-ncarray_1.0.4-2_all.deb access NetCDF files as a multi-dimensional array in Octave
octave-netcdf_1.0.12-2_amd64.deb Matlab compatible NetCDF interface for Octave
octave-nlopt_2.4.2+dfsg-8build1_amd64.deb nonlinear optimization library -- GNU Octave package
octave-nurbs_1.3.13-5_amd64.deb non-uniform rational B-splines for Octave
Advertisement
Advertisement