octave-communications_1.2.1-7_amd64.deb


Advertisement

Description

octave-communications - communications package for Octave

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename octave-communications_1.2.1-7_amd64.deb
Package name octave-communications
Package version 1.2.1
Package release 7
Package architecture amd64
Package type deb
Category universe/math
Homepage https://octave.sourceforge.io/communications/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 177.78 KB
Installed size 766.00 KB
This package provides functions for Octave, a numerical computation
software, to perform error analysis on communication signals,
convert between analog and digital signals, and many more functions
pertaining to signal analysis.
This Octave add-on package is part of the Octave-Forge project.

Alternatives

Package Version Architecture Repository
octave-communications_1.2.1-7_i386.deb 1.2.1 i386 Ubuntu Universe
octave-communications - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
liboctave6 -
libstdc++6 >= 5.2
octave-communications-common = 1.2.1-7

Download

Type URL
Mirror archive.ubuntu.com
Binary Package octave-communications_1.2.1-7_amd64.deb
Source Package octave-communications

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install octave-communications deb package:
    # sudo apt-get install octave-communications

Files

Path
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/PKG_ADD
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/PKG_DEL
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/__errcore__.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/__gfweight__.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/cyclgen.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/cyclpoly.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/genqamdemod.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/gf.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/isprimitive.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/primpoly.oct
/usr/lib/x86_64-linux-gnu/octave/packages/communications-1.2.1/x86_64-pc-linux-gnu-api-v52/syndtable.oct
/usr/share/doc/octave-communications/NEWS
/usr/share/doc/octave-communications/changelog.Debian.gz
/usr/share/doc/octave-communications/copyright

Changelog

2019-01-02 - Rafael Laboissiere <rafael@debian.org>
octave-communications (1.2.1-7) unstable; urgency=medium
* d/control:
+ Add Rules-Requires-Root: no
+ Bump Standards-Version to 4.3.0
+ Build depend on texlive-plain-generic
+ Bump to debhelper compat level 12
* Build-depend on debhelper-compat instead of using d/compat
2018-06-20 - Sébastien Villemot <sebastien@debian.org>
octave-communications (1.2.1-6) unstable; urgency=medium
* Team upload
[ Mike Miller ]
* d/control, d/copyright: Use secure URL for upstream source.
[ Rafael Laboissiere ]
* d/control: Bump Standards-Version to 4.1.4 (no changes needed)
[ Sébastien Villemot ]
* octave-4.2.patch renamed to octave-4.4.patch, with more fixes for 4.4
* Add dependency on octave-statistics
qfuncinv() uses norminv(). This function is no longer in Octave core
since 4.4, and has moved to the statistics package.
+ depends-on-statistics.patch: new patch
+ d/control: add B-D on octave-statistics
2018-02-10 - Rafael Laboissiere <rafael@debian.org>
octave-communications (1.2.1-5) unstable; urgency=medium
* Use dh-octave for building the package
* d/control:
+ Use Debian's GitLab URLs in Vcs-* headers
+ Change Maintainer to team+pkg-octave-team@tracker.debian.org
2017-12-29 - Rafael Laboissiere <rafael@debian.org>
octave-communications (1.2.1-4) unstable; urgency=medium
* Use the dh-based version of octave-pkg-dev
* Set debhelper compatibility level to >= 11
* d/control:
+ Add Testsuite field
+ Build-depend on gnuplot-nox, instead of gnuplot
+ Bump Standards-Version to 4.1.3 (no changes needed)
2017-07-03 - Sébastien Villemot <sebastien@debian.org>
octave-communications (1.2.1-3) unstable; urgency=medium
* Team upload.
[ Sébastien Villemot ]
* d/p/octave-4.2.patch: new patch, fixes FTBFS against Octave 4.2.
(Closes: #867014)
* d/copyright: use secure URL for format.
* Bump to debhelper compat level 10.
* d/watch: bump to format version 4.
* d/rules: add support for "nodoc" flag of DEB_BUILD_OPTIONS.
* d/control:
+ Drop unneeded versioned dependencies.
+ Bump to Standards-Version 4.0.0.
[ Rafael Laboissiere ]
* d/control: Use cgit instead of gitweb in Vcs-Browser URL
2016-07-28 - Rafael Laboissiere <rafael@debian.org>
octave-communications (1.2.1-2) unstable; urgency=medium
* d/control: Use secure URIs in the Vcs-* fields
* d/control: Bump Standards-Version to 3.9.8 (no changes needed)
* Reproducible build
+ d/rules: Set SOURCE_DATE_EPOCH envvar, for
+ d/p/random-seed-for-pdf-doc.patch: New patch
+ d/rules: Avoid non-deterministic tempfile names in PDF files
* Clean files explicitly
+ d/rules: Drop the clean target
+ d/clean: Add file
2015-07-20 - Sébastien Villemot <sebastien@debian.org>
octave-communications (1.2.1-1) unstable; urgency=medium
* Team upload.
[ Rafael Laboissiere ]
* Imported Upstream version 1.2.1
* d/p/autoload-yes.patch: Remove patch (deprecated upstream)
* d/control: Bump Standards-Version to 3.9.6 (no changes needed)
[ Sébastien Villemot ]
* d/p/hdf5-ldflags.patch: drop patch, no longer needed.
2014-08-21 - Sébastien Villemot <sebastien@debian.org>
octave-communications (1.2.0-2) unstable; urgency=medium
* Team upload.
* Uploaders: set as Rafael Laboissiere and Mike Miller.
* hdf5-ldflags.patch: new patch, inject HDF5 LDFLAGS in the build.
Needed for the new HDF5 1.8.13 layout. (Closes: #758733)
2013-12-02 - Thomas Weber <tweber@debian.org>
octave-communications (1.2.0-1) unstable; urgency=low
* Imported Upstream version 1.2.0
* Bump to Standards-Version 3.9.5, no changes needed
* Dropped patches (applied upstream):
- oct2dec.patch
- build-documentation.patch
- avoid-makeinfo-section-raising-error.patch
* Refreshed patches
* Update copyright information

See Also

Package Description
octave-control_3.1.0-3_amd64.deb computer-aided control system design (CACSD) for Octave
octave-data-smoothing_1.3.0-7_all.deb functions to do data smoothing on noisy data
octave-dataframe_1.2.0-4_all.deb manipulate data in Octave similar to R data.frame
octave-dicom_0.2.1-5_amd64.deb manipulate DICOM files in Octave
octave-divand_1.1.2+dfsg-4_all.deb n-dimensional interpolation for Octave
octave-doc_4.4.1-5_all.deb documentation of the GNU Octave language
octave-doctest_0.6.1-2_all.deb documentation tests for Octave
octave-econometrics_1.1.1-6_amd64.deb econometrics functions for Octave
octave-financial_0.5.3-2_all.deb financial package for Octave
octave-fits_1.0.7-2_amd64.deb manipulation of FITS files in Octave
octave-fpl_1.3.5-5_all.deb plot data on unstructured triangular and tetrahedral meshes in Octave
octave-fuzzy-logic-toolkit_0.4.5-2_all.deb fuzzy logic toolkit for Octave
octave-ga_0.10.0-6_all.deb genetic optimization code for Octave
octave-gdf_0.1.2-2.1build3_amd64.deb IO library for the GDF -- Octave interface
octave-general_2.1.0-2_amd64.deb provide extra general functions for Octave
Advertisement
Advertisement