obmenu_1.0-4_amd64.deb


Advertisement

Description

obmenu - Graphical menu editor for openbox

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename obmenu_1.0-4_amd64.deb
Package name obmenu
Package version 1.0
Package release 4
Package architecture amd64
Package type deb
Category universe/x11
Homepage http://obmenu.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 22.93 KB
Installed size 123.00 KB
Obmenu is a graphical menu editor for the Openbox window manager.
Openbox uses XML to store its menu preferences, and editing these by hand
can quickly become tedious. This utility provides a convenient method of
editing the menu in a graphical interface, while not losing the powerful
features of Openbox such as its pipe menus.
This also provides a Python module named obxml that can be used to further
script Openbox's menu system.

Alternatives

Package Version Architecture Repository
obmenu_1.0-4_i386.deb 1.0 i386 Ubuntu Universe
obmenu - - -

Requires

Name Value
python-glade2 -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package obmenu_1.0-4_amd64.deb
Source Package obmenu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install obmenu deb package:
    # sudo apt-get install obmenu

Files

Path
/usr/bin/obm-dir
/usr/bin/obm-moz
/usr/bin/obm-nav
/usr/bin/obm-xdg
/usr/bin/obmenu
/usr/lib/python2.7/dist-packages/obMenu-1.0.egg-info
/usr/lib/python2.7/dist-packages/obxml.py
/usr/share/doc/obmenu/README
/usr/share/doc/obmenu/changelog.Debian.gz
/usr/share/doc/obmenu/copyright
/usr/share/doc/obmenu/obxml-help
/usr/share/doc/obmenu/pipes-help
/usr/share/man/man1/obm-dir.1.gz
/usr/share/man/man1/obm-moz.1.gz
/usr/share/man/man1/obm-nav.1.gz
/usr/share/man/man1/obm-xdg.1.gz
/usr/share/man/man1/obmenu.1.gz
/usr/share/menu/obmenu
/usr/share/obmenu/mnu16.png
/usr/share/obmenu/mnu48.png
/usr/share/obmenu/obmenu.glade

Changelog

2017-01-25 - Diego Sarzi <diegosarzi@gmail.com>
obmenu (1.0-4) unstable; urgency=medium
* debian/control:
- Removed "${python:Versions}" to avoid the package can't
be uninstallable. (Closes: #852452)
* debian/copyright:
- Updated the copyright years.
2017-01-19 - Diego Sarzi <diegosarzi@gmail.com>
obmenu (1.0-3) unstable; urgency=medium
* New Maintainer. Thanks to Edgar Antonio 
Palma de la Cruz. (Closes: #834307).
* debian/control:
- Added "${python:Versions}".
- Bumped Standards-Version to 3.9.8.
- Bumped compat file and debhelper to 10.
* debian/copyright:
- Update all information and licenses.
* debian/dirs:
- Removed, useless file.
* debian/manpages:
- Created file to install manpages correctly and
removed override_dh_installman in debian rules.
* debian/python-module-stampdir:
- Removed, useless directory.
* debian/rules:
- Added "--buildsystem=pybuild" in rules file.
* debian/watch:
- Update Version to 4.
- Update watch file (regular expression).
2015-08-24 - Andrey Rahmatullin <wrar@debian.org>
obmenu (1.0-2+nmu2) unstable; urgency=medium
* Non-maintainer upload.
* Port from python-support to dh-python (Closes: #786203).
* Drop obsolete debian/pycompat.
2012-11-21 - Michael Gilbert <mgilbert@debian.org>
obmenu (1.0-2+nmu1) unstable; urgency=medium
* Non-maintainer upload.
* Handle insufficient number of command-line arguments in obm-xdg
(closes: #693319).
2011-05-02 - Edgar Antonio Palma de la Cruz <xbytemx@gmail.com>
obmenu (1.0-2) unstable; urgency=low
[ Edgar Antonio Palma de la Cruz ]
* New maintainer. Closes: #583246, #512607
* Bumped Standards-Version to 3.9.2
* Bumped compat file and debhelper to 8
* Added misc depends to control file.
* Switch to dpkg-source 3.0 (quilt) format.
* Removed cdbs and dpatch from control file.
* Added a watch file.
* Fixed a few typos on manpages of obm-dir and obm-moz. Closes: #573819
* Fix the python2.5 dependency. Closes: #623012
* Removed post*debhelper.
* Added python-Depends to binary.
* Added a homepage.
* Moved to Applications/System/Administration section on menu file.
2007-08-02 - Davide Truffa <davide@catoblepa.org>
obmenu (1.0-1) unstable; urgency=low
* Initial release (Closes: #433520)

See Also

Package Description
obs-api_2.9.4-1_all.deb Open Build Service (API)
obs-build_20180831-2_all.deb scripts for building RPM/debian packages for multiple distributions
obs-plugins_22.0.3+dfsg1-1_amd64.deb recorder and streamer for live video content (plugins)
obs-productconverter_2.9.4-1_all.deb Open Build Service (product definition utility)
obs-server_2.9.4-1_all.deb Open Build Service (server component)
obs-studio_22.0.3+dfsg1-1_amd64.deb recorder and streamer for live video content
obs-utils_2.9.4-1_all.deb Open Build Service (utilities)
obs-worker_2.9.4-1_all.deb Open Build Service (build host component)
obsession_20140608-2build1_amd64.deb Session management helpers for lightweight desktop environments
obsidian-icon-theme_3.5-1_all.deb Intuitive Faenza-like icon theme
oca-core_11.0.20180730-1_all.deb Odoo Community business app
ocaml-base-nox_4.05.0-10ubuntu2_amd64.deb Runtime system for OCaml bytecode executables (no X)
ocaml-base_4.05.0-10ubuntu2_amd64.deb Runtime system for OCaml bytecode executables
ocaml-batteries-included_2.6.0-1build1_all.deb Batteries included: OCaml development platform - metapackage
ocaml-compiler-libs_4.05.0-10ubuntu2_amd64.deb OCaml interpreter and standard libraries
Advertisement
Advertisement