nvi-doc_1.81.6-15_all.deb


Advertisement

Description

nvi-doc - 4.4BSD re-implementation of vi - documentation files

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename nvi-doc_1.81.6-15_all.deb
Package name nvi-doc
Package version 1.81.6
Package release 15
Package architecture all
Package type deb
Category universe/doc
Homepage https://repo.or.cz/nvi.git
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 104.99 KB
Installed size 195.00 KB
Vi is the original screen based text editor for Unix systems.
It is considered the standard text editor, and is available on
almost all Unix systems.
Nvi is intended as a "bug-for-bug compatible" clone of the original
BSD vi editor. As such, it doesn't have a lot of snazzy features as do
some of the other vi clones such as elvis and vim. However, if all
you want is vi, this is the one to get.
This package contains the tutorials and the reference manual.

Alternatives

Package Version Architecture Repository
nvi-doc_1.81.6-15_all.deb 1.81.6 all Ubuntu Universe
nvi-doc - - -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package nvi-doc_1.81.6-15_all.deb
Source Package nvi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nvi-doc deb package:
    # sudo apt-get install nvi-doc

Files

Path
/usr/share/doc/nvi-doc/NEWS.Debian.gz
/usr/share/doc/nvi-doc/changelog.Debian.gz
/usr/share/doc/nvi-doc/changelog_stable.gz
/usr/share/doc/nvi-doc/copyright
/usr/share/doc/nvi-doc/vi.advanced
/usr/share/doc/nvi-doc/vi.beginner
/usr/share/doc/nvi-doc/vi.ref.txt.gz

Changelog

2018-12-04 - Boyuan Yang <byang@debian.org>
nvi (1.81.6-15) unstable; urgency=medium
* QA upload.
* debian/control:
+ Add Vcs-Git and Vcs-Browser fields and use git repo under
Salsa Debian group.
+ Mark nvi-doc as Multi-Arch: foreign.
+ Use a more recent project homepage for Homepage field.
(Closes: #749334)
* Remove trailing spaces in debian/control and debian/changelog.
2018-12-01 - Ansgar Burchardt <ansgar@debian.org>
nvi (1.81.6-14) unstable; urgency=medium
* QA upload.
* Explicit pass vi_cv_path_shell=/bin/sh to configure to make build
reproducible between merged-usr and non-merged-usr systems.
(Closes: #915170)
2016-12-31 - Colin Watson <cjwatson@debian.org>
nvi (1.81.6-13) unstable; urgency=medium
* QA upload.
* Build with all hardening options.
* CVE-2015-2305: Apply heap overflow patch from Dragonfly BSD (closes:
#778412).
* Fix cross-build failure: pass --build and --host to configure (thanks,
Helmut Grohne; closes: #794030).
2015-09-17 - Bryan Quigley <bryan.quigley@canonical.com>
nvi (1.81.6-12) unstable; urgency=medium
* QA upload
* Add systemd job (Closes: #796635)
* Make recover script complete enough for use in init process
- Rename init script from nviboot to nvi, move out of runlevel S
* Cleanup
2014-01-09 - Colin Watson <cjwatson@debian.org>
nvi (1.81.6-11) unstable; urgency=medium
* QA upload.
* Pass "-s /bin/sh" to "su nobody" to cope with the change of nobody's
shell in base-passwd 3.5.30.
2013-05-25 - Frank Lichtenheld <djpig@debian.org>
nvi (1.81.6-10) unstable; urgency=low
* QA upload.
* Fix binary-arch builds
2013-05-25 - Frank Lichtenheld <djpig@debian.org>
nvi (1.81.6-9) unstable; urgency=low
* QA upload.
* Change maintainer to QA group
* debian/ cleanup:
+ bump debhelper compat to 9
+ use dpkg-buildflags
+ use dh (as far as possible)
+ convert from dpatch to 3.0 (quilt) with patch from
Jari Aalto. (Closes: #664360)
2011-05-14 - Axel Beckert <abe@debian.org>
nvi (1.81.6-8.2) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on libdb-dev (Closes: #621381)
* Bumped Standards-Version to 3.9.2
- Included full license texts in debian/copyright instead of refering
to /usr/share/common-licenses/BSD (which is due to be removed from
common-licenses)
* Added a dependency on ${misc:Depends} to each binary to fix the lintian
warning debhelper-but-no-misc-depends.
* Added a README.source (based on dpatch's standard README.source) to
fix the lintian warning patch-system-but-no-source-readme.
2010-01-28 - Moritz Muehlenhoff <jmm@debian.org>
nvi (1.81.6-8.1) unstable; urgency=medium
* Non-maintainer upload.
* Build-depend on libdb4.7-dev (Closes: #555933)
2009-07-24 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de>
nvi (1.81.6-8) unstable; urgency=low
* Fix generation of backup file names. Closes: #534732.
* Bump Standards version to 3.8.2 (no changes).
* Minor adjustments to make lintian's pedantic mode happier:
* Remove redundant lines from d/control.
* Add some patch descriptions.
* Adjust packaging copyright year list.

See Also

Package Description
nvi_1.81.6-15_amd64.deb 4.4BSD re-implementation of vi
nvidia-common_0.6.3_amd64.deb transitional package for ubuntu-drivers-common
nvme-cli_1.7-1_amd64.deb userspace tooling to control NVMe drives
nvptx-tools_0.20180301-1_amd64.deb collection of tools for use with nvptx-none GCC toolchains
nvram-wakeup_1.1-4build1_amd64.deb Read/write the WakeUp time from/to the BIOS
nvramtool_0.0+r3669-2.2build1_amd64.deb Read/write coreboot-related NVRAM/CMOS information
nvtv_0.4.7-8build1_amd64.deb tool to control TV chips on NVidia cards under Linux
nwall_1.32+debian-4.2build2_amd64.deb version of wall that uses GNU readline
nwchem-data_6.8.1-5_all.deb High-performance computational chemistry software (data files)
nwchem_6.8.1-5_amd64.deb High-performance computational chemistry software
nwipe_0.25-1_amd64.deb Utility to securely erase disks
nwrite_1.9.2-20.1build1_amd64.deb Enhanced replacement for the write command
nx-x11-common_3.5.99.19-1_all.deb nx-X11 (common files)
nx-x11proto-composite-dev_3.5.99.19-1_amd64.deb nx-X11 Composite extension wire protocol
nx-x11proto-core-dev_3.5.99.19-1_amd64.deb nx-X11 core wire protocol and auxiliary headers
Advertisement
Advertisement