npm2deb_0.2.8-5_all.deb


Advertisement

Description

npm2deb - tool to help debianize Node.js modules

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename npm2deb_0.2.8-5_all.deb
Package name npm2deb
Package version 0.2.8
Package release 5
Package architecture all
Package type deb
Category universe/devel
Homepage https://github.com/LeoIannacone/npm2deb
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 18.86 KB
Installed size 96.00 KB
This application eases packaging Node.js modules available via npm.
It is also able to list modules dependencies and check which ones are
already available as Debian packages.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
npm2deb_0.2.8-5_all.deb 0.2.8 all Ubuntu Universe
npm2deb - - -

Requires

Name Value
devscripts -
node-github-url-from-git >= 1.4.0~
npm -
python3-apt -
python3-dateutil -
python3:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package npm2deb_0.2.8-5_all.deb
Source Package npm2deb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install npm2deb deb package:
    # sudo apt-get install npm2deb

Files

Path
/usr/bin/npm2deb
/usr/lib/python3/dist-packages/npm2deb-0.2.8.egg-info
/usr/lib/python3/dist-packages/npm2deb/__init__.py
/usr/lib/python3/dist-packages/npm2deb/helper.py
/usr/lib/python3/dist-packages/npm2deb/mapper.py
/usr/lib/python3/dist-packages/npm2deb/scripts.py
/usr/lib/python3/dist-packages/npm2deb/templates.py
/usr/lib/python3/dist-packages/npm2deb/utils.py
/usr/share/bash-completion/completions/npm2deb
/usr/share/doc/npm2deb/AUTHORS
/usr/share/doc/npm2deb/README.md
/usr/share/doc/npm2deb/changelog.Debian.gz
/usr/share/doc/npm2deb/copyright
/usr/share/man/man1/npm2deb.1.gz

Changelog

2018-09-30 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.8-5) unstable; urgency=medium
* Update rmadison-fix.patch to use python-apt for version comparison
* Update at-in-name-fix.patch
* Set DEBEMAIL and DEBFULLNAME for autopkgtest
2018-09-28 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.8-4) unstable; urgency=medium
* Patch by anarcat to find packages correctly (Closes: #909753)
* Add autopkgtest test case for view
2018-09-27 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.8-3) unstable; urgency=medium
* Add set -x to autopkgtest script
* Add patch to fix modules with @ in name (Closes: #909101)
Thanks to Ashutosh Kumar Singh (juggernaut451) for the patch
* Add more test cases to autopkgtest
2018-09-23 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.8-2) unstable; urgency=medium
* Add basic autopkgtest
* Bump Standards-Version to 4.2.1 (no changes needed)
* Drop X-Python3-version field (obsolete)
2018-08-17 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.8-1) unstable; urgency=medium
[ Pirate Praveen ]
* New upstream version 0.2.8 (Closes: #901125, #867298, #873098, #905943)
* Switch to github releases page from tags page in watch
* Bump Standards-Version to 4.2.0 (no changes needed)
* Bump debhelper compatibility level to 11
* Drop all patches applied upstream
[ Julien Puydt ]
* Use https in the d/copyright template's Format field
2017-10-23 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.7-6) unstable; urgency=medium
* Bump standards version to 4.1.1 (both for npm2deb and created packages)
2017-09-29 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.7-5) unstable; urgency=medium
* Use tac instead of tail (fixes js-task-wiki-edit script)
2017-09-28 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.7-4) unstable; urgency=medium
* Take latest version listed by rmadison
2017-09-25 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.7-3) unstable; urgency=medium
* Change section to javascript
* Set standards version of created package to 4.1.0
* Bump standards version to 4.1.0
2017-07-30 - Pirate Praveen <praveen@debian.org>
npm2deb (0.2.7-2) unstable; urgency=medium
* Set standards version of created package to 4.0.0
* Blacklist unwanted files from created package's debian/install
(Closes: #867295)

See Also

Package Description
npm_5.8.0+ds6-4_all.deb package manager for Node.js
nq_0.3.1-1_amd64.deb Lightweight queue system
nqc_3.1.r6-7_amd64.deb Not Quite C compiler for LEGO Mindstorms RCX
nqp_2018.12+dfsg-1_amd64.deb Not Quite Perl compiler
nrefactory-samples_5.3.0+20130718.73b6d0f-4_all.deb C# Parsing and Refactoring Library - Sample programs
nrg2iso_0.4-4build1_amd64.deb Extracts ISO9660 data from Nero ".nrg" files
nrpe-ng_0.2.0-1_all.deb Next-generation Nagios remote plugin agent
ns2-doc_2.35+dfsg-3_all.deb docs of ns2
ns2-examples_2.35+dfsg-3_all.deb examples of ns2
ns2_2.35+dfsg-3_amd64.deb Discrete event simulator targeted at networking research
ns3-doc_3.29+dfsg-3_all.deb documentation for ns3
ns3_3.29+dfsg-3_amd64.deb discrete-event network simulator for Internet systems
nsca-client_2.9.2-2_amd64.deb Nagios service monitor agent - client package
nsca-ng-client_1.5-3_amd64.deb Send monitoring commands to NSCA-ng server
nsca-ng-server_1.5-3_amd64.deb Monitoring command acceptor
Advertisement
Advertisement