notary_0.6.1~ds1-3_amd64.deb


Advertisement

Description

notary - tool for running and interacting with trusted collections

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename notary_0.6.1~ds1-3_amd64.deb
Package name notary
Package version 0.6.1~ds1
Package release 3
Package architecture amd64
Package type deb
Category universe/devel
Homepage https://github.com/theupdateframework/notary
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.06 MB
Installed size 43.00 MB
Notary is a project that allows anyone to have trust over arbitrary
collections of data.
The Notary project comprises a server (cmd/notary-server) and a client
(cmd/notary) for running and interacting with trusted collections.
Notary aims to make the internet more secure by making it easy for people to
publish and verify content. We often rely on TLS to secure our communications
with a web server which is inherently flawed, as any compromise of the server
enables malicious content to be substituted for the legitimate content.
With Notary, publishers can sign their content offline using keys kept highly
secure. Once the publisher is ready to make the content available, they can
push their signed trusted collection to a Notary Server.
Consumers, having acquired the publisher's public key through a secure
channel, can then communicate with any notary server or (insecure) mirror,
relying only on the publisher's key to determine the validity and integrity
of the received content.
This package contains the binaries/tools.

Alternatives

Package Version Architecture Repository
notary_0.6.1~ds1-3_i386.deb 0.6.1~ds1 i386 Ubuntu Universe
notary - - -

Requires

Name Value
libc6 >= 2.4
libltdl7 >= 2.4.6
libnspr4 >= 2:4.9-2~
libnss3 >= 2:3.13.4-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package notary_0.6.1~ds1-3_amd64.deb
Source Package notary

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install notary deb package:
    # sudo apt-get install notary

Files

Path
/usr/bin/escrow
/usr/bin/notary
/usr/bin/notary-server
/usr/bin/notary-signer
/usr/share/doc/notary/README.md.gz
/usr/share/doc/notary/ROADMAP.md
/usr/share/doc/notary/changelog.Debian.gz
/usr/share/doc/notary/copyright
/usr/share/doc/notary/docs/Dockerfile
/usr/share/doc/notary/docs/Makefile
/usr/share/doc/notary/docs/README.md
/usr/share/doc/notary/docs/advanced_usage.md.gz
/usr/share/doc/notary/docs/best_practices.md.gz
/usr/share/doc/notary/docs/command_reference.md.gz
/usr/share/doc/notary/docs/getting_started.md.gz
/usr/share/doc/notary/docs/index.md
/usr/share/doc/notary/docs/running_a_service.md.gz
/usr/share/doc/notary/docs/service_architecture.md.gz
/usr/share/doc/notary/docs/images/key-hierarchy.svg
/usr/share/doc/notary/docs/images/metadata-sequence.svg
/usr/share/doc/notary/docs/images/notary-blk.svg
/usr/share/doc/notary/docs/images/notary-n-blk.svg
/usr/share/doc/notary/docs/images/notary-n-wht.svg
/usr/share/doc/notary/docs/images/notary-wth.svg
/usr/share/doc/notary/docs/images/service-architecture.svg
/usr/share/doc/notary/docs/images/service-deployment.svg
/usr/share/doc/notary/docs/images/trust-pinning-flow.png
/usr/share/doc/notary/docs/reference/client-config.md.gz
/usr/share/doc/notary/docs/reference/common-configs.md
/usr/share/doc/notary/docs/reference/index.md
/usr/share/doc/notary/docs/reference/server-config.md.gz
/usr/share/doc/notary/docs/reference/signer-config.md.gz
/usr/share/doc/notary/docs/resources/ncc_docker_notary_audit_2015_07_31.pdf.gz
/usr/share/doc/notary/docs/resources/opensslCertGen.sh
/usr/share/doc/notary/docs/resources/tuf_update_flow.jpg
/usr/share/lintian/overrides/notary

Changelog

2019-04-04 - Shengjing Zhu <zhsj@debian.org>
notary (0.6.1~ds1-3) unstable; urgency=medium
* Team upload.
* Regenerate some test certs since they are expired (Closes: #924119)
2018-07-11 - Dmitry Smirnov <onlyjob@debian.org>
notary (0.6.1~ds1-2) unstable; urgency=medium
* New upstream patch to remove "golang-ed25519-dev" dependency.
2018-06-20 - Dmitry Smirnov <onlyjob@debian.org>
notary (0.6.1~ds1-1) unstable; urgency=medium
* Team upload
* Fixed FTBFS (Closes: #861546, #835782).
[ Dmitry Smirnov ]
* New namespace github.com/theupdateframework/notary
* Provides: golang-github-theupdateframework-notary-dev
* Testsuite: autopkgtest-pkg-go
* Standards-Version: 4.1.4; Priority: optional.
* Updates Vcs URLs.
* golang-go --> golang-any
* debhelper to version 11; compat to version 10.
* logrus dependency update.
* new patch to disable failing networking test.
* L: duplicate-short-description
* Build-Depends:
- golang-github-docker-distribution-dev
[ Arnaud Rebillout ]
* New upstream version 0.6.1~ds1
* Remove patches applied upstream
* Remove obsolete patches
* lintian: no more embedded yaml, add a few overrides
* docs: include changelog and roadmap
* rules: install test fixtures explicitly instead of using INSTALL_ALL
* rules: enable pkcs11 build tag
* rules: enable tests
* control: update dependencies
* control: update description
* control: add myself to uploaders
2018-04-02 - Alexandre Viau <aviau@debian.org>
notary (0.2.0~ds1-1) unstable; urgency=medium
[ Tianon Gravi ]
* Update to 0.2.0 upstream release
[ Paul Tagliamonte ]
* Remove Built-Using from arch:all -dev package
[ Alexandre Viau ]
* Point Vcs-* urls to salsa.debian.org.
2016-03-17 - Dmitry Smirnov <onlyjob@debian.org>
notary (0.1~ds1-1) unstable; urgency=medium
* Team upload.
* New upstream release (Closes: #818439).
[ Tim Potter ]
* Update to latest upstream version and add new dependencies
(Closes: #810777).
* Refresh d/patches to reflect upstream work and run more tests.
[ Dmitry Smirnov ]
* Standards-Version: 3.9.7.
* Build-Depends += "golang-github-bugsnag-bugsnag-go-dev".
* Dropped obsolete "no-bugsnag.patch".
* Ignore test failures.
2015-10-28 - Tianon Gravi <tianon@debian.org>
notary (0.0~git20150801.0.8e8122e-2) unstable; urgency=medium
* Swap Build-Depends relations for buildability
2015-10-23 - Tianon Gravi <tianon@debian.org>
notary (0.0~git20150801.0.8e8122e-1) unstable; urgency=medium
* Initial release (Closes: #797660)

See Also

Package Description
note_1.3.26-2_all.deb small program managing notes from commandline
notification-daemon_3.20.0-4_amd64.deb daemon for displaying passive pop-up notifications
notify-osd-icons_0.8+15.10.20151016.2-0ubuntu1_all.deb Notify-OSD icons
notify-osd_0.9.35+16.04.20160415-0ubuntu3_amd64.deb daemon that displays passive pop-up notifications
notmuch-addrlookup_9-1_amd64.deb Address lookup tool for Notmuch
notmuch-emacs_0.28.3-1ubuntu1_all.deb thread-based email index, search and tagging (transitional package)
notmuch-mutt_0.28.3-1ubuntu1_all.deb thread-based email index, search and tagging (Mutt interface)
notmuch-vim_0.28.3-1ubuntu1_all.deb thread-based email index, search and tagging (vim interface)
notmuch_0.28.3-1ubuntu1_amd64.deb thread-based email index, search and tagging
nova-ajax-console-proxy_19.0.0-0ubuntu2_all.deb OpenStack Compute - AJAX console proxy - transitional package
nova-api-metadata_19.0.0-0ubuntu2_all.deb OpenStack Compute - metadata API frontend
nova-api-os-compute_19.0.0-0ubuntu2_all.deb OpenStack Compute - OpenStack Compute API frontend
nova-api-os-volume_19.0.0-0ubuntu2_all.deb OpenStack Compute - OpenStack Volume API frontend
nova-cells_19.0.0-0ubuntu2_all.deb Openstack Compute - cells
nova-compute-qemu_19.0.0-0ubuntu2_all.deb OpenStack Compute - compute node (QEmu)
Advertisement
Advertisement