node-zipfile_0.5.12+ds-3_amd64.deb


Advertisement

Description

node-zipfile - library for handling zipfiles in Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-zipfile_0.5.12+ds-3_amd64.deb
Package name node-zipfile
Package version 0.5.12+ds
Package release 3
Package architecture amd64
Package type deb
Category universe/libdevel
Homepage https://github.com/springmeyer/node-zipfile
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 31.28 KB
Installed size 110.00 KB
node-zipfile is a C++ module for handling zipfiles in Node.js. It provides
bindings to libzip, whis is a C library for reading, creating, and modifying
zip archives..
Node.js is an event-based server-side javascript engine.

Alternatives

Package Version Architecture Repository
node-zipfile_0.5.12+ds-3_i386.deb 0.5.12+ds i386 Ubuntu Universe
node-zipfile - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libnode64 -
libstdc++6 >= 5.2
libzip5 >= 0.10
node-pre-gyp >= 0.10.2~
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-zipfile_0.5.12+ds-3_amd64.deb
Source Package node-zipfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-zipfile deb package:
    # sudo apt-get install node-zipfile

Files

Path
/usr/lib/nodejs/zipfile/package.json
/usr/lib/nodejs/zipfile/lib/index.js
/usr/lib/nodejs/zipfile/lib/zipfile.js
/usr/lib/nodejs/zipfile/lib/binding/zipfile.node
/usr/share/doc/node-zipfile/README.md
/usr/share/doc/node-zipfile/changelog.Debian.gz
/usr/share/doc/node-zipfile/copyright

Changelog

2019-01-07 - Jérémy Lal <kapouer@melix.org>
node-zipfile (0.5.12+ds-3) unstable; urgency=medium
* Build against libnode-dev
* Use https homepage
* Standards-Version 4.3.0
* Use Test-Command for autopkgtest (Closes: #894959)
2018-08-22 - Pirate Praveen <praveen@debian.org>
node-zipfile (0.5.12+ds-2) unstable; urgency=medium
* Team upload
* Reupload to unstable 
2018-08-20 - Pirate Praveen <praveen@debian.org>
node-zipfile (0.5.12+ds-1) experimental; urgency=medium
* Team upload
* New upstream version 0.5.12+ds
* Bump Standards-Version to 4.2.0 (no changes needed)
* Bump debhelper compatibility level to 11
* Use salsa.debian.org in Vcs-* fields
* Tighten dependency on node-pre-gyp
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-zipfile (0.5.11+ds-2) unstable; urgency=medium
* Stick to how upstream installs files
2016-12-20 - Jérémy Lal <kapouer@melix.org>
node-zipfile (0.5.11+ds-1) unstable; urgency=medium
* New upstream version 0.5.11+ds (Closes: #802351)
* Patch package.json to fix binding load path
* Build-Depends mocha, node-pre-gyp
* Depends node-pre-gyp
* Run tests during build
* Copyright for world mercator test data, and keep
those test files in tarball
* Enable autopkgtests
* Standards-Version 3.9.8
* Secure Vcs url
* Use dh nodejs
* Use repacksuffix
* Properly install module with package.json
2014-03-16 - Jérémy Lal <kapouer@melix.org>
node-zipfile (0.5.0+ds-1) unstable; urgency=medium
* New upstream version
* Install zipfile.node only to get rid of node-pre-gyp dependency.
* Build-Depends pkg-config, fix configure flags (Closes: #741748).
* copyright:
+ add new owner for 2014
+ use Excluded-Files section
2013-08-30 - Jérémy Lal <kapouer@melix.org>
node-zipfile (0.4.0+ds1-1) unstable; urgency=low
* New upstream version
* Loosen dependency on nodejs
* Build using node-gyp instead of node-waf
* Remove pkg-config from Build-Depends, not needed by node-gyp
* Further repackaging: remove test data, and keep deps/*.gypi
* Update copyright, fix Source field, explain repackaging
* Canonicalize Vcs fields
* Standards-Version 3.9.4
* Use dh 9 for hardening
* Watch github, mangle version
2012-04-14 - David Paleino <dapal@debian.org>
node-zipfile (0.3.1+ds1-1) unstable; urgency=low
* New upstream version
* Add B-D on libuv-dev
* Bump dependency on Node >= 0.6
* Bump Standards-Version to 3.9.3, no changes needed
* Updated debian/copyright
2011-10-23 - David Paleino <dapal@debian.org>
node-zipfile (0.2.4+ds1-1) unstable; urgency=low
* Initial release (Closes: #646395)

See Also

Package Description
nodeenv_0.13.4-1_all.deb Node.js virtual environment builder
nodejs-doc_10.15.2~dfsg-1_all.deb API documentation for Node.js, the javascript platform
nodejs_10.15.2~dfsg-1_amd64.deb evented I/O for V8 javascript - runtime executable
nodeunit_0.11.2+ds3-2_all.deb Unit test framework for Node.js and the browser
nodm_0.13-4_amd64.deb automatic display manager
noiz2sa-data_0.51a-10.1_all.deb abstract arcade shooter, data files
noiz2sa_0.51a-10.1_amd64.deb abstract arcade shooter
nomacs-l10n_3.12.0+dfsg-2_all.deb image viewer with capability of syncing multiple instances (data)
nomacs_3.12.0+dfsg-2_amd64.deb image viewer with capability of syncing multiple instances
nomad_0.4.0+dfsg-1_amd64.deb distributed, highly available, datacenter-aware scheduler
nomarch_1.4-3build1_amd64.deb Unpacks .ARC and .ARK MS-DOS archives
nomnom_0.3.1-2build1_amd64.deb download videos from Youtube and other similar video websites
nootka_1.2.0-0ubuntu3_amd64.deb This package nootka provides an application to learn classical score notation
nordlicht_0.4.5-1build1_amd64.deb create colorful video barcodes
nordugrid-arc-acix-cache_5.4.3-2_all.deb ARC cache index - cache server
Advertisement
Advertisement