node-websocket_1.0.28-3_amd64.deb


Advertisement

Description

node-websocket - WebSocket implementation for NodeJS

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-websocket_1.0.28-3_amd64.deb
Package name node-websocket
Package version 1.0.28
Package release 3
Package architecture amd64
Package type deb
Category universe/web
Homepage https://github.com/theturtle32/WebSocket-Node
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.43 KB
Installed size 194.00 KB
An implementation of the WebSocket API for NodeJS.

Alternatives

Package Version Architecture Repository
node-websocket_1.0.28-3_i386.deb 1.0.28 i386 Ubuntu Universe
node-websocket - - -

Requires

Name Value
libc6 >= 2.14
libjs-websocket -
libnode64 -
libstdc++6 >= 5
node-debug -
node-typedarray-to-buffer -
nodejs >= 0.6.19~dfsg1-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-websocket_1.0.28-3_amd64.deb
Source Package node-websocket

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-websocket deb package:
    # sudo apt-get install node-websocket

Files

Path
/usr/lib/nodejs/websocket/index.js
/usr/lib/nodejs/websocket/package.json
/usr/lib/nodejs/websocket/build/Release/bufferutil.node
/usr/lib/nodejs/websocket/build/Release/validation.node
/usr/lib/nodejs/websocket/lib/BufferUtil.fallback.js
/usr/lib/nodejs/websocket/lib/BufferUtil.js
/usr/lib/nodejs/websocket/lib/Deprecation.js
/usr/lib/nodejs/websocket/lib/Validation.fallback.js
/usr/lib/nodejs/websocket/lib/Validation.js
/usr/lib/nodejs/websocket/lib/W3CWebSocket.js
/usr/lib/nodejs/websocket/lib/WebSocketClient.js
/usr/lib/nodejs/websocket/lib/WebSocketConnection.js
/usr/lib/nodejs/websocket/lib/WebSocketFrame.js
/usr/lib/nodejs/websocket/lib/WebSocketRequest.js
/usr/lib/nodejs/websocket/lib/WebSocketRouter.js
/usr/lib/nodejs/websocket/lib/WebSocketRouterRequest.js
/usr/lib/nodejs/websocket/lib/WebSocketServer.js
/usr/lib/nodejs/websocket/lib/browser.js
/usr/lib/nodejs/websocket/lib/utils.js
/usr/lib/nodejs/websocket/lib/version.js
/usr/lib/nodejs/websocket/lib/websocket.js
/usr/lib/nodejs/websocket/node_modules/yaeti/index.js
/usr/lib/nodejs/websocket/node_modules/yaeti/lib/Event.browser.js
/usr/lib/nodejs/websocket/node_modules/yaeti/lib/Event.js
/usr/lib/nodejs/websocket/node_modules/yaeti/lib/EventTarget.js
/usr/lib/nodejs/websocket/vendor/FastBufferList.js
/usr/share/doc/node-websocket/changelog.Debian.gz
/usr/share/doc/node-websocket/copyright

Changelog

2019-01-25 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.28-3) unstable; urgency=medium
* Team upload
* Fix patch, forgot to update other ports
2019-01-25 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.28-2) unstable; urgency=medium
* Add patch to increase timeouts
2019-01-24 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.28-1) unstable; urgency=medium
* Team upload
* New upstream version 1.0.28
* Section: javascript
* Update Vcs-* fields
* Use https in copyright format url
* Build against libnode-dev, using dh 10, node-gyp >= 3.8.0-2
* Build-Depends node-tape, drop node-tap patch
* Check nocheck for tests
* Drop useless get-orig-source
* Standards-Version 4.3.0
* Drop useless patches
* Patch to use a less known port for tests
(Closes: #918441,#865510)
2018-12-11 - Sam Hartman <hartmans@debian.org>
node-websocket (1.0.23-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Don't run dh_nodejs against libjs-websocket, because that is an arch
all package with no ABI dependencies.  We don't want shared library
dependencies on an arch all package because it breaks the ability to
do binary NMUs for library transitions, Closes: #877469
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.23-3) unstable; urgency=medium
* Team Upload
* Use node-websocket.install not relying upon indep target
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.23-2) unstable; urgency=medium
* Team Upload
* Override rules for arch and indep
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-websocket (1.0.23-1) unstable; urgency=medium
* Team Upload
* Imported upstream version 1.0.23
* Use dh nodejs
* Secure Vcs url
* Standards-Version 3.9.8
* MIT is Expat
* Fix order of section in copyright (general to particular)
* dh installdocs already takes care of CHANGELOG.md
* shlibdeps, strip *.node files
* Bundle yaeti as module
* Patch to run tests using tap
* Build-Depends node-tap, node-buffer-equal for tests
* Run tests during build
* Do not remove .pc on clean
2015-09-30 - Daniel Pocock <daniel@pocock.pro>
node-websocket (1.0.22-2) unstable; urgency=low
* Update libjs-websocket description.
2015-09-29 - Daniel Pocock <daniel@pocock.pro>
node-websocket (1.0.22-1) unstable; urgency=medium
* New upstream release.
* Supports node-nan >= 2.0.  (Closes: #799656)
2015-09-24 - Daniel Pocock <daniel@pocock.pro>
node-websocket (1.0.19-2) unstable; urgency=medium
* Update VCS URLs.

See Also

Package Description
node-when_3.7.8+ds-2_all.deb Async tools and when() implementation for Node.js
node-which-module_2.0.0-1_all.deb Find the module object for something that was require()d
node-which_1.3.0-2_all.deb Cross-platform 'which' module for Node.js
node-wide-align_1.1.0-1_all.deb Wide-character aware text alignment function
node-widest-line_1.2.2-1_all.deb Get the visual width of the widest line in a string -
node-wildemitter_1.2.0-1_all.deb lightweight event emitter that supports wildcard handlers
node-with_3.0.0-2_all.deb compile-time `with` statement - Node.js module
node-wordwrap_1.0.0-1_all.deb word wrapping library for NodeJS
node-wrap-ansi_4.0.0-1_all.deb Wordwrap a string with ANSI escape codes
node-wrappy_1.0.2-1_all.deb Callback wrapping utility
node-write-file-atomic_2.3.0-1_all.deb Write files in an atomic fashion w/configurable ownership
node-write-file-promise_1.0.0-1_all.deb Write a file creating intermediate directories
node-ws_1.1.0+ds1.e6ddaae4-4_amd64.deb RFC-6455 WebSocket implementation module for Node.js
node-xdg-basedir_3.0.0-1_all.deb Get XDG Base Directory paths
node-xml2js_0.2.8-1_all.deb simple XML to JavaScript object converter - Node.js module
Advertisement
Advertisement