node-wcwidth.js_1.0.0-1_all.deb


Advertisement

Description

node-wcwidth.js - wcwidth.js is a javascript porting of C's wcwidth()

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-wcwidth.js_1.0.0-1_all.deb
Package name node-wcwidth.js
Package version 1.0.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage http://code.woong.org/wcwidth.js
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.30 KB
Installed size 23.00 KB
wcwidth.js is a simple javascript porting of wcwidth()
implemented in C by Markus Kuhn.
wcwidth() and its string version, wcswidth() are defined by
IEEE Std 1002.1-2001, a.k.a. POSIX.1-2001, and return the
number of columns used to represent a wide character and
string on fixed-width output devices like terminals.
Markus's implementation assumes wide characters to be
encoded in ISO 10646, which is almost true for JavaScript;
almost because JavaScript uses UCS-2 and has problems
with surrogate pairs. wcwidth.js converts surrogate pairs
to Unicode code points to handle them correctly.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-wcwidth.js_1.0.0-1_all.deb 1.0.0 all Ubuntu Universe
node-wcwidth.js - - -

Requires

Name Value
node-defaults >= 1.0.0
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-wcwidth.js_1.0.0-1_all.deb
Source Package node-wcwidth.js

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-wcwidth.js deb package:
    # sudo apt-get install node-wcwidth.js

Files

Path
/usr/lib/nodejs/wcwidth.js/combining.js
/usr/lib/nodejs/wcwidth.js/index.js
/usr/lib/nodejs/wcwidth.js/package.json
/usr/share/doc/node-wcwidth.js/README.md.gz
/usr/share/doc/node-wcwidth.js/changelog.Debian.gz
/usr/share/doc/node-wcwidth.js/copyright

Changelog

2016-10-30 - Suhail P <psuhailp@gmail.com>
node-wcwidth.js (1.0.0-1) unstable; urgency=low
* Initial release (Closes: #842533)

See Also

Package Description
node-webfinger_0.4.2-1_all.deb Client library for Host Meta (RFC 6415) and Webfinger
node-webpack-merge_2.2.0-2_all.deb merge designed for Webpack
node-webpack-sources_1.0.1-1_all.deb Source code handling classes for webpack
node-webpack-stats-plugin_0.2.1-1_all.deb Webpack stats plugin
node-webrtc-adapter_7.2.1~ds-1_all.deb shim to insulate apps from WebRTC quirks - Node.js library
node-websocket-driver_0.3.5-1_all.deb WebSocket protocol handler with pluggable I/O for Node.js
node-websocket_1.0.28-3_amd64.deb WebSocket implementation for NodeJS
node-when_3.7.8+ds-2_all.deb Async tools and when() implementation for Node.js
node-which-module_2.0.0-1_all.deb Find the module object for something that was require()d
node-which_1.3.0-2_all.deb Cross-platform 'which' module for Node.js
node-wide-align_1.1.0-1_all.deb Wide-character aware text alignment function
node-widest-line_1.2.2-1_all.deb Get the visual width of the widest line in a string -
node-wildemitter_1.2.0-1_all.deb lightweight event emitter that supports wildcard handlers
node-with_3.0.0-2_all.deb compile-time `with` statement - Node.js module
node-wordwrap_1.0.0-1_all.deb word wrapping library for NodeJS
Advertisement
Advertisement