node-uuid_3.3.2-2_all.deb


Advertisement

Description

node-uuid - simple and fast RFC4122 UUID generation - Node.js module

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-uuid_3.3.2-2_all.deb
Package name node-uuid
Package version 3.3.2
Package release 2
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/kelektiv/node-uuid
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.05 KB
Installed size 49.00 KB
Node-uuid provides simple, fast generation of RFC4122 UUIDs.
* Generate RFC4122 version 1 or version 4 UUIDs
* Runs in Node.js and web browsers
* Cryptographically strong random number generation on supporting platforms
* Small footprint
This package provides node-uuid usable with Node.js -
an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-uuid_3.3.2-2_all.deb 3.3.2 all Ubuntu Universe
node-uuid - - -

Requires

Name Value
nodejs -

Replaces

Name Value
node-node-uuid << 3.3.2-1~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-uuid_3.3.2-2_all.deb
Source Package node-uuid

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-uuid deb package:
    # sudo apt-get install node-uuid

Files

Path
/usr/lib/nodejs/uuid/index.js
/usr/lib/nodejs/uuid/package.json
/usr/lib/nodejs/uuid/v1.js
/usr/lib/nodejs/uuid/v3.js
/usr/lib/nodejs/uuid/v4.js
/usr/lib/nodejs/uuid/v5.js
/usr/lib/nodejs/uuid/lib/bytesToUuid.js
/usr/lib/nodejs/uuid/lib/md5-browser.js
/usr/lib/nodejs/uuid/lib/md5.js
/usr/lib/nodejs/uuid/lib/rng-browser.js
/usr/lib/nodejs/uuid/lib/rng.js
/usr/lib/nodejs/uuid/lib/sha1-browser.js
/usr/lib/nodejs/uuid/lib/sha1.js
/usr/lib/nodejs/uuid/lib/v35.js
/usr/share/doc/node-uuid/README.md.gz
/usr/share/doc/node-uuid/README_js.md.gz
/usr/share/doc/node-uuid/changelog.Debian.gz
/usr/share/doc/node-uuid/copyright

Changelog

2018-09-29 - W. Martin Borgert <debacle@debian.org>
node-uuid (3.3.2-2) unstable; urgency=medium
* Team upload
* Files are installed under uuid now instead of node-uuid
2018-09-23 - W. Martin Borgert <debacle@debian.org>
node-uuid (3.3.2-1) unstable; urgency=medium
* Team upload
* New upstream version (Closes: #895625)
* Rename binary package node-node-uuid to node-uuid
* Drop binary package libjs-node-uuid
* Set Vcs fields to salsa
2018-02-01 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.4.7-5) unstable; urgency=medium
* Add autopkgtests.
Thanks to Pirate Praveen.
2018-02-01 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.4.7-4) unstable; urgency=medium
* No-opt release to fix uncoordinated problematic release.
2018-02-01 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.4.7-2) unstable; urgency=medium
* Fix symlink.
Closes: Bug#887069. Thanks to Pirate Praveen and others.
2018-01-10 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.4.7-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Modernize git-buildpackage config:
+ Drop git- prefix.
+ Filter any .git* file.
* Update watch file:
+ Limit to 1.x.
+ Bump file format to version 4.
+ Use github pattern from documentation.
+ Add usage comment.
+ Use substitution strings.
* Drop cdbs:
+ Drop upstream-tarball hints: Use gbp import-orig --uscan.
+ Stop resolve package relations in rules file.
+ Do copyright-check in maintainer script (not during build).
+ Use short-form dh sequencer (not cdbs).
+ Stop build-depend on devscripts cdbs.
* Stop build-depend on dh-buildinfo.
* Fix install nodejs code into subdirectory.
See e.g. Bug#772835.
* Fix have node-node-uuid install package.json.
* Use dephelper compatibility level 9 (not 8).
* Modernize Vcs-* fields:
+ Use protocol https (not http or git).
+ Use git (not cgit) in path.
+ Include .git suffix in path.
* Declare compliance with Debian Policy 4.1.3.
* Improve short and long descriptions.
* Use package section javascript (not web).
* Drop obsolete transitional Breaks/Conflicts/Replaces.
* Update copyright info:
+ Change main license to only Expat (from Expat or GPL.
+ Use License-Grant and License-Reference fields. Thanks to Ben Finney.
+ Extend coverage for myself.
+ Use https protocol in file format URL.
+ Rewrap using semantic newlines.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
2013-08-15 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.4.0-1) unstable; urgency=low
[ upstream ]
* New release.
+ Improved module context detection.
+ Removed public RNG functions.
[ Jonas Smedegaard ]
* Update rules files to directly use github.com URL (not
githubredir.debian.net).
* Extend copyright coverage for main upstream author to include recent
years.
2013-06-14 - Jonas Smedegaard <dr@jones.dk>
node-uuid (1.3.3-2) unstable; urgency=low
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Stop tracking md5sum of upstream tarball.
* Bump dephelper compatibility level to 8.
* Bump standards-version to 3.9.4.
* Use canonical host (anonscm.debian.org) in Vcs-* URIs.
* Build-depend on devscripts, to enable copyright check
unconditionally: Needed version satisfied even in oldstable.
* Bump packaging license to GPL-3+, and extend copyrigt coverage for
myself to include recent years.
* Update copyright file:
+ Fix use comment and license pseudo-sections in copyright file to
obey silly restrictions of copyright format 1.0.
+ Fix mention correct version of GPL in licensing comment.
+ Quote license in licensing comment.
+ Bump file format to 1.0.
* Update watch file to directly track github URL (drop
githubredir.debian.net proxy).
* Have git-import-orig filter-out .gitignore files.

See Also

Package Description
node-v8flags_3.1.2-3_all.deb Get available V8 JavaScript engine flags
node-vali-date_1.0.0-1_all.deb Validate a date
node-validate-npm-package-license_3.0.1-1_all.deb Tells if a string is a valid npm package license string
node-validate-npm-package-name_3.0.0-1_all.deb Checks if a string is a valid npm package name
node-validator_4.7.1+dfsg1-1.1_all.deb Javascript string validation and sanitization for Node.js
node-vary_1.1.2-1_all.deb manage the Vary header of a HTTP response - Node.js module
node-verror_1.10.0-1_all.deb rich JavaScript errors
node-vhost_3.0.2-1_all.deb connect middleware for domain request matching - Node.js module
node-vinyl-fs_2.4.4-1_all.deb Vinyl adapter for the file system
node-vinyl-sourcemaps-apply_0.2.1-1_all.deb Apply a source map to a vinyl file
node-vinyl_2.0.1-1_all.deb Virtual file format
node-vlq_1.0.0-3_all.deb Variable-length quantity mapper for Node.js
node-vm-browserify_0.0.4-1_all.deb vm module for the browser
node-vows_0.8.1-3_all.deb asynchronous BDD & continuous integration for Node
node-vue-hot-reload-api_2.3.0-1_all.deb hot reload api for *.vue components
Advertisement
Advertisement