node-security_1.0.0-1_all.deb


Advertisement

Description

node-security - Safely encoding and decoding methods for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-security_1.0.0-1_all.deb
Package name node-security
Package version 1.0.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/cweider/js-security
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.59 KB
Installed size 23.00 KB
Safely encode/decode HTML, Javascript and CSS data compliant to the standard
as demanded by the OWASP (Open Web Application Security Project) when using
Node.js.

Alternatives

Package Version Architecture Repository
node-security_1.0.0-1_all.deb 1.0.0 all Ubuntu Universe
node-security - - -

Requires

Name Value
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-security_1.0.0-1_all.deb
Source Package node-security

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-security deb package:
    # sudo apt-get install node-security

Files

Path
/usr/lib/nodejs/security/index.js
/usr/lib/nodejs/security/package.json
/usr/share/doc/node-security/README.md
/usr/share/doc/node-security/changelog.Debian.gz
/usr/share/doc/node-security/copyright
/usr/share/doc/node-security/package.json
/usr/share/doc/node-security/test/test.js

Changelog

2019-02-05 - Xavier Guimard <yadd@debian.org>
node-security (1.0.0-1) unstable; urgency=medium
[ Mike Gabriel ]
* debian/control: Drop myself from Uploaders: field.
[ Xavier Guimard ]
* Add upstream/metadata
* Bump debhelper compatibility level to 11
* Declare compliance with policy 4.3.0
* Change section to javascript
* Change priority to optional
* Update debian/watch
* New upstream version 1.0.0
* Add myself to uploaders (Closes: #921359)
* Update VCS fields to salsa
* Update debian/copyright
* Add tests based on pkg-js-tools
* Fix install
* Add mocha in build dependencies
* Hide false positive lintian error
2014-05-14 - Mike Gabriel <sunweaver@debian.org>
node-security (1.0.0~git20130515-2) unstable; urgency=low
* debian/docs:
+ Install package.json into doc folder.
* debian/control:
+ Add D (bin:package node-security): nodejs. (Closes: #747661).
+ Alioth-canonicalize Vcs-*: fields.
+ Bump Standards: to 3.9.5. No changes needed.
2013-05-15 - Mike Gabriel <sunweaver@debian.org>
node-security (1.0.0~git20130515-1) unstable; urgency=low
* Initial release. (Closes: #707640). Obtained from upstream Git,
corresponding to commit: 199356533633216ffa47981b8ccf132b9fa074aa.

See Also

Package Description
node-seedrandom_2.4.3+dfsg-1_all.deb Seeded random number generator for Javascript
node-sellside-emitter_1.2.1-2_all.deb Event emitter for node.js projects
node-semver-diff_2.1.0-2_all.deb get the diff type of two semver versions
node-semver_5.5.1-1_all.deb Semantic Versioning for Node.js
node-send_0.16.2-1_all.deb Static file server with ranges and negotiation support for Node.js
node-seq_0.3.5-2_all.deb Chainable asynchronous flow control
node-sequencify_0.0.7-1_all.deb module for sequencing tasks and dependencies
node-serve-favicon_2.1.5-1_all.deb favicon serving middleware with caching - Node.js module
node-serve-index_1.9.1-1_all.deb directory listings middleware for Node.js
node-serve-static_1.6.4-2_all.deb static files server module for Node.js
node-set-blocking_2.0.0-1_all.deb set blocking stdio and stderr
node-set-getter_0.1.0-1_all.deb Create nested getter properties and any intermediary dot notation
node-set-immediate-shim_1.0.1-1_all.deb Simple setImmediate shim
node-set-value_0.4.0-1_all.deb create nested values and any intermediaries using dot notation
node-setimmediate_1.0.5-4_all.deb shim for the setImmediate efficient script yielding API
Advertisement
Advertisement