node-require-dir_1.0.0-1_all.deb


Advertisement

Description

node-require-dir - helper to require() directories

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-require-dir_1.0.0-1_all.deb
Package name node-require-dir
Package version 1.0.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/aseemk/requireDir
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.20 KB
Installed size 21.00 KB
Node helper to require() directories. The directory's files are examined,
and each one that can be require()'d is require()'d and returned as part
of a hash from that file's basename to its exported contents.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-require-dir_1.0.0-1_all.deb 1.0.0 all Ubuntu Universe
node-require-dir - - -

Requires

Name Value
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-require-dir_1.0.0-1_all.deb
Source Package node-require-dir

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-require-dir deb package:
    # sudo apt-get install node-require-dir

Files

Path
/usr/lib/nodejs/require-dir/index.js
/usr/lib/nodejs/require-dir/package.json
/usr/share/doc/node-require-dir/README.md.gz
/usr/share/doc/node-require-dir/changelog.Debian.gz
/usr/share/doc/node-require-dir/copyright

Changelog

2018-03-01 - Pirate Praveen <praveen@debian.org>
node-require-dir (1.0.0-1) unstable; urgency=medium
* Team upload
* New upstream version 1.0.0
* Bump debhelper compat to 11
* Bump standards version to 4.1.3
* Change section to javascript
* Enable tests
2016-11-05 - Thorsten Alteholz <debian@alteholz.de>
node-require-dir (0.3.1-1) unstable; urgency=medium
* new upstream version
* debian/control: bump version to 3.9.8 (no changes)
2016-03-05 - Thorsten Alteholz <debian@alteholz.de>
node-require-dir (0.3.0-1) unstable; urgency=medium
* Initial release

See Also

Package Description
node-require-directory_2.1.1-1_all.deb require all files in a directory
node-require-from-string_2.0.1-1_all.deb Require module from string
node-require-inject_1.4.0-1_all.deb simple mock injector
node-require-main-filename_1.0.1-1_all.deb shim for require.main.filename() that works in as many environments as possible
node-require-relative_0.8.7-2_all.deb Relative require module import for Node.js
node-requirejs-text_2.0.12-2_all.deb RequireJS/AMD loader plugin for text resources
node-requirejs_2.3.6-1_all.deb JavaScript file and module loader - NodeJS
node-requires-port_1.0.0-1_all.deb checks if a protocol requires a certain port number to be added to an URL
node-reserved_0.1.2+20140511-3_all.deb List of JavaScript reserved words (Node.js module)
node-resolve-cwd_2.0.0-2_all.deb Resolve the path of a module from current directory
node-resolve-dir_1.0.1-2_all.deb Resolve a directory
node-resolve-from_4.0.0-1_all.deb Resolve the path of a module from a given path
node-resolve-pkg_0.2.0-1_all.deb Resolve the path of a package regardless of it having an entry point
node-resolve_1.5.0-1_all.deb Synchronous/Asynchronous require.resolve() algorithm
node-response-time_2.2.0-1_all.deb X-Response-Time header manager for HTTP response - Node.js module
Advertisement
Advertisement