node-request_2.88.1-2_all.deb


Advertisement

Description

node-request - simplified HTTP request client module for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-request_2.88.1-2_all.deb
Package name node-request
Package version 2.88.1
Package release 2
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/mikeal/request
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.68 KB
Installed size 163.00 KB
node-request is an HTTP client with a simple API and a lot of features:
* streaming response
* multipart form upload
* HTTP auth
* OAuth signing
* Proxy
Some features are available as suggested Node.js modules.
Node.js is an event-based server-side javascript engine.

Alternatives

Package Version Architecture Repository
node-request_2.88.1-2_all.deb 2.88.1 all Ubuntu Universe
node-request - - -

Requires

Name Value
node-aws-sign2 >= 0.7~
node-aws4 >= 1.8~
node-caseless >= 0.12~
node-combined-stream >= 1.0.6~
node-extend >= 3.0.2~
node-forever-agent >= 0.6.1~
node-form-data >= 2.3.2~
node-har-validator >= 5.1~
node-http-signature >= 1.2~
node-is-typedarray >= 1.0~
node-isstream >= 0.1.2~
node-json-stringify-safe >= 5.0.1~
node-mime-types >= 2.1.19~
node-node-uuid -
node-oauth-sign >= 0.9~
node-performance-now >= 2.1~
node-qs >= 6.5.2~
node-safe-buffer >= 5.1.2~
node-tough-cookie -
node-tunnel-agent >= 0.6~
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-request_2.88.1-2_all.deb
Source Package node-request

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-request deb package:
    # sudo apt-get install node-request

Files

Path
/usr/lib/nodejs/request/index.js
/usr/lib/nodejs/request/package.json
/usr/lib/nodejs/request/request.js
/usr/lib/nodejs/request/lib/auth.js
/usr/lib/nodejs/request/lib/cookies.js
/usr/lib/nodejs/request/lib/getProxyFromURI.js
/usr/lib/nodejs/request/lib/har.js
/usr/lib/nodejs/request/lib/hawk.js
/usr/lib/nodejs/request/lib/helpers.js
/usr/lib/nodejs/request/lib/multipart.js
/usr/lib/nodejs/request/lib/oauth.js
/usr/lib/nodejs/request/lib/querystring.js
/usr/lib/nodejs/request/lib/redirect.js
/usr/lib/nodejs/request/lib/tunnel.js
/usr/lib/nodejs/request/node_modules/uuid/AUTHORS
/usr/lib/nodejs/request/node_modules/uuid/CHANGELOG.md
/usr/lib/nodejs/request/node_modules/uuid/LICENSE.md
/usr/lib/nodejs/request/node_modules/uuid/README.md
/usr/lib/nodejs/request/node_modules/uuid/README_js.md
/usr/lib/nodejs/request/node_modules/uuid/index.js
/usr/lib/nodejs/request/node_modules/uuid/package.json
/usr/lib/nodejs/request/node_modules/uuid/v1.js
/usr/lib/nodejs/request/node_modules/uuid/v3.js
/usr/lib/nodejs/request/node_modules/uuid/v4.js
/usr/lib/nodejs/request/node_modules/uuid/v5.js
/usr/lib/nodejs/request/node_modules/uuid/bin/uuid
/usr/lib/nodejs/request/node_modules/uuid/lib/bytesToUuid.js
/usr/lib/nodejs/request/node_modules/uuid/lib/md5-browser.js
/usr/lib/nodejs/request/node_modules/uuid/lib/md5.js
/usr/lib/nodejs/request/node_modules/uuid/lib/rng-browser.js
/usr/lib/nodejs/request/node_modules/uuid/lib/rng.js
/usr/lib/nodejs/request/node_modules/uuid/lib/sha1-browser.js
/usr/lib/nodejs/request/node_modules/uuid/lib/sha1.js
/usr/lib/nodejs/request/node_modules/uuid/lib/v35.js
/usr/share/doc/node-request/changelog.Debian.gz
/usr/share/doc/node-request/copyright

Changelog

2018-09-30 - Pirate Praveen <praveen@debian.org>
node-request (2.88.1-2) unstable; urgency=medium
* Add require test during build (all ruby packages have this and its useful
in backporting - saves manually verifying the dependencies).
2018-09-19 - Pirate Praveen <praveen@debian.org>
node-request (2.88.1-1) unstable; urgency=medium
* New upstream version 2.88.1 (Closes: #844072)
* Remove gbp.conf as we can directly use unmodified upstream tarballs
* Use salsa.debian.org in Vcs-* fields
* Bump debhelper compatibility level to 11
* Bump Standards-Version to 4.2.1 (no changes needed)
* Change section to javascript and priority to optional
* Switch to dh sequence
2013-08-15 - Jérémy Lal <kapouer@melix.org>
node-request (2.26.1-1) unstable; urgency=low
* Upstream update.
* control:
+ canonicalize Vcs fields
+ upstream has split request in several submodules, depend on them
+ auth modules should be optional, suggest them.
+ Standards-Version bumped to 3.9.4, no changes needed
* copyright:
+ rename MIT license to Expat license
+ add Upstream-Contact field
* 1001 patch : lazy load auth modules, forwarded upstream
[ Jonas Smedegaard ]
* Repackage using CDBS.
2012-03-17 - David Paleino <dapal@debian.org>
node-request (2.9.153-1) unstable; urgency=low
[ Jérémy Lal ]
* New upstream version
[ David Paleino ]
* Standards-Version bumped to 3.9.3, no changes needed
* Updated debian/copyright
* Added Jérémy to Uploaders
2011-12-31 - David Paleino <dapal@debian.org>
node-request (2.9.3-1) unstable; urgency=low
* New upstream version
2011-11-23 - David Paleino <dapal@debian.org>
node-request (2.2.5-2) unstable; urgency=low
* Install missing vendor/ directory, and update copyright to include
it.
2011-11-17 - David Paleino <dapal@debian.org>
node-request (2.2.5-1) unstable; urgency=low
* New upstream release
* Also install oauth.js and uuid.js
2011-10-16 - David Paleino <dapal@debian.org>
node-request (2.1.1-1) unstable; urgency=low
* Initial release (Closes: #645520)

See Also

Package Description
node-require-all_3.0.0-1_all.deb Require all Node.js module files within a directory
node-require-dir_1.0.0-1_all.deb helper to require() directories
node-require-directory_2.1.1-1_all.deb require all files in a directory
node-require-from-string_2.0.1-1_all.deb Require module from string
node-require-inject_1.4.0-1_all.deb simple mock injector
node-require-main-filename_1.0.1-1_all.deb shim for require.main.filename() that works in as many environments as possible
node-require-relative_0.8.7-2_all.deb Relative require module import for Node.js
node-requirejs-text_2.0.12-2_all.deb RequireJS/AMD loader plugin for text resources
node-requirejs_2.3.6-1_all.deb JavaScript file and module loader - NodeJS
node-requires-port_1.0.0-1_all.deb checks if a protocol requires a certain port number to be added to an URL
node-reserved_0.1.2+20140511-3_all.deb List of JavaScript reserved words (Node.js module)
node-resolve-cwd_2.0.0-2_all.deb Resolve the path of a module from current directory
node-resolve-dir_1.0.1-2_all.deb Resolve a directory
node-resolve-from_4.0.0-1_all.deb Resolve the path of a module from a given path
node-resolve-pkg_0.2.0-1_all.deb Resolve the path of a package regardless of it having an entry point
Advertisement
Advertisement