node-regjsparser_0.6.0+ds-1_all.deb


Advertisement

Description

node-regjsparser - Parser for JavaScript's RegExp for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-regjsparser_0.6.0+ds-1_all.deb
Package name node-regjsparser
Package version 0.6.0+ds
Package release 1
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/jviereck/regjsparser
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 15.86 KB
Installed size 73.00 KB
This module provides a parser for the JavaScript's RegExp, itself written
in Javascript.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-regjsparser_0.6.0+ds-1_all.deb 0.6.0+ds all Ubuntu Universe
node-regjsparser - - -

Requires

Name Value
node-jsesc >= 0.5.0
nodejs >= 6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-regjsparser_0.6.0+ds-1_all.deb
Source Package node-regjsparser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-regjsparser deb package:
    # sudo apt-get install node-regjsparser

Files

Path
/usr/bin/regjsparser
/usr/lib/nodejs/regjsparser/package.json
/usr/lib/nodejs/regjsparser/parser.js
/usr/lib/nodejs/regjsparser/bin/parser
/usr/share/doc/node-regjsparser/README.md
/usr/share/doc/node-regjsparser/changelog.Debian.gz
/usr/share/doc/node-regjsparser/copyright
/usr/share/doc/node-regjsparser/examples/index.html
/usr/share/doc/node-regjsparser/examples/parser.js
/usr/share/doc/node-regjsparser/examples/demo/main.js
/usr/share/doc/node-regjsparser/examples/demo/styles.css
/usr/share/man/man1/regjsparser.1.gz

Changelog

2018-12-07 - Julien Puydt <jpuydt@debian.org>
node-regjsparser (0.6.0+ds-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
2018-11-29 - Julien Puydt <jpuydt@debian.org>
node-regjsparser (0.5.1+ds-1) unstable; urgency=medium
* New upstream release.
2018-09-13 - Julien Puydt <jpuydt@debian.org>
node-regjsparser (0.4.0+ds-2) unstable; urgency=medium
* Build-depend on node-unicode-11.0.0 (Closes: #908213).
2018-09-01 - Julien Puydt <jpuydt@debian.org>
node-regjsparser (0.4.0+ds-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
- Use my debian.org mail address.
- Bump dh compat to 11. 
- Point Vcs-* fields to salsa. 
- Bump std-ver to 4.2.1. 
2018-02-20 - Julien Puydt <julien.puydt@laposte.net>
node-regjsparser (0.3.0+ds-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
- Bump std-ver to 4.1.3.
- Refresh d/copyright.
- Refresh patches.
2017-10-10 - Julien Puydt <julien.puydt@laposte.net>
node-regjsparser (0.2.1+ds-3) unstable; urgency=medium
* Fix the simple autopkgtest
* Bump std-ver to 4.1.1.
2017-09-26 - Pirate Praveen <praveen@debian.org>
node-regjsparser (0.2.1+ds-2) unstable; urgency=medium
[ Daniel Ring ]
* Fix regex substitution in build process
2017-08-20 - Julien Puydt <julien.puydt@laposte.net>
node-regjsparser (0.2.1+ds-1) unstable; urgency=low
* Initial release (Closes: #872737)

See Also

Package Description
node-reinterval_1.1.0-1_all.deb reschedulable setInterval for node.js
node-remove-trailing-separator_1.0.1-1_all.deb Removes separators from the end of the string
node-repeat-element_1.1.2+github-2_all.deb create an array by repeating the given value n times
node-repeat-string_1.6.1-1_all.deb repeat the given string n times
node-repeating_3.0.0-1_all.deb Repeat a string - fast
node-replace-ext_1.0.0-1_all.deb Replaces a file extension with another one
node-request-capture-har_1.2.2-1_all.deb Save all traffic as a HAR file
node-request_2.88.1-2_all.deb simplified HTTP request client module for Node.js
node-require-all_3.0.0-1_all.deb Require all Node.js module files within a directory
node-require-dir_1.0.0-1_all.deb helper to require() directories
node-require-directory_2.1.1-1_all.deb require all files in a directory
node-require-from-string_2.0.1-1_all.deb Require module from string
node-require-inject_1.4.0-1_all.deb simple mock injector
node-require-main-filename_1.0.1-1_all.deb shim for require.main.filename() that works in as many environments as possible
node-require-relative_0.8.7-2_all.deb Relative require module import for Node.js
Advertisement
Advertisement