node-raw-body_2.3.3-3_all.deb


Advertisement

Description

node-raw-body - Request body length validation supporting streams - Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-raw-body_2.3.3-3_all.deb
Package name node-raw-body
Package version 2.3.3
Package release 3
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/stream-utils/raw-body
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.27 KB
Installed size 26.00 KB
This module gets the entire buffer of a stream and validates its length
against an expected length. A limit can also be set, preventing memory
exhaustion. It is useful for parsing request bodies.
Node.js is an event-based server-side javascript engine.

Alternatives

Package Version Architecture Repository
node-raw-body_2.3.3-3_all.deb 2.3.3 all Ubuntu Universe
node-raw-body - - -

Requires

Name Value
node-bytes >= 3.0.0
node-http-errors >= 1.6.0
node-iconv >= 2
node-unpipe >= 1.0.0
nodejs -

Provides

Name Value
nodetypes-raw-body = 2.3.3-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-raw-body_2.3.3-3_all.deb
Source Package node-raw-body

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-raw-body deb package:
    # sudo apt-get install node-raw-body

Files

Path
/usr/lib/nodejs/raw-body/index.d.ts
/usr/lib/nodejs/raw-body/index.js
/usr/lib/nodejs/raw-body/package.json
/usr/share/doc/node-raw-body/README.md.gz
/usr/share/doc/node-raw-body/changelog.Debian.gz
/usr/share/doc/node-raw-body/copyright

Changelog

2019-01-07 - Jérémy Lal <kapouer@melix.org>
node-raw-body (2.3.3-3) unstable; urgency=medium
* Restore master without applied patches
* Set longer timeout for tests (Closes: #862496)
* Standards-Version: 4.3.0
2018-06-26 - Bastien Roucariès <rouca@debian.org>
node-raw-body (2.3.3-2) unstable; urgency=medium
* Fix CI
2018-06-20 - Bastien Roucariès <rouca@debian.org>
node-raw-body (2.3.3-1) unstable; urgency=medium
* Team upload
* New upstream version
* Refresh patches
* Move to section javascript
* Bump compat and policy
* Run CI
2014-06-17 - Jérémy Lal <kapouer@melix.org>
node-raw-body (1.2.0-1) unstable; urgency=medium
* Imported Upstream version 1.2.0
* Build-Depends: add binaries from Depends, and required packages
for running tests.
* Enable tests during build, add patch to workaround unneeded
readable-stream dependency.
* Patch to use iconv API instead of iconv-lite API
* Depends node-bytes, node-iconv
2013-10-26 - Jérémy Lal <kapouer@melix.org>
node-raw-body (0.0.3-1) unstable; urgency=low
* Initial release (Closes: #727795)

See Also

Package Description
node-raw-loader_0.5.1-3_all.deb raw loader module for webpack
node-rbush_2.0.2-3_all.deb High-performance 2D spatial index for rectangles
node-rc_1.1.6-2_all.deb find, load, flatten json or ini application configuration
node-rdf-canonize_1.0.2-1_all.deb RDF Dataset Normalization Algorithm - Node library
node-read-file_0.2.0-1_all.deb wrapper around fs.readFile and fs.readFileSync
node-read-only-stream_2.0.0-2_all.deb Node.js read-only stream implementation
node-read-package-json_2.0.13-1_all.deb Read package.json for npm module for Node.js
node-read-pkg-up_2.0.0-1_all.deb Read the closest package.json file
node-read-pkg_2.0.0-1_all.deb Read a package.json file
node-read_1.0.7-1_all.deb Read user input from stdin module for Node.js
node-readable-stream_2.3.6-1_all.deb stream compatibility library for Node.js and browser
node-readdirp_2.1.0-4_all.deb Recursive version of Node.js's fs.readdir
node-recast_0.16.1-1_all.deb Pretty printer and syntax tree transformer for JavaScript
node-rechoir_0.6.2-1_all.deb require any supported file as a node module
node-redent_2.0.0-1_all.deb Strip redundant indentation and indent the string
Advertisement
Advertisement