node-pumpify_1.5.1-1_all.deb


Advertisement

Description

node-pumpify - combine streams into a single duplex stream by pump and duplexify

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-pumpify_1.5.1-1_all.deb
Package name node-pumpify
Package version 1.5.1
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/mafintosh/pumpify
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.25 KB
Installed size 17.00 KB
Combine an array of streams into a single duplex stream using pump and
duplexify. If one of the streams closes/errors all streams in the pipeline
will be destroyed.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-pumpify_1.5.1-1_all.deb 1.5.1 all Ubuntu Universe
node-pumpify - - -

Requires

Name Value
node-duplexify >= 3.6.1
node-inherits -
node-pump -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-pumpify_1.5.1-1_all.deb
Source Package node-pumpify

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-pumpify deb package:
    # sudo apt-get install node-pumpify

Files

Path
/usr/lib/nodejs/pumpify/index.js
/usr/lib/nodejs/pumpify/package.json
/usr/share/doc/node-pumpify/README.md
/usr/share/doc/node-pumpify/changelog.Debian.gz
/usr/share/doc/node-pumpify/copyright

Changelog

2019-01-21 - Xavier Guimard <yadd@debian.org>
node-pumpify (1.5.1-1) unstable; urgency=medium
[ Utkarsh Gupta ]
* Team upload
* New upstream version 1.5.1
* Bump debhelper compatibility level to 11
* Bump Standards-Version to 4.3.0 (no changes needed)
* Update URL in Vcs-* field
* Update d/copyright
* Update d/rules
* Add upstream test in autopkgtest
* Add d/upstream/metadata
* Update d/control to add build dependencies
[ Xavier Guimard ]
* Enable tape test
* Update node-duplexify dependency to (>= 3.6.1) due to nodejs stream
changes
* Remove useless versioned dependencies
2017-07-19 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
node-pumpify (1.3.5-1) unstable; urgency=low
* Initial release (Closes: #868829)

See Also

Package Description
node-punycode_2.1.1-2_all.deb Nodejs robust Punycode converter fully RFC compliant
node-q_1.5.1-1_all.deb Node.js module for promises (CommonJS/Promises/A,B,D)
node-qs_6.5.2-1_all.deb Parse, stringify query strings for Node.js
node-querystring-es3_0.2.1-1_all.deb Node's querystring module for all engines (ES3 compat fork)
node-querystring_0.2.0-2_all.deb Node's querystring module for all engines
node-querystringify_0.0.4-1_all.deb Querystringify - Small, simple but powerful query string parser
node-queue-async_1.0.7-1_all.deb asynchronous helper library for JavaScript - NodeJS
node-quick-lru_1.1.0-2_all.deb Simple "Least Recently Used" (LRU) cache
node-quickselect_1.0.1-3_all.deb JavaScript selection algorithm
node-quote-stream_1.0.2-5_all.deb transform a stream into a quoted string
node-qw_1.0.1-1_all.deb Quoted word literals
node-rai_0.1.12-3_all.deb Request-Answer-Interface for generating text based command servers (SMTP,POP)
node-ramda_0.26.1+dfsg-2_all.deb practical functional library for JavaScript programmers
node-random-bytes_1.0.0-1_all.deb generate strong pseudo-random bytes
node-randombytes_2.0.6-1_all.deb random bytes from browserify stand alone
Advertisement
Advertisement