node-postcss_6.0.23-1_all.deb


Advertisement

Description

node-postcss - Tool for transforming styles with JS plugins

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-postcss_6.0.23-1_all.deb
Package name node-postcss
Package version 6.0.23
Package release 1
Package architecture all
Package type deb
Category universe/javascript
Homepage http://postcss.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 159.11 KB
Installed size 800.00 KB
These plugins can lint your CSS, support variables and mixins, transpile
future CSS syntax, inline images, and more.
PostCSS is used by industry leaders including Wikipedia, Twitter, Alibaba,
and JetBrains. The [Autoprefixer] PostCSS plugin is one of the most popular
CSS processors.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-postcss_6.0.23-1_all.deb 6.0.23 all Ubuntu Universe
node-postcss - - -

Requires

Name Value
node-chalk >= 2.3.0
node-source-map >= 0.6.1
node-supports-color >= 4.4.0
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-postcss_6.0.23-1_all.deb
Source Package node-postcss

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-postcss deb package:
    # sudo apt-get install node-postcss

Files

Path
/usr/lib/nodejs/postcss/package.json
/usr/lib/nodejs/postcss/lib/at-rule.es6
/usr/lib/nodejs/postcss/lib/at-rule.js
/usr/lib/nodejs/postcss/lib/comment.es6
/usr/lib/nodejs/postcss/lib/comment.js
/usr/lib/nodejs/postcss/lib/container.es6
/usr/lib/nodejs/postcss/lib/container.js
/usr/lib/nodejs/postcss/lib/css-syntax-error.es6
/usr/lib/nodejs/postcss/lib/css-syntax-error.js
/usr/lib/nodejs/postcss/lib/declaration.es6
/usr/lib/nodejs/postcss/lib/declaration.js
/usr/lib/nodejs/postcss/lib/input.es6
/usr/lib/nodejs/postcss/lib/input.js
/usr/lib/nodejs/postcss/lib/lazy-result.es6
/usr/lib/nodejs/postcss/lib/lazy-result.js
/usr/lib/nodejs/postcss/lib/list.es6
/usr/lib/nodejs/postcss/lib/list.js
/usr/lib/nodejs/postcss/lib/map-generator.es6
/usr/lib/nodejs/postcss/lib/map-generator.js
/usr/lib/nodejs/postcss/lib/node.es6
/usr/lib/nodejs/postcss/lib/node.js
/usr/lib/nodejs/postcss/lib/parse.es6
/usr/lib/nodejs/postcss/lib/parse.js
/usr/lib/nodejs/postcss/lib/parser.es6
/usr/lib/nodejs/postcss/lib/parser.js
/usr/lib/nodejs/postcss/lib/postcss.d.ts
/usr/lib/nodejs/postcss/lib/postcss.es6
/usr/lib/nodejs/postcss/lib/postcss.js
/usr/lib/nodejs/postcss/lib/previous-map.es6
/usr/lib/nodejs/postcss/lib/previous-map.js
/usr/lib/nodejs/postcss/lib/processor.es6
/usr/lib/nodejs/postcss/lib/processor.js
/usr/lib/nodejs/postcss/lib/result.es6
/usr/lib/nodejs/postcss/lib/result.js
/usr/lib/nodejs/postcss/lib/root.es6
/usr/lib/nodejs/postcss/lib/root.js
/usr/lib/nodejs/postcss/lib/rule.es6
/usr/lib/nodejs/postcss/lib/rule.js
/usr/lib/nodejs/postcss/lib/stringifier.es6
/usr/lib/nodejs/postcss/lib/stringifier.js
/usr/lib/nodejs/postcss/lib/stringify.es6
/usr/lib/nodejs/postcss/lib/stringify.js
/usr/lib/nodejs/postcss/lib/terminal-highlight.es6
/usr/lib/nodejs/postcss/lib/terminal-highlight.js
/usr/lib/nodejs/postcss/lib/tokenize.es6
/usr/lib/nodejs/postcss/lib/tokenize.js
/usr/lib/nodejs/postcss/lib/vendor.es6
/usr/lib/nodejs/postcss/lib/vendor.js
/usr/lib/nodejs/postcss/lib/warn-once.es6
/usr/lib/nodejs/postcss/lib/warn-once.js
/usr/lib/nodejs/postcss/lib/warning.es6
/usr/lib/nodejs/postcss/lib/warning.js
/usr/share/doc/node-postcss/README-cn.md.gz
/usr/share/doc/node-postcss/README.md.gz
/usr/share/doc/node-postcss/changelog.Debian.gz
/usr/share/doc/node-postcss/copyright
/usr/share/doc/node-postcss/docs/api.md
/usr/share/doc/node-postcss/docs/architecture.md.gz
/usr/share/doc/node-postcss/docs/plugins.md.gz
/usr/share/doc/node-postcss/docs/source-maps.md
/usr/share/doc/node-postcss/docs/syntax.md.gz
/usr/share/doc/node-postcss/docs/writing-a-plugin.md
/usr/share/doc/node-postcss/docs/guidelines/plugin.md.gz
/usr/share/doc/node-postcss/docs/guidelines/runner.md.gz

Changelog

2018-11-10 - Pirate Praveen <praveen@debian.org>
node-postcss (6.0.23-1) unstable; urgency=medium
* New upstream version 6.0.23
* Use salsa.debian.org in Vcs-* fields
* Bump Standards-Version to 4.2.1 (no changes needed)
* Bump debhelper compatibility level to 11
2018-01-19 - Pirate Praveen <praveen@debian.org>
node-postcss (6.0.16-1) unstable; urgency=medium
* New upstream release
* Embed new build dependencies
* Use gulp directly to build
2017-10-19 - Pirate Praveen <praveen@debian.org>
node-postcss (6.0.11-2) unstable; urgency=medium
* Move to main, all dependencies are in archive now
* babel command is now babeljs
2017-09-08 - Pirate Praveen <praveen@debian.org>
node-postcss (6.0.11-1) unstable; urgency=low
* Initial release (Closes: #874668)

See Also

Package Description
node-pre-gyp_0.10.2-3_all.deb Native addon deployment tool for Node.js
node-preact_8.2.5-1_all.deb React alternative with the same ES6 API
node-prelude-ls_1.1.2+dfsg-3_all.deb functionally oriented utility library
node-prepend-http_2.0.0-1_all.deb Prepend `http://` to humanized URLs like todomvc.com and localhost
node-preserve_0.2.0-1_all.deb Protect tokens from being mutated when the string is transformed
node-pretty-bytes_4.0.2-2_all.deb Convert bytes to a human readable string
node-pretty-hrtime_1.0.3-1_all.deb process.hrtime() to words
node-pretty-ms_3.2.0-1_all.deb Convert milliseconds to a human readable string
node-private_0.1.8-3_all.deb Utility for associating truly private state with any JavaScript object
node-process-nextick-args_2.0.0-1_all.deb process.nextTick but always with args
node-process_0.11.10-2_all.deb process information for node.js and browsers
node-progress_1.1.8-1_all.deb Flexible ascii progress bar
node-proj4_2.3.17+ds-1_all.deb Node.js module to transform point coordinates systems
node-promise-inflight_1.0.1-1_all.deb one promise for multiple requests in flight to avoid async duplication
node-promise-retry_1.1.1-2_all.deb Retries a function that returns a promise
Advertisement
Advertisement