node-nomnom_1.8.1-1_all.deb


Advertisement

Description

node-nomnom - Option parser with generated usage and commands for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-nomnom_1.8.1-1_all.deb
Package name node-nomnom
Package version 1.8.1
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/harthur/nomnom
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 9.27 KB
Installed size 30.00 KB
nomnom is an option parser for Node.js. It noms your args and gives them
back to you in a hash.
Nomnom supports args like -d, --debug, --no-debug, --file=test.txt,
--file test.txt, -f test.txt, -xvf, and positionals. Positionals are
arguments that don't fit the -a or --atomic format and aren't attached
to an option.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-nomnom_1.8.1-1_all.deb 1.8.1 all Ubuntu Universe
node-nomnom - - -

Requires

Name Value
node-chalk -
node-underscore -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-nomnom_1.8.1-1_all.deb
Source Package node-nomnom

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-nomnom deb package:
    # sudo apt-get install node-nomnom

Files

Path
/usr/lib/nodejs/nomnom/nomnom.js
/usr/lib/nodejs/nomnom/package.json
/usr/share/doc/node-nomnom/README.md.gz
/usr/share/doc/node-nomnom/changelog.Debian.gz
/usr/share/doc/node-nomnom/copyright

Changelog

2016-07-18 - Mathias Behrle <mbehrle@debian.org>
node-nomnom (1.8.1-1) unstable; urgency=low
[ Bas Couwenberg ]
* Initial release (Closes: #774567)
* Remove myself from Uploaders.
[ Ross Gammon ]
* Update control file and add myself as uploader
* Always sign tags
* Explain the use of fakeupstream
* Fix underscore package name
* Remove build target & add comment to test target in debian/rules
[ Mathias Behrle ]
* Removing unused Build-Dependencies.
* Updating to Standards-Version 3.9.8, no changes needed.
* Removing versioned Depends.
* Putting myself in Uploaders according to #774567.
* Adding myself to debian copyright.
* Running wrap-and-sort -sta.

See Also

Package Description
node-nopt_3.0.6-3_all.deb Command-line option parser for Node.js
node-normalize-git-url_3.0.1-1_all.deb normalizes Git URLs
node-normalize-package-data_2.4.0-1_all.deb Normalizes package metadata - Node.js module
node-normalize-path_2.0.1-2_all.deb Normalize file path slashes to be unix-like forward slashes
node-normalize-range_0.1.2-1_all.deb Utility for normalizing a numeric range
node-normalize.css_8.0.1-3_all.deb Modern alternative to CSS resets
node-npm-bundled_1.0.3-1_all.deb Parses info on bundled dependencies
node-npm-package-arg_6.0.0-2_all.deb Parse the things that can be arguments to npm install
node-npm-run-path_2.0.2-2_all.deb Get your PATH prepended with locally installed binaries
node-npmlog_4.1.2-1_all.deb Logger with custom levels and colored output for Node.js
node-npmrc_1.1.1-1_all.deb Switch between different .npmrc files
node-nth-check_1.0.1-1_all.deb performant nth-check parser & compiler
node-number-is-nan_1.0.0-1_all.deb ES6 Number.isNaN() ponyfill
node-nwmatcher_1.3.3+dfsg-2ubuntu1_all.deb CSS3-compliant JavaScript selector engine
node-oauth-sign_0.9.0-1_all.deb OAuth 1 signing module for Node.js
Advertisement
Advertisement