node-node-stringprep_0.8.0-5_amd64.deb


Advertisement

Description

node-node-stringprep - ICU StringPrep profiles for Node

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-node-stringprep_0.8.0-5_amd64.deb
Package name node-node-stringprep
Package version 0.8.0
Package release 5
Package architecture amd64
Package type deb
Category universe/web
Homepage https://node-xmpp.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.74 KB
Installed size 44.00 KB
Node is an event-based server-side JavaScript engine.
node-stringprep provides a Node binding to ICU, exposing predefined
Unicode normalization functions that are required by many protocols.

Alternatives

Package Version Architecture Repository
node-node-stringprep_0.8.0-5_i386.deb 0.8.0 i386 Ubuntu Universe
node-node-stringprep - - -

Requires

Name Value
node-bindings >= 1.2.1
node-debug -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-node-stringprep_0.8.0-5_amd64.deb
Source Package node-stringprep

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-node-stringprep deb package:
    # sudo apt-get install node-node-stringprep

Files

Path
/usr/lib/nodejs/node-stringprep/index.js
/usr/lib/nodejs/node-stringprep/package.json
/usr/lib/nodejs/node-stringprep/build/Release/node_stringprep.node
/usr/share/doc/node-node-stringprep/README.markdown
/usr/share/doc/node-node-stringprep/changelog.Debian.gz
/usr/share/doc/node-node-stringprep/copyright

Changelog

2019-01-31 - Gianfranco Costamagna <locutusofborg@debian.org>
node-stringprep (0.8.0-5) unstable; urgency=medium
[ Gianfranco Costamagna ]
* Team upload
[ Xavier Guimard ]
* Fix cdbs files
2019-01-10 - Xavier Guimard <yadd@debian.org>
node-stringprep (0.8.0-4) unstable; urgency=medium
* Team upload
[ Jérémy Lal ]
* Move to salsa
* Refresh control
[ Xavier Guimard ]
* Fix compilation errors with 2 patches (Closes: #895029)
* Add minimal autopkgtest files
* Declare compliance with policy 4.3.0
* Change section to javascript
* Bump debhelper compatibility level to 10 (due to cdbs)
* Update debian/copyright links
* Update debian/control links
* Set hardening flags
* Update build dependencies:
- libnode-dev instead of nodejs-dev
- node-gyp >= 3.8.0-2s
* Remove useless dh_nodejs
2017-01-10 - Jonas Smedegaard <dr@jones.dk>
node-stringprep (0.8.0-3) unstable; urgency=medium
* Update watch file: Use substitution string @PACKAGE@.
* Update homepage.
* Update watch file: Drop unneeded repackaging options.
* Drop obsolete lintian override regarding debhelper 9.
* Update copyright info: Extend coverage of Debian packaging.
* Cleanup gyp only if built, to simplify bootstrapping a build.
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-stringprep (0.8.0-2) unstable; urgency=medium
* Team Upload
* Call dh_nodejs (Closes: #848886)
2016-08-31 - Jonas Smedegaard <dr@jones.dk>
node-stringprep (0.8.0-1) unstable; urgency=medium
[ upstream ]
* New release(s).
[ Jonas Smedegaard ]
* Update package relations:
+ Tighten build-dependency on node-nan.
+ Tighten dependency on node-bindings.
+ Build-depend on licensecheck (not devscripts).
* Declare compliance with Debian Policy 3.9.8.
* Modernize Vcs-Git field: Use https URL.
* Update copyright info:
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend copyright of packaging to cover current year.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
* Bump debhelper compatibility level to 9.
* Add lintian override regarding debhelper 9.
* Modernize git-buildpackage config:
+ Avoid git- prefix.
+ Filter any .gitignore file.
* Stop track upstream source with CDBS (use gpb --uscan).
* Update watch file:
+ Bump to version 4.
+ Use Github and repack patterns.
+ Mention uscan and gpb in usage comment.
2015-05-19 - Jonas Smedegaard <dr@jones.dk>
node-stringprep (0.6.2-2) unstable; urgency=medium
* Fix install path.
2015-05-19 - Jonas Smedegaard <dr@jones.dk>
node-stringprep (0.6.2-1) unstable; urgency=medium
[ upstream ]
* New release(s).
[ Jonas Smedegaard ]
* Add README.source emphasizing that control.in file is *not* a
show-stopper for contributions, referring to wiki page for details.
* Switch upstream URLs to reflect new home at
https://github.com/node-xmpp/node-stringprep.
* Declare compliance with Debian Policy 3.9.6.
* Update Vcs-* fields to use canonical URLs and cgit browser.
* Update package relations:
+ Drop obsolete provides/replaces/conflicts against
libnode-node-stringprep.
+ Relax to build-depend unversioned on nodejs-dev: Needed version
satisfied even in oldstable.
+ Build-depend on node-nan.
+ Depend on node-bindings and node-debug.
* Modernize git-buildpackage config: Drop "git-" prefix.
* Modernize CDBS inclusions: Needed packages are even in oldstable.
Build-depend on devscripts.
* Stop track md5sum of upstream tarball: Compare tarball against
upstream git commits instead.
* Update copyright info:
+ Extend coverage for myself.
+ Bump packaging copyright to GPL-3+.
* Adapt rules file to use node-gyp.
Build-depend on node-gyp.
* Add patch 2001 to call nodejs (not node) executable.
[ Leo Iannacone ]
* Handle eventual prereleases and repackaging in watch file.

See Also

Package Description
node-node-uuid_3.3.2-2_all.deb transitional package
node-nodedbi_1.0.12-4_amd64.deb libdbi interface for Node.js
node-nomnom_1.8.1-1_all.deb Option parser with generated usage and commands for Node.js
node-nopt_3.0.6-3_all.deb Command-line option parser for Node.js
node-normalize-git-url_3.0.1-1_all.deb normalizes Git URLs
node-normalize-package-data_2.4.0-1_all.deb Normalizes package metadata - Node.js module
node-normalize-path_2.0.1-2_all.deb Normalize file path slashes to be unix-like forward slashes
node-normalize-range_0.1.2-1_all.deb Utility for normalizing a numeric range
node-normalize.css_8.0.1-3_all.deb Modern alternative to CSS resets
node-npm-bundled_1.0.3-1_all.deb Parses info on bundled dependencies
node-npm-package-arg_6.0.0-2_all.deb Parse the things that can be arguments to npm install
node-npm-run-path_2.0.2-2_all.deb Get your PATH prepended with locally installed binaries
node-npmlog_4.1.2-1_all.deb Logger with custom levels and colored output for Node.js
node-npmrc_1.1.1-1_all.deb Switch between different .npmrc files
node-nth-check_1.0.1-1_all.deb performant nth-check parser & compiler
Advertisement
Advertisement