node-node-expat_2.3.17-1_amd64.deb


Advertisement

Description

node-node-expat - fast XML parser library for Node

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-node-expat_2.3.17-1_amd64.deb
Package name node-node-expat
Package version 2.3.17
Package release 1
Package architecture amd64
Package type deb
Category universe/web
Homepage http://node-xmpp.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 18.57 KB
Installed size 71.00 KB
Node is an event-based server-side JavaScript engine.
node-expat is a fast XML parser library for Node.

Alternatives

Package Version Architecture Repository
node-node-expat_2.3.17-1_i386.deb 2.3.17 i386 Ubuntu Universe
node-node-expat - - -

Requires

Name Value
libc6 >= 2.4
libexpat1 >= 2.0.1
libnode64 -
libstdc++6 >= 5
node-bindings -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-node-expat_2.3.17-1_amd64.deb
Source Package node-expat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-node-expat deb package:
    # sudo apt-get install node-node-expat

Files

Path
/usr/lib/nodejs/node-expat/package.json
/usr/lib/nodejs/node-expat/build/Release/node_expat.node
/usr/lib/nodejs/node-expat/lib/node-expat.js
/usr/share/doc/node-node-expat/changelog.Debian.gz
/usr/share/doc/node-node-expat/copyright

Changelog

2019-01-25 - Jérémy Lal <kapouer@melix.org>
node-expat (2.3.17-1) unstable; urgency=medium
* New upstream version 2.3.17
* Move to dh 10, build against libnode, node-gyp 3.8.0-2
* Depends nodejs, node-bindings
* AMAU since Jonas only handles cdbs
* Update Vcs-* fields
* Drop nodejs rename patch
* https url in copyright
* Standards-Version 4.3.0
* Add autopkgtests
* DEP-3 format patch
* Copyright: update and use stricter format, drop unused
lintian overrides
2017-12-29 - Jérémy Lal <kapouer@melix.org>
node-expat (2.3.15-5) experimental; urgency=medium
* Section: javascript
2017-01-23 - Jonas Smedegaard <dr@jones.dk>
node-expat (2.3.15-4) unstable; urgency=medium
* Let tests not fail (new failures emerged with 2.3.15-3 on mips -
possibly timing-related but too close to freeze to investigate).
* Modernize Vcs-* fields:
+ Use git subdir.
+ Use .git suffix.
2017-01-10 - Jonas Smedegaard <dr@jones.dk>
node-expat (2.3.15-3) unstable; urgency=medium
* Update watch file: Use substitution string @PACKAGE@.
* Cleanup gyp only if built, to simplify bootstrapping a build.
* Drop obsolete lintian override regarding debhelper 9.
* Update copyright info: Extend coverage of Debian packaging.
* Extract metadata from png file for copyright check.
Build-depend on libregexp-assemble-perl libimage-exiftool-perl
libfont-ttf-perl.
Tighten to build-depend versioned on cdbs.
2016-12-21 - Jérémy Lal <kapouer@melix.org>
node-expat (2.3.15-2) unstable; urgency=medium
* Team Upload
* Call dh_nodejs
2016-08-31 - Jonas Smedegaard <dr@jones.dk>
node-expat (2.3.15-1) unstable; urgency=medium
[ upstream ]
* New release(s).
+ Benchmark.
+ Bump dependencies.
+ Fix test randomly failing.
+ Add Windows notice.
+ Bump dependencies and update README benchmark.
+ Move back to astro github account.
+ Delint.
+ Update dependencies.
+ Upgrade libexpat to version 2.2.0.
+ Fix add missing standard dependency (lint script).
+ Add many contributors to package.json.
+ Remove duplicated API method in documentation.
[ Jonas Smedegaard ]
* Stop suppress versioned debhelper build-dependency (done in CDBS
now).
* Stop track upstream source with CDBS (use gpb --uscan).
* Update watch file:
+ Use Github pattern.
+ Mention gpb --uscan in usage comment.
* Modernize git-buildpackage config:
+ Avoid git- prefix.
+ Filter any .gitignore file.
* Declare compliance with Debian Policy 3.9.8.
* Fix Vcs-Git field URL.
* Build-depend on licensecheck (not devscripts).
* Fix use http protocol (not https) for Homepage URL.
* Unfuzz patch 1001.

See Also

Package Description
node-node-forge_0.8.1~dfsg-1_all.deb JavaScript implementation of TLS and more - Node library
node-node-localstorage_1.3.0-2_all.deb substitute for the browser native localStorage API
node-node-rest-client_2.5.0-3_all.deb Rest API client for NodeJS
node-node-rsa_1.0.3-1_all.deb RSA library for Node.js
node-node-stringprep_0.8.0-5_amd64.deb ICU StringPrep profiles for Node
node-node-uuid_3.3.2-2_all.deb transitional package
node-nodedbi_1.0.12-4_amd64.deb libdbi interface for Node.js
node-nomnom_1.8.1-1_all.deb Option parser with generated usage and commands for Node.js
node-nopt_3.0.6-3_all.deb Command-line option parser for Node.js
node-normalize-git-url_3.0.1-1_all.deb normalizes Git URLs
node-normalize-package-data_2.4.0-1_all.deb Normalizes package metadata - Node.js module
node-normalize-path_2.0.1-2_all.deb Normalize file path slashes to be unix-like forward slashes
node-normalize-range_0.1.2-1_all.deb Utility for normalizing a numeric range
node-normalize.css_8.0.1-3_all.deb Modern alternative to CSS resets
node-npm-bundled_1.0.3-1_all.deb Parses info on bundled dependencies
Advertisement
Advertisement