node-mongodb_3.1.13+~3.1.11-2_all.deb


Advertisement

Description

node-mongodb - official MongoDB driver for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-mongodb_3.1.13+~3.1.11-2_all.deb
Package name node-mongodb
Package version 3.1.13+~3.1.11
Package release 2
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/mongodb/node-mongodb-native
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 218.53 KB
Installed size 1.43 MB
MongoDB is a high-performance, open source, schema-free document-oriented
data store.
node-mongodb provides a high-level API on top of node-mongodb-core that is
the meant for end users.

Alternatives

Package Version Architecture Repository
node-mongodb_3.1.13+~3.1.11-2_all.deb 3.1.13+~3.1.11 all Ubuntu Universe
node-mongodb - - -

Requires

Name Value
node-resolve-from -
node-safe-buffer -
node-semver >= 5.1.0
nodejs -

Provides

Name Value
node-bson = 1.1.0
node-mongodb-core = 3.1.9
node-require-optional = 1.0.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-mongodb_3.1.13+~3.1.11-2_all.deb
Source Package node-mongodb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-mongodb deb package:
    # sudo apt-get install node-mongodb

Files

Path
/usr/lib/nodejs/bson/index.js
/usr/lib/nodejs/bson/package.json
/usr/lib/nodejs/bson/lib/bson/binary.js
/usr/lib/nodejs/bson/lib/bson/bson.js
/usr/lib/nodejs/bson/lib/bson/code.js
/usr/lib/nodejs/bson/lib/bson/db_ref.js
/usr/lib/nodejs/bson/lib/bson/decimal128.js
/usr/lib/nodejs/bson/lib/bson/double.js
/usr/lib/nodejs/bson/lib/bson/float_parser.js
/usr/lib/nodejs/bson/lib/bson/int_32.js
/usr/lib/nodejs/bson/lib/bson/long.js
/usr/lib/nodejs/bson/lib/bson/map.js
/usr/lib/nodejs/bson/lib/bson/max_key.js
/usr/lib/nodejs/bson/lib/bson/min_key.js
/usr/lib/nodejs/bson/lib/bson/objectid.js
/usr/lib/nodejs/bson/lib/bson/regexp.js
/usr/lib/nodejs/bson/lib/bson/symbol.js
/usr/lib/nodejs/bson/lib/bson/timestamp.js
/usr/lib/nodejs/bson/lib/bson/parser/calculate_size.js
/usr/lib/nodejs/bson/lib/bson/parser/deserializer.js
/usr/lib/nodejs/bson/lib/bson/parser/serializer.js
/usr/lib/nodejs/bson/lib/bson/parser/utils.js
/usr/lib/nodejs/mongodb/index.js
/usr/lib/nodejs/mongodb/package.json
/usr/lib/nodejs/mongodb-core/index.js
/usr/lib/nodejs/mongodb-core/package.json
/usr/lib/nodejs/mongodb-core/lib/cursor.js
/usr/lib/nodejs/mongodb-core/lib/error.js
/usr/lib/nodejs/mongodb-core/lib/sessions.js
/usr/lib/nodejs/mongodb-core/lib/transactions.js
/usr/lib/nodejs/mongodb-core/lib/uri_parser.js
/usr/lib/nodejs/mongodb-core/lib/utils.js
/usr/lib/nodejs/mongodb-core/lib/auth/defaultAuthProviders.js
/usr/lib/nodejs/mongodb-core/lib/auth/gssapi.js
/usr/lib/nodejs/mongodb-core/lib/auth/mongocr.js
/usr/lib/nodejs/mongodb-core/lib/auth/plain.js
/usr/lib/nodejs/mongodb-core/lib/auth/scram.js
/usr/lib/nodejs/mongodb-core/lib/auth/sspi.js
/usr/lib/nodejs/mongodb-core/lib/auth/x509.js
/usr/lib/nodejs/mongodb-core/lib/connection/apm.js
/usr/lib/nodejs/mongodb-core/lib/connection/command_result.js
/usr/lib/nodejs/mongodb-core/lib/connection/commands.js
/usr/lib/nodejs/mongodb-core/lib/connection/connection.js
/usr/lib/nodejs/mongodb-core/lib/connection/logger.js
/usr/lib/nodejs/mongodb-core/lib/connection/pool.js
/usr/lib/nodejs/mongodb-core/lib/connection/utils.js
/usr/lib/nodejs/mongodb-core/lib/sdam/cursor.js
/usr/lib/nodejs/mongodb-core/lib/sdam/monitoring.js
/usr/lib/nodejs/mongodb-core/lib/sdam/server.js
/usr/lib/nodejs/mongodb-core/lib/sdam/server_description.js
/usr/lib/nodejs/mongodb-core/lib/sdam/server_selectors.js
/usr/lib/nodejs/mongodb-core/lib/sdam/topology.js
/usr/lib/nodejs/mongodb-core/lib/sdam/topology_description.js
/usr/lib/nodejs/mongodb-core/lib/tools/smoke_plugin.js
/usr/lib/nodejs/mongodb-core/lib/topologies/mongos.js
/usr/lib/nodejs/mongodb-core/lib/topologies/read_preference.js
/usr/lib/nodejs/mongodb-core/lib/topologies/replset.js
/usr/lib/nodejs/mongodb-core/lib/topologies/replset_state.js
/usr/lib/nodejs/mongodb-core/lib/topologies/server.js
/usr/lib/nodejs/mongodb-core/lib/topologies/shared.js
/usr/lib/nodejs/mongodb-core/lib/wireprotocol/2_6_support.js
/usr/lib/nodejs/mongodb-core/lib/wireprotocol/3_2_support.js
/usr/lib/nodejs/mongodb-core/lib/wireprotocol/compression.js
/usr/lib/nodejs/mongodb-core/lib/wireprotocol/shared.js
/usr/lib/nodejs/mongodb/lib/admin.js
/usr/lib/nodejs/mongodb/lib/aggregation_cursor.js
/usr/lib/nodejs/mongodb/lib/apm.js
/usr/lib/nodejs/mongodb/lib/authenticate.js
/usr/lib/nodejs/mongodb/lib/change_stream.js
/usr/lib/nodejs/mongodb/lib/collection.js
/usr/lib/nodejs/mongodb/lib/command_cursor.js
/usr/lib/nodejs/mongodb/lib/constants.js
/usr/lib/nodejs/mongodb/lib/cursor.js
/usr/lib/nodejs/mongodb/lib/db.js
/usr/lib/nodejs/mongodb/lib/error.js
/usr/lib/nodejs/mongodb/lib/mongo_client.js
/usr/lib/nodejs/mongodb/lib/url_parser.js
/usr/lib/nodejs/mongodb/lib/utils.js
/usr/lib/nodejs/mongodb/lib/bulk/common.js
/usr/lib/nodejs/mongodb/lib/bulk/ordered.js
/usr/lib/nodejs/mongodb/lib/bulk/unordered.js
/usr/lib/nodejs/mongodb/lib/gridfs/chunk.js
/usr/lib/nodejs/mongodb/lib/gridfs/grid_store.js
/usr/lib/nodejs/mongodb/lib/gridfs-stream/download.js
/usr/lib/nodejs/mongodb/lib/gridfs-stream/index.js
/usr/lib/nodejs/mongodb/lib/gridfs-stream/upload.js
/usr/lib/nodejs/mongodb/lib/operations/admin_ops.js
/usr/lib/nodejs/mongodb/lib/operations/collection_ops.js
/usr/lib/nodejs/mongodb/lib/operations/cursor_ops.js
/usr/lib/nodejs/mongodb/lib/operations/db_ops.js
/usr/lib/nodejs/mongodb/lib/operations/mongo_client_ops.js
/usr/lib/nodejs/mongodb/lib/topologies/mongos.js
/usr/lib/nodejs/mongodb/lib/topologies/replset.js
/usr/lib/nodejs/mongodb/lib/topologies/server.js
/usr/lib/nodejs/mongodb/lib/topologies/topology_base.js
/usr/lib/nodejs/require_optional/index.js
/usr/lib/nodejs/require_optional/package.json
/usr/share/doc/node-mongodb/HISTORY-bson.md.gz
/usr/share/doc/node-mongodb/HISTORY-mongodb-core.md.gz
/usr/share/doc/node-mongodb/HISTORY-requireoptional.md
/usr/share/doc/node-mongodb/HISTORY.md.gz
/usr/share/doc/node-mongodb/README-bson.md.gz
/usr/share/doc/node-mongodb/README-mongodb-core.md.gz
/usr/share/doc/node-mongodb/README-requireoptional.md
/usr/share/doc/node-mongodb/README.md.gz
/usr/share/doc/node-mongodb/changelog.Debian.gz
/usr/share/doc/node-mongodb/copyright

Changelog

2019-02-27 - Xavier Guimard <yadd@debian.org>
node-mongodb (3.1.13+~3.1.11-2) unstable; urgency=medium
* Remove bson tests (Closes: #923353)
* Update lintian overrides
2019-02-18 - Xavier Guimard <yadd@debian.org>
node-mongodb (3.1.13+~3.1.11-1) unstable; urgency=medium
* Remove bson test patch
* New upstream version 3.1.13+~3.1.11
2018-12-26 - Xavier Guimard <yadd@debian.org>
node-mongodb (3.1.10+~3.1.9-1) unstable; urgency=medium
* debian/watch:
- use uscan grouped version
- don't include bson and require_optional in grouped version
* Import upstream version:
- mongodb 3.1.10
- mongodb-core 3.1.9
- downgrade bson to 1.1.0 as required by upstream
* Change component name
* New upstream version 3.1.10+~3.1.9
* Refresh bson test patch
* Add node-safe-buffer and nodeunit in build dependencies
* Update debian/copyright
* Update tests
* Change component name
* New upstream version 3.1.8+~3.0.2+~3.1.7+~1.0.1
* New upstream version 3.1.10+~3.1.9
* Refresh bson test patch
* Add node-safe-buffer and nodeunit in build dependencies
* Update debian/copyright
* Update tests
* Declare compliance with policy 4.3.0
2018-10-13 - Xavier Guimard <yadd@debian.org>
node-mongodb (3.1.8+~3.0.2+~3.1.7+~1.0.1-1) unstable; urgency=medium
* Add strict mode in debian/watch to avoid release-candidate in components
* Import upstream versions:
- mongodb 3.1.8
- mongodb-core 3.1.7
2018-09-11 - Xavier Guimard <yadd@debian.org>
node-mongodb (3.1.4+~3.0.2+~3.1.3+~1.0.1-1) unstable; urgency=medium
* Initial release (Closes: #651368, #897282, #897361, #897399)

See Also

Package Description
node-monocle_1.1.51+dfsg-1_all.deb Watch directories for file changes - Node.js module
node-mousetrap_1.6.1+ds-1_all.deb Simple library for handling keyboard shortcuts
node-move-concurrently_1.0.1-2_all.deb Move files and directories concurrently
node-mqtt-packet_6.0.0-1_all.deb parse and generate MQTT packets
node-ms_2.1.1-1_all.deb milliseconds conversion utility - Node.js module
node-multimatch_2.1.0-1_all.deb Extends minimatch.match() with support for multiple patterns
node-multiparty_4.2.1-1_all.deb Multipart/form-data parser for Node.js
node-multipipe_1.0.2-1_all.deb pipe streams with centralized error handling
node-music-library-index_1.2.2-1ubuntu1_all.deb build a searchable object model given track metadata objects - Node.js module
node-mustache_2.3.2-1_all.deb Mustache rendering engine for Javascript - NodeJS
node-mutate-fs_2.1.1-1_all.deb Mutates the node.js file-system behavior for tests
node-mute-stream_0.0.8-1_all.deb Pass-through stream that can be muted module for Node.js
node-mysql_2.16.0-1_all.deb MySQL client implementation for Node.js
node-mz_2.7.0-1_all.deb Modernize node.js to current ECMAScript specifications
node-n3_1.0.4-1_all.deb fast asynchronous streaming RDF for JavaScript - Node library
Advertisement
Advertisement