node-minimatch_3.0.4-3_all.deb


Advertisement

Description

node-minimatch - Convert glob expressions into RegExp objects for Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-minimatch_3.0.4-3_all.deb
Package name node-minimatch
Package version 3.0.4
Package release 3
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/isaacs/minimatch
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.20 KB
Installed size 41.00 KB
A pure javascript, not strictly compatible, implementation of fnmatch/glob.
Supports negation, comment, double-star, brace expansion.
Node.js is an event-based server-side javascript engine.

Alternatives

Package Version Architecture Repository
node-minimatch_3.0.4-3_all.deb 3.0.4 all Ubuntu Universe
node-minimatch - - -

Requires

Name Value
node-brace-expansion >= 1.1.7
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-minimatch_3.0.4-3_all.deb
Source Package node-minimatch

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-minimatch deb package:
    # sudo apt-get install node-minimatch

Files

Path
/usr/lib/nodejs/minimatch/minimatch.js
/usr/lib/nodejs/minimatch/package.json
/usr/share/doc/node-minimatch/README.md.gz
/usr/share/doc/node-minimatch/changelog.Debian.gz
/usr/share/doc/node-minimatch/copyright

Changelog

2017-08-24 - Bastien Roucariès <rouca@debian.org>
node-minimatch (3.0.4-3) unstable; urgency=medium
* Team upload
* set section to javascript
* Bump policy (no changes)
* Upload to unstable
2017-08-13 - Bastien Roucariès <rouca@debian.org>
node-minimatch (3.0.4-2) experimental; urgency=medium
* Team upload
* Install package.json
* Install under /usr/lib/nodejs/minimatch
instead of /usr/lib/nodejs.
* Update copyright
2017-08-13 - Bastien Roucariès <rouca@debian.org>
node-minimatch (3.0.4-1) unstable; urgency=medium
[ Pirate Praveen ]
* Team upload
* New upstream release
[ Bastien Roucariès ]
* Bump policy no change
* Bump compat
* Enable testsuite
* Run autopkgtest suite in isolation
2016-11-04 - Jérémy Lal <kapouer@melix.org>
node-minimatch (3.0.3-1) unstable; urgency=medium
* New upstream version 3.0.3 (Closes: #843087)
* License switch to ISC
* Standards-Version 3.9.8
* Secure Vcs url
* Depends only on node-brace-expansion
* Bump debhelper to 9
* autopkgtest
* Patch to run tests using old tap
2014-07-29 - Jérémy Lal <kapouer@melix.org>
node-minimatch (1.0.0-1) unstable; urgency=medium
* Standards-Version: 3.9.5
* Move to pkg-javascript
* Imported Upstream version 1.0.0
2013-08-15 - Jérémy Lal <kapouer@melix.org>
node-minimatch (0.2.12-1) unstable; urgency=low
* Upstream update
* control:
+ canonicalize Vcs fields
+ Standards-Version 3.9.4
2013-03-23 - Jérémy Lal <kapouer@melix.org>
node-minimatch (0.2.11-1) experimental; urgency=low
* Upstream update.
* Add dependency on node-sigmund.
* Tighten dependency on node-lru-cache >= 2.
* Use github url in watch file.
2012-03-17 - Jérémy Lal <kapouer@melix.org>
node-minimatch (0.2.0-1) unstable; urgency=low
* Initial release (Closes: #664143)

See Also

Package Description
node-minimist_1.2.0-1_all.deb Argument options parsing for Node.js
node-mirror_0.3.3-3_all.deb content aggregator for NodeJS
node-mississippi_3.0.0-1_all.deb collection of useful streams
node-mithril_1.1.6-2_all.deb Javascript framework for building Single Page Applications
node-mixin-deep_1.1.3-1_all.deb Deeply mix the properties of objects into the first object
node-mkdirp_0.5.1-1_all.deb Recursively create directories - Node.js module
node-mocha-lcov-reporter_1.3.0-1_all.deb LCOV reporter for Mocha
node-mocks-http_1.5.1-3_all.deb Mock 'http' objects for testing Express routing functions
node-modern-syslog_1.1.4-2_amd64.deb native syslog client library for Node.js
node-modestmaps_3.3.6+ds2-1_all.deb display and interaction library for tile-based maps - NodeJS
node-modify-babel-preset_3.2.1-2_all.deb Create a modified babel preset based on an existing preset
node-module-deps_6.1.0-1_all.deb walk the dependency graph to generate json output for browser-pack
node-moment-timezone_0.5.23+dfsg1-1_all.deb Parse and display dates in any timezone (node.js library)
node-moment_2.24.0+ds-1_all.deb Work with dates in JavaScript (Node.js module)
node-mongodb_3.1.13+~3.1.11-2_all.deb official MongoDB driver for Node.js
Advertisement
Advertisement