node-less_1.6.3~dfsg-3_all.deb


Advertisement

Description

node-less - LESS CSS meta-language - compiler and Node module

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-less_1.6.3~dfsg-3_all.deb
Package name node-less
Package version 1.6.3~dfsg
Package release 3
Package architecture all
Package type deb
Category universe/web
Homepage http://lesscss.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 69.59 KB
Installed size 355.00 KB
Node is an event-based server-side JavaScript engine.
LESS is a meta-language on top of CSS that’s used to describe the style
of a document cleanly and structurally, with more power than flat CSS
allows.  LESS both provides a simpler, more elegant syntax for CSS and
implements various features that are useful for creating manageable
stylesheets.
less.js is the reference implementation of LESS, written in JavaScript.
This package contains less.js usable as Node module, and the script
lessc for statically compiling LESS data into CSS.

Alternatives

Package Version Architecture Repository
node-less_1.6.3~dfsg-3_all.deb 1.6.3~dfsg all Ubuntu Universe
node-less - - -

Requires

Name Value
nodejs >= 6.11.2~dfsg-1
nodejs-legacy -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-less_1.6.3~dfsg-3_all.deb
Source Package less.js

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-less deb package:
    # sudo apt-get install node-less

Files

Path
/usr/bin/lessc
/usr/lib/nodejs/less/package.json
/usr/lib/nodejs/less/bin/lessc
/usr/lib/nodejs/less/lib/less/browser.js
/usr/lib/nodejs/less/lib/less/colors.js
/usr/lib/nodejs/less/lib/less/encoder.js
/usr/lib/nodejs/less/lib/less/env.js
/usr/lib/nodejs/less/lib/less/extend-visitor.js
/usr/lib/nodejs/less/lib/less/functions.js
/usr/lib/nodejs/less/lib/less/import-visitor.js
/usr/lib/nodejs/less/lib/less/index.js
/usr/lib/nodejs/less/lib/less/join-selector-visitor.js
/usr/lib/nodejs/less/lib/less/lessc_helper.js
/usr/lib/nodejs/less/lib/less/parser.js
/usr/lib/nodejs/less/lib/less/rhino.js
/usr/lib/nodejs/less/lib/less/source-map-output.js
/usr/lib/nodejs/less/lib/less/to-css-visitor.js
/usr/lib/nodejs/less/lib/less/tree.js
/usr/lib/nodejs/less/lib/less/visitor.js
/usr/lib/nodejs/less/lib/less/tree/alpha.js
/usr/lib/nodejs/less/lib/less/tree/anonymous.js
/usr/lib/nodejs/less/lib/less/tree/assignment.js
/usr/lib/nodejs/less/lib/less/tree/call.js
/usr/lib/nodejs/less/lib/less/tree/color.js
/usr/lib/nodejs/less/lib/less/tree/comment.js
/usr/lib/nodejs/less/lib/less/tree/condition.js
/usr/lib/nodejs/less/lib/less/tree/dimension.js
/usr/lib/nodejs/less/lib/less/tree/directive.js
/usr/lib/nodejs/less/lib/less/tree/element.js
/usr/lib/nodejs/less/lib/less/tree/expression.js
/usr/lib/nodejs/less/lib/less/tree/extend.js
/usr/lib/nodejs/less/lib/less/tree/import.js
/usr/lib/nodejs/less/lib/less/tree/javascript.js
/usr/lib/nodejs/less/lib/less/tree/keyword.js
/usr/lib/nodejs/less/lib/less/tree/media.js
/usr/lib/nodejs/less/lib/less/tree/mixin.js
/usr/lib/nodejs/less/lib/less/tree/negative.js
/usr/lib/nodejs/less/lib/less/tree/operation.js
/usr/lib/nodejs/less/lib/less/tree/paren.js
/usr/lib/nodejs/less/lib/less/tree/quoted.js
/usr/lib/nodejs/less/lib/less/tree/rule.js
/usr/lib/nodejs/less/lib/less/tree/ruleset.js
/usr/lib/nodejs/less/lib/less/tree/selector.js
/usr/lib/nodejs/less/lib/less/tree/unicode-descriptor.js
/usr/lib/nodejs/less/lib/less/tree/url.js
/usr/lib/nodejs/less/lib/less/tree/value.js
/usr/lib/nodejs/less/lib/less/tree/variable.js
/usr/share/doc/node-less/README.md.gz
/usr/share/doc/node-less/changelog.Debian.gz
/usr/share/doc/node-less/copyright
/usr/share/man/man1/lessc.1.gz

Changelog

2019-01-25 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-3) unstable; urgency=medium
* Simplify rules.
Stop build-depend on cdbs.
* Wrap and sort control file.
* Provide gzip and brotli pre-compressed files.
Build-depend on brotli pigz.
* Improve optimization of browser library.
* Add autopkgtest.
Update Vcs-* fields: Maintenance moved to Salsa.
Set Rules-Requires-Root: no.
Declare compliance with Debian Policy 4.3.0.
Relax to (build-)depend unversioned on nodejs:
Needed version satisfied even in oldstable.
Update patch 2001 to use executable nodejs
(not nodejs - see bug#862051).
Tighten dependency on nodejs accordingly.
2015-10-23 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-2) unstable; urgency=medium
* Fix have node-less (not libjs-less) recommend node-source-map.
Thanks to David Prévot (see bug#773010).
2015-10-12 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-1) unstable; urgency=medium
[ upstream ]
* New release(s).
+ Avoids sys.puts.
Closes: Bug#800353. Thanks to Sebastian Rittau.
[ Jonas Smedegaard ]
* Adjust comment about when to drop backport-easing fallback
build-dependency on yui-compressor.
Thanks to Alexander E. Patrakov.
* Update copyright info:
+ Update source URLs.
+ Extend coverage of packaging to include current year.
+ Drop Files sections (and corresponding License section) for files
no longer shipped upstream since before 1.4.2.
+ Extend coverage for main upstream author.
* Update source URLs in watch file and CDBS hints.
* Reimplement build (i.e. mostly concatenation) in rules file:
Upstream is moving to grunt which is not yet in Debian.
Build-depend on libyaml-tiny-perl.
* Install upstream CLI script in library path and symlink to bin path
(instead of patching paths in script).
* Bump debhelper compatibility level to 9.
* Move package VCS to pkg-javascript team.
* Add patches cherry-picked upstream to succeed testsuite with modern
Nodejs.
* Repackage upstream tarball to avoid sourceless binary code,
potentially sourceless minified code, and convenience code copies.
Mangle version in watch file (to match default CDBS suffix ~dfsg).
* Update patch 2001.
* Build-depend on and recommend node-source-map.
* Stop build-depend on yui-compressor as fallback: Nodejs needed
during build so backporting to oldstable is a pain anyway.
* Strip article from short descriptions.
[ Christian Amsüss ]
* Declare compliance with Debian Policy 3.9.6.
* Build man page using help2man.
Closes: Bug#693944. Thanks to Martey Dodoo and David Prévot.
* Update Vcs-* URIs.
2013-07-23 - Jonas Smedegaard <dr@jones.dk>
less.js (1.4.2-1) unstable; urgency=low
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Stop tracking md5sum of upstream tarball.
* Bump standards-version to 3.9.4.
* Use canonical hostname (anonscm.debian.org) in Vcs-Browser URI.
* Bump packaging license to GPL-3+, and extend copyrigt coverage for
myself to include recent years.
* Simplify to enable CDBS copyright check and get-orig-source features
unconditionally: Both are backporting-friendly nowadays - or rather
nowadays is more CDBS-backporting friendly).
Build-depend on devscripts.
* Extend copyright coverage for main upstream author.
* Skip a graphics file from copyright-check.
* List upstream issue tracker as preferred contact.
* Unfuzz patches.

See Also

Package Description
node-leveldown_1.5.0+dfsg-3build1_amd64.deb LevelDB bindings - Node.js module
node-leven_2.1.0-2_all.deb library to measure the difference between two strings
node-levn_0.3.0+dfsg-1build2_all.deb Light ECMAScript (JavaScript) Value Notation
node-lex-parser_0.1.4-5build2_all.deb parser for lexical grammars used by jison and jison-lex
node-lexical-scope_1.2.0+dfsg1-2_all.deb detect global and local lexical identifiers in javascript
node-libnpx_10.2.0+repack-2_all.deb support library for npx
node-libravatar_2.0.0-6_all.deb libravatar library for NodeJS
node-libs-browser_2.2.0-1_all.deb node core libs for in browser usage
node-lie_3.1.1+dfsg-1_all.deb basic but performant promise implementation
node-liftoff_2.3.0-3_all.deb command line tool launcher
node-lightgallery_1.6.11+dfsg-1_all.deb Modular lightbox gallery plugin for jQuery
node-load-grunt-tasks_3.5.2-1_all.deb Load multiple grunt tasks using globbing patterns
node-load-json-file_2.0.0-1_all.deb read and parse a JSON file
node-loader-runner_2.3.0-1_all.deb Runs (webpack) loaders
node-loader-utils_1.1.0-2_all.deb utils for webpack loaders
Advertisement
Advertisement