node-jsonld_1.5.3-1_all.deb


Advertisement

Description

node-jsonld - JSON-LD processor - Node library

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-jsonld_1.5.3-1_all.deb
Package name node-jsonld
Package version 1.5.3
Package release 1
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/digitalbazaar/jsonld.js
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 68.98 KB
Installed size 554.00 KB
This library is an implementation
of the JSON-LD specification in JavaScript.
JavaScript Object Notation for Linked Data (JSON-LD)
is a method of encoding Linked Data using JSON.
Linked Data is a method of publishing structured data
so that it can be interlinked
and become more useful through semantic queries.
This package contains jsonld usable with Node.

Alternatives

Package Version Architecture Repository
node-jsonld_1.5.3-1_all.deb 1.5.3 all Ubuntu Universe
node-jsonld - - -

Requires

Name Value
node-rdf-canonize >= 1.0.2
node-request -
node-semver -
node-xmldom -
nodejs >= 6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-jsonld_1.5.3-1_all.deb
Source Package node-jsonld

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-jsonld deb package:
    # sudo apt-get install node-jsonld

Files

Path
/usr/lib/nodejs/jsonld/package.json
/usr/lib/nodejs/jsonld/dist/node6/lib/ActiveContextCache.js
/usr/lib/nodejs/jsonld/dist/node6/lib/DocumentCache.js
/usr/lib/nodejs/jsonld/dist/node6/lib/JsonLdError.js
/usr/lib/nodejs/jsonld/dist/node6/lib/JsonLdProcessor.js
/usr/lib/nodejs/jsonld/dist/node6/lib/NQuads.js
/usr/lib/nodejs/jsonld/dist/node6/lib/Rdfa.js
/usr/lib/nodejs/jsonld/dist/node6/lib/RequestQueue.js
/usr/lib/nodejs/jsonld/dist/node6/lib/compact.js
/usr/lib/nodejs/jsonld/dist/node6/lib/constants.js
/usr/lib/nodejs/jsonld/dist/node6/lib/context.js
/usr/lib/nodejs/jsonld/dist/node6/lib/expand.js
/usr/lib/nodejs/jsonld/dist/node6/lib/flatten.js
/usr/lib/nodejs/jsonld/dist/node6/lib/frame.js
/usr/lib/nodejs/jsonld/dist/node6/lib/fromRdf.js
/usr/lib/nodejs/jsonld/dist/node6/lib/graphTypes.js
/usr/lib/nodejs/jsonld/dist/node6/lib/index.js
/usr/lib/nodejs/jsonld/dist/node6/lib/jsonld.js
/usr/lib/nodejs/jsonld/dist/node6/lib/nodeMap.js
/usr/lib/nodejs/jsonld/dist/node6/lib/toRdf.js
/usr/lib/nodejs/jsonld/dist/node6/lib/types.js
/usr/lib/nodejs/jsonld/dist/node6/lib/url.js
/usr/lib/nodejs/jsonld/dist/node6/lib/util.js
/usr/lib/nodejs/jsonld/dist/node6/lib/documentLoaders/node.js
/usr/lib/nodejs/jsonld/dist/node6/lib/documentLoaders/xhr.js
/usr/lib/nodejs/jsonld/lib/ActiveContextCache.js
/usr/lib/nodejs/jsonld/lib/DocumentCache.js
/usr/lib/nodejs/jsonld/lib/JsonLdError.js
/usr/lib/nodejs/jsonld/lib/JsonLdProcessor.js
/usr/lib/nodejs/jsonld/lib/NQuads.js
/usr/lib/nodejs/jsonld/lib/Rdfa.js
/usr/lib/nodejs/jsonld/lib/RequestQueue.js
/usr/lib/nodejs/jsonld/lib/compact.js
/usr/lib/nodejs/jsonld/lib/constants.js
/usr/lib/nodejs/jsonld/lib/context.js
/usr/lib/nodejs/jsonld/lib/expand.js
/usr/lib/nodejs/jsonld/lib/flatten.js
/usr/lib/nodejs/jsonld/lib/frame.js
/usr/lib/nodejs/jsonld/lib/fromRdf.js
/usr/lib/nodejs/jsonld/lib/graphTypes.js
/usr/lib/nodejs/jsonld/lib/index.js
/usr/lib/nodejs/jsonld/lib/jsonld.js
/usr/lib/nodejs/jsonld/lib/nodeMap.js
/usr/lib/nodejs/jsonld/lib/toRdf.js
/usr/lib/nodejs/jsonld/lib/types.js
/usr/lib/nodejs/jsonld/lib/url.js
/usr/lib/nodejs/jsonld/lib/util.js
/usr/lib/nodejs/jsonld/lib/documentLoaders/node.js
/usr/lib/nodejs/jsonld/lib/documentLoaders/xhr.js
/usr/share/doc/node-jsonld/TODO.Debian
/usr/share/doc/node-jsonld/changelog.Debian.gz
/usr/share/doc/node-jsonld/copyright

Changelog

2019-02-25 - Jonas Smedegaard <dr@jones.dk>
node-jsonld (1.5.3-1) unstable; urgency=medium
[ upstream ]
* New release(s).
[ Jonas Smedegaard ]
* Update watch file:
+ Simplify regular expressions.
+ Rewrite usage comment.
* Update patch 2002 to revive loading webpack itself.
* Unfuzz patches.
* Tighten to (build-)depend versioned on node-rdf-canonize.
2019-01-19 - Jonas Smedegaard <dr@jones.dk>
node-jsonld (1.4.0-4) unstable; urgency=medium
* Update copyright info: Fix source URLs.
* Fix depend (not only build-depend) on node-semver.
* Mark libjs-jsonld as Multi-Arch: foreign.
2019-01-14 - Jonas Smedegaard <dr@jones.dk>
node-jsonld (1.4.0-3) unstable; urgency=medium
* Fix build-depend on node-rdf-canonize.
Closes: Bug#919237. Thanks to Santiago Vila.
* Unfuzz patch 2002.
2019-01-13 - Jonas Smedegaard <dr@jones.dk>
node-jsonld (1.4.0-2) unstable; urgency=medium
* Add patch 1001 to fix odd whitespace breaking Webpack 3.
* Fix and limit patch 2001 to downgrade to use Babel 6
(not avoid Babel altogether).
* Transpile with Babel to support Nodejs 6.
Build-depend on node-babel-cli node-babel-preset-env node-semver.
(Build-)depend on (not very) recent nodejs.
* Add patch 2002 to downgrade to use Webpack 3.
* Add patch 2003 to have webpack use system shared modules.
* Provide binary package libjs-jsonld.
Build-depend on node-babel-loader
node-babel-plugin-transform-object-rest-spread
node-babel-plugin-transform-runtime node-core-js
node-webpack-merge webpack.
* Provide zlib and brotli pre-compressed files.
Build-depend on brotli pigz.
* Update TODOs.
2019-01-12 - Jonas Smedegaard <dr@jones.dk>
node-jsonld (1.4.0-1) unstable; urgency=low
* Initial release.
Closes: Bug#919024.

See Also

Package Description
node-jsonminify_0.4.1+dfsg1-1_all.deb Minify blocks of JSON-like content into valid JSON
node-jsonparse_1.3.1-6_all.deb Pure javascript JSON streaming parser for node.js
node-jsonselect_0.4.0+dfsg3-1_all.deb CSS-like selectors for JSON
node-jsonstream_1.3.2-1_all.deb streaming JSON.parse and stringify
node-jsprim_1.4.0-1_all.deb utilities for primitive JavaScript types
node-jssip_0.6.34-5build1_all.deb JavaScript implementation of a WebRTC SIP video phone
node-jstimezonedetect_1.0.6-2_all.deb Finds the zone info key representing the timezone setting
node-jsv_4.0.0+ds1-1_all.deb extendable, fully compliant JSON schema validator for NodeJS
node-jszip-utils_0.0.2+dfsg-1_all.deb collection of cross-browser utilities to go along with JSZip
node-jszip_3.1.4+dfsg-1_all.deb Create, read and edit .zip files with Javascript
node-katex_0.8.3+dfsg-1_all.deb Fast math typesetting for the web
node-keese_1.1.1-1_all.deb arbitrary-precision floats encoded as strings - Node.js module
node-kew_0.7.0-1_all.deb lightweight promise library for node
node-keygrip_1.0.1-1_all.deb Key signing and verification for rotated credentials for Node.js
node-keypress_0.2.1-1_all.deb Make any Node ReadableStream emit "keypress" events
Advertisement
Advertisement