node-jsonfile_5.0.0-1_all.deb


Advertisement

Description

node-jsonfile - Easily read/write JSON files in Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-jsonfile_5.0.0-1_all.deb
Package name node-jsonfile
Package version 5.0.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/jprichardson/node-jsonfile
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.39 KB
Installed size 21.00 KB
jsonfile is a Node.js module to easily read/write JSON files in JavaScript.
The module provides readFile() and writeFile() methods that combine
JSON.parse() with fs.readFile() and JSON.parse() with fs.readFile().
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-jsonfile_5.0.0-1_all.deb 5.0.0 all Ubuntu Universe
node-jsonfile - - -

Requires

Name Value
node-graceful-fs >= 4.1.6
node-universalify -
nodejs >= 6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-jsonfile_5.0.0-1_all.deb
Source Package node-jsonfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-jsonfile deb package:
    # sudo apt-get install node-jsonfile

Files

Path
/usr/lib/nodejs/jsonfile/index.js
/usr/lib/nodejs/jsonfile/package.json
/usr/share/doc/node-jsonfile/README.md.gz
/usr/share/doc/node-jsonfile/changelog.Debian.gz
/usr/share/doc/node-jsonfile/copyright

Changelog

2018-09-13 - Julien Puydt <jpuydt@debian.org>
node-jsonfile (5.0.0-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
- Move to section javascript and priority optional.
- Point Vcs-* fields to salsa. 
- Bump dh compat to 11. 
- Bump std-ver to 4.2.1. 
- Use my debian.org mail address. 
- Update d/copyright.
2017-09-15 - Julien Puydt <julien.puydt@laposte.net>
node-jsonfile (4.0.0-1) unstable; urgency=medium
* New upstream release.
* Bump std-ver to 4.1.0.
* Bump d/watch to version 4.
* Run the upstream testsuite in autopkgtest.
* Require nodejs >= 6 now upstream dropped support for older versions.
2017-07-24 - Julien Puydt <julien.puydt@laposte.net>
node-jsonfile (3.0.1-1) unstable; urgency=medium
* New upstream release.
2017-06-28 - Julien Puydt <julien.puydt@laposte.net>
node-jsonfile (3.0.0-1) unstable; urgency=medium
* New upstream release.
* Push standards-version to 4.0.0.
2016-10-16 - Julien Puydt <julien.puydt@laposte.net>
node-jsonfile (2.4.0-1) unstable; urgency=medium
[ Bas Couwenberg ]
* Initial release.
[ Julien Puydt ]
* Push dh compat to 10.
* Push standards-version to 3.9.8.
* Use https for Vcs-* fields.
* New upstream release (Closes: #840991).
* Add myself to uploaders and taking over (Bas is ok with that).
* Add dep on node-graceful-fs.

See Also

Package Description
node-jsonify_0.0.0-1_all.deb JSON without touching any globals
node-jsonld_1.5.3-1_all.deb JSON-LD processor - Node library
node-jsonminify_0.4.1+dfsg1-1_all.deb Minify blocks of JSON-like content into valid JSON
node-jsonparse_1.3.1-6_all.deb Pure javascript JSON streaming parser for node.js
node-jsonselect_0.4.0+dfsg3-1_all.deb CSS-like selectors for JSON
node-jsonstream_1.3.2-1_all.deb streaming JSON.parse and stringify
node-jsprim_1.4.0-1_all.deb utilities for primitive JavaScript types
node-jssip_0.6.34-5build1_all.deb JavaScript implementation of a WebRTC SIP video phone
node-jstimezonedetect_1.0.6-2_all.deb Finds the zone info key representing the timezone setting
node-jsv_4.0.0+ds1-1_all.deb extendable, fully compliant JSON schema validator for NodeJS
node-jszip-utils_0.0.2+dfsg-1_all.deb collection of cross-browser utilities to go along with JSZip
node-jszip_3.1.4+dfsg-1_all.deb Create, read and edit .zip files with Javascript
node-katex_0.8.3+dfsg-1_all.deb Fast math typesetting for the web
node-keese_1.1.1-1_all.deb arbitrary-precision floats encoded as strings - Node.js module
node-kew_0.7.0-1_all.deb lightweight promise library for node
Advertisement
Advertisement