node-js-yaml_3.11.0+dfsg-1_all.deb


Advertisement

Description

node-js-yaml - YAML 1.2 parser and serializer

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-js-yaml_3.11.0+dfsg-1_all.deb
Package name node-js-yaml
Package version 3.11.0+dfsg
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/nodeca/js-yaml
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 35.57 KB
Installed size 160.00 KB
This is an implementation of YAML, a human-friendly data serialization
language. Started as PyYAML port, it was completely rewritten from scratch.
Now it's very fast, and supports the 1.2 spec.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-js-yaml_3.11.0+dfsg-1_all.deb 3.11.0+dfsg all Ubuntu Universe
node-js-yaml - - -

Requires

Name Value
node-argparse >= 1.0.7
node-esprima >= 4.0.0
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-js-yaml_3.11.0+dfsg-1_all.deb
Source Package node-js-yaml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-js-yaml deb package:
    # sudo apt-get install node-js-yaml

Files

Path
/usr/bin/js-yaml
/usr/lib/nodejs/js-yaml/index.js
/usr/lib/nodejs/js-yaml/package.json
/usr/lib/nodejs/js-yaml/bin/js-yaml.js
/usr/lib/nodejs/js-yaml/lib/js-yaml.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/common.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/dumper.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/exception.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/loader.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/mark.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema/core.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema/default_full.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema/default_safe.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema/failsafe.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/schema/json.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/binary.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/bool.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/float.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/int.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/map.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/merge.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/null.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/omap.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/pairs.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/seq.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/set.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/str.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/timestamp.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/js/function.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/js/regexp.js
/usr/lib/nodejs/js-yaml/lib/js-yaml/type/js/undefined.js
/usr/share/doc/node-js-yaml/README.Debian
/usr/share/doc/node-js-yaml/README.md.gz
/usr/share/doc/node-js-yaml/changelog.Debian.gz
/usr/share/doc/node-js-yaml/copyright
/usr/share/doc/node-js-yaml/examples/custom_types.js
/usr/share/doc/node-js-yaml/examples/custom_types.yml
/usr/share/doc/node-js-yaml/examples/dumper.js
/usr/share/doc/node-js-yaml/examples/dumper.json
/usr/share/doc/node-js-yaml/examples/sample_document.js
/usr/share/doc/node-js-yaml/examples/sample_document.yml.gz
/usr/share/man/man1/js-yaml.1.gz

Changelog

2018-05-08 - Bastien Roucariès <rouca@debian.org>
node-js-yaml (3.11.0+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream version, fix problems with octal/hex/bin
format.
* Bump format and policy (no changes).
* Move to salsa
2017-09-14 - Bastien Roucariès <rouca@debian.org>
node-js-yaml (3.10.0+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream version, fix problems with unicode.
2017-08-17 - Bastien Roucariès <rouca@debian.org>
node-js-yaml (3.9.1+dfsg-1) unstable; urgency=medium
* Team upload
* Bump compat
* Create build profile nodoc, nocheck to reduce
build loop of node-tape.
* Run a copy of testsuite in autopkgtest
2017-08-15 - Ross Gammon <rossgammon@debian.org>
node-js-yaml (3.9.1+dfsg-1~exp1) experimental; urgency=medium
* New upstream version
* Update lintian overrides
* Use Debian email address
* Switch to javascript for section hint
* Bump standards version, switched to https for copyright format URL
2017-02-01 - Jérémy Lal <kapouer@melix.org>
node-js-yaml (3.7.0+dfsg-2) unstable; urgency=medium
* Team upload.
* Build reproducibility: do not use dh_fixperms -X
2016-11-12 - Jérémy Lal <kapouer@melix.org>
node-js-yaml (3.7.0+dfsg-1) unstable; urgency=medium
* Team upload.
[ Ross Gammon ]
* Add missing copyright attribution
[ Jérémy Lal ]
* Remove restrictions on dependencies (Closes: #844014)
* Fix Files-Excluded field, missing wildcard
* Add repacksuffix in watch file
* New upstream version 3.7.0+dfsg
* Just generate manpage on build, depends help2man
2016-09-04 - Ross Gammon <rosco2@ubuntu.com>
node-js-yaml (3.6.1+dfsg-1) unstable; urgency=low
* Initial release (Closes: #805411)

See Also

Package Description
node-jsbn_1.1.0-1_all.deb fast, portable implementation of large-number math in pure JS
node-jschardet_1.6.0+dfsg-3_all.deb Character encoding auto-detection in JavaScript
node-jsesc_2.5.2-1_all.deb Escape JavaScript strings, with short output (Node.js module)
node-json-buffer_3.0.0-1_all.deb JSON functions that can convert buffers
node-json-loader_0.5.4-1_all.deb json loader for webpack
node-json-localizer_0.0.3-1_all.deb Utility to localize a json object
node-json-parse-better-errors_1.0.2-2_all.deb JSON.parse() with context information on error
node-json-parse-helpfulerror_1.0.3-2_all.deb drop-in replacement for JSON.parse that uses `jju`
node-json-schema-traverse_0.3.1-1_all.deb Json schema traveral package
node-json-schema_0.2.3-1_all.deb JSON Schema validation and specifications
node-json-stable-stringify_1.0.1-1_all.deb deterministic JSON.stringify()
node-json-stringify-safe_5.0.1-1_all.deb JSON.stringify with circular references module for Node.js
node-json2module_0.0.3-1_all.deb Convert a JSON object to an ES6 module
node-json3_3.3.2-1_all.deb modern JSON implementation
node-json5_0.5.1-1_all.deb JSON for the ES5 era
Advertisement
Advertisement