node-es5-shim_4.5.12-1_all.deb


Advertisement

Description

node-es5-shim - ECMAScript 5 compatibility shims for old JavaScript engines (Node.js)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-es5-shim_4.5.12-1_all.deb
Package name node-es5-shim
Package version 4.5.12
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/es-shims/es5-shim/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 3.14 KB
Installed size 22.00 KB
The es5-shim library monkey-patches a JavaScript context to contain
all ECMAScript 5 methods that can be faithfully emulated with a
legacy JavaScript engine.
The es5-sham part tries to complete the picture as best as possible, but
for those methods the result is not as close and mostly intends to avoid
runtime errors : in many cases it might just silently fail.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-es5-shim_4.5.12-1_all.deb 4.5.12 all Ubuntu Universe
node-es5-shim - - -

Requires

Name Value
libjs-es5-shim = 4.5.12-1
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-es5-shim_4.5.12-1_all.deb
Source Package node-es5-shim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-es5-shim deb package:
    # sudo apt-get install node-es5-shim

Files

Path
/usr/lib/nodejs/es5-shim/es5-sham.js
/usr/lib/nodejs/es5-shim/es5-shim.js
/usr/lib/nodejs/es5-shim/package.json
/usr/share/doc/node-es5-shim/CONTRIBUTORS.md
/usr/share/doc/node-es5-shim/README.md.gz
/usr/share/doc/node-es5-shim/changelog.Debian.gz
/usr/share/doc/node-es5-shim/copyright

Changelog

2018-09-28 - Julien Puydt <jpuydt@debian.org>
node-es5-shim (4.5.12-1) unstable; urgency=medium
* New upstrem release.
2018-09-04 - Julien Puydt <jpuydt@debian.org>
node-es5-shim (4.5.11-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
- Point Vcs-* fields to salsa.
- Use my debian.org mail address.
- Update copyright dates in d/copyright. 
- Bump dh compat to 11. 
- Bump std-ver to 4.2.1. 
- Use whole words in description. 
2017-12-17 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.5.10-1) unstable; urgency=medium
* New upstream release.
* Update packaging:
- Bump d/watch to version 4. 
- Use https in d/copyright's format.
- Update copyright dates in d/copyright.
- Bump dh compat to 10. 
- Put in section javascript.
- Declare libjs-es5-shim Multi-Arch: foreign following hinter.
- Bump std-ver to 4.1.2.0. 
- Use https for upstream links. 
2016-06-18 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.5.9-1) unstable; urgency=medium
* New upstream release.
* Correct links in the node-es5-shim package.
2016-05-14 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.5.8-1) unstable; urgency=medium
* New upstream release.
* Bump standards-version up.
* Use https in Vcs-* fields.
* Made node-es5-shim ship links to libjs-es5-shim.
2016-01-02 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.4.1-1) unstable; urgency=medium
* New upstream release.
2015-11-05 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.2.0-1) unstable; urgency=medium
* New upstream release.
2015-10-15 - Julien Puydt <julien.puydt@laposte.net>
node-es5-shim (4.1.14-1) unstable; urgency=low
* Initial release (Closes: #776025)

See Also

Package Description
node-es6-error_4.1.1-1_all.deb Easily-extendable error for use with ES6 classes
node-es6-iterator_2.0.1-1_all.deb ECMAScript 6 Iterator interface
node-es6-map_0.1.5-1_all.deb ECMAScript6 Map polyfill
node-es6-module-transpiler_0.10.0-2_all.deb Module transpiler from ECMAScript 6 for Node.js
node-es6-promise_4.2.5-2_all.deb Lightweight async code library for JavaScript (Node.js module)
node-es6-set_0.1.5-1_all.deb ECMAScript6 Set polyfill
node-es6-shim_0.35.4+ds-2_all.deb ECMAScript 6 shims for legacy JavaScript engines (Node.js)
node-es6-symbol_3.1.1-1_all.deb ECMAScript 6 Symbol polyfill
node-es6-weak-map_2.0.2-1_all.deb ECMAScript6 WeakMap polyfill
node-escape-html_1.0.3-1_all.deb simply escape HTML entities
node-escape-string-regexp_1.0.5-1_all.deb Escape RegExp special characters in Node.js
node-escodegen_1.11.0+dfsg-1build1_all.deb ECMAScript code generator
node-escope_3.6.0+ds-2_all.deb ECMAScript scope analyzer
node-eslint-plugin-flowtype_2.25.0-1_all.deb flow type linting rules for ESLint
node-eslint-plugin-html_3.2.1-1_all.deb lint and fix inline scripts contained in HTML files
Advertisement
Advertisement