node-errorhandler_1.5.0-1_all.deb


Advertisement

Description

node-errorhandler - error handler middleware - Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-errorhandler_1.5.0-1_all.deb
Package name node-errorhandler
Package version 1.5.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/expressjs/errorhandler
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.98 KB
Installed size 26.00 KB
This package provides a middleware to handle errors and to be used
in a development environment.
When an error occurs the full error stack traces is sent back to
the client for debugging purpose.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-errorhandler_1.5.0-1_all.deb 1.5.0 all Ubuntu Universe
node-errorhandler - - -

Requires

Name Value
node-accepts >= 1.1.1
node-escape-html >= 1.0.3
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-errorhandler_1.5.0-1_all.deb
Source Package node-errorhandler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-errorhandler deb package:
    # sudo apt-get install node-errorhandler

Files

Path
/usr/lib/nodejs/errorhandler/index.js
/usr/lib/nodejs/errorhandler/package.json
/usr/lib/nodejs/errorhandler/public/error.html
/usr/lib/nodejs/errorhandler/public/style.css
/usr/share/doc/node-errorhandler/HISTORY.md.gz
/usr/share/doc/node-errorhandler/README.md.gz
/usr/share/doc/node-errorhandler/changelog.Debian.gz
/usr/share/doc/node-errorhandler/copyright

Changelog

2018-05-10 - Bastien Roucari├Ęs <rouca@debian.org>
node-errorhandler (1.5.0-1) unstable; urgency=medium
* Team upload
* New upstream version
* Fix problem with mocha
* Bump compat and policy
* Improve cli
* Move to section javascript
2014-10-11 - Leo Iannacone <l3on@ubuntu.com>
node-errorhandler (1.2.0-1) unstable; urgency=medium
* Imported Upstream version 1.2.0
* Bump Standard-Version 3.9.6
* debian/rules:
- update debian dh_auto_test command
- update HISTORY.md filename
* debian/watch: fix dversionmangle
2014-07-04 - Leo Iannacone <l3on@ubuntu.com>
node-errorhandler (1.1.1-1) unstable; urgency=low
* Initial release (Closes: #751596)

See Also

Package Description
node-errs_0.3.2-1_all.deb Simple error creation and passing utilities
node-es5-ext_0.10.30-1_all.deb ECMAScript extensions and shims
node-es5-shim_4.5.12-1_all.deb ECMAScript 5 compatibility shims for old JavaScript engines (Node.js)
node-es6-error_4.1.1-1_all.deb Easily-extendable error for use with ES6 classes
node-es6-iterator_2.0.1-1_all.deb ECMAScript 6 Iterator interface
node-es6-map_0.1.5-1_all.deb ECMAScript6 Map polyfill
node-es6-module-transpiler_0.10.0-2_all.deb Module transpiler from ECMAScript 6 for Node.js
node-es6-promise_4.2.5-2_all.deb Lightweight async code library for JavaScript (Node.js module)
node-es6-set_0.1.5-1_all.deb ECMAScript6 Set polyfill
node-es6-shim_0.35.4+ds-2_all.deb ECMAScript 6 shims for legacy JavaScript engines (Node.js)
node-es6-symbol_3.1.1-1_all.deb ECMAScript 6 Symbol polyfill
node-es6-weak-map_2.0.2-1_all.deb ECMAScript6 WeakMap polyfill
node-escape-html_1.0.3-1_all.deb simply escape HTML entities
node-escape-string-regexp_1.0.5-1_all.deb Escape RegExp special characters in Node.js
node-escodegen_1.11.0+dfsg-1build1_all.deb ECMAScript code generator
Advertisement
Advertisement