node-encoding_0.1.12-2_all.deb


Advertisement

Description

node-encoding - Convert encodings, uses iconv by default and fallbacks to iconv-lite if needed

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-encoding_0.1.12-2_all.deb
Package name node-encoding
Package version 0.1.12
Package release 2
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/andris9/encoding#readme
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.20 KB
Installed size 21.00 KB
encoding is a simple wrapper around
node-iconv (https://github.com/bnoordhuis/node-iconv) and
iconv-lite (https://github.com/ashtuchkin/iconv-lite/) to convert strings
from one encoding to another. If node-iconv is not available for some reason,
iconv-lite will be used instead of it as a fallback.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-encoding_0.1.12-2_all.deb 0.1.12 all Ubuntu Universe
node-encoding - - -

Requires

Name Value
node-iconv-lite -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-encoding_0.1.12-2_all.deb
Source Package node-encoding

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-encoding deb package:
    # sudo apt-get install node-encoding

Files

Path
/usr/lib/nodejs/encoding/package.json
/usr/lib/nodejs/encoding/lib/encoding.js
/usr/lib/nodejs/encoding/lib/iconv-loader.js
/usr/share/doc/node-encoding/README.md
/usr/share/doc/node-encoding/changelog.Debian.gz
/usr/share/doc/node-encoding/copyright

Changelog

2016-09-18 - Mathias Behrle <mathiasb@m9s.biz>
node-encoding (0.1.12-2) unstable; urgency=medium
* Remove patch to use iconv instead of iconv-lite.
2016-07-19 - Mathias Behrle <mbehrle@debian.org>
node-encoding (0.1.12-1) unstable; urgency=low
* Imported Upstream version 0.1.12
* Initial release (Closes: #831782)

See Also

Package Description
node-end-of-stream_1.4.1-1_all.deb Invoke a callback when a stream has completed or failed
node-enhanced-resolve_3.4.1-1_all.deb Offers a async require.resolve function
node-entities_1.1.1-1ubuntu1_all.deb Encode and decode XML/HTML entities with ease
node-err-code_1.1.2+dfsg-1_all.deb Create an error with a code
node-errno_0.1.4-1_all.deb libuv errno details exposed - Node.js module
node-error-ex_1.3.0-1_all.deb easy error subclassing and stack customization
node-errorhandler_1.5.0-1_all.deb error handler middleware - Node.js
node-errs_0.3.2-1_all.deb Simple error creation and passing utilities
node-es5-ext_0.10.30-1_all.deb ECMAScript extensions and shims
node-es5-shim_4.5.12-1_all.deb ECMAScript 5 compatibility shims for old JavaScript engines (Node.js)
node-es6-error_4.1.1-1_all.deb Easily-extendable error for use with ES6 classes
node-es6-iterator_2.0.1-1_all.deb ECMAScript 6 Iterator interface
node-es6-map_0.1.5-1_all.deb ECMAScript6 Map polyfill
node-es6-module-transpiler_0.10.0-2_all.deb Module transpiler from ECMAScript 6 for Node.js
node-es6-promise_4.2.5-2_all.deb Lightweight async code library for JavaScript (Node.js module)
Advertisement
Advertisement