node-elliptic_6.4.1~dfsg-1_all.deb


Advertisement

Description

node-elliptic - fast elliptic curve cryptography in pure javascript

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-elliptic_6.4.1~dfsg-1_all.deb
Package name node-elliptic
Package version 6.4.1~dfsg
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/indutny/elliptic
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 37.22 KB
Installed size 138.00 KB
Fast elliptic-curve cryptography in a plain javascript implementation.
Incentive for Elliptic: ECC (another library with comparable features) is
much slower than regular RSA cryptography, the JS implementations are even
more slower.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-elliptic_6.4.1~dfsg-1_all.deb 6.4.1~dfsg all Ubuntu Universe
node-elliptic - - -

Requires

Name Value
node-assert -
node-bn.js -
node-brorand -
node-hash.js -
node-hmac-drbg -
node-inherits -
node-minimalistic-crypto-utils -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-elliptic_6.4.1~dfsg-1_all.deb
Source Package node-elliptic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-elliptic deb package:
    # sudo apt-get install node-elliptic

Files

Path
/usr/lib/nodejs/elliptic/package.json
/usr/lib/nodejs/elliptic/lib/elliptic.js
/usr/lib/nodejs/elliptic/lib/elliptic/curves.js
/usr/lib/nodejs/elliptic/lib/elliptic/utils.js
/usr/lib/nodejs/elliptic/lib/elliptic/curve/base.js
/usr/lib/nodejs/elliptic/lib/elliptic/curve/edwards.js
/usr/lib/nodejs/elliptic/lib/elliptic/curve/index.js
/usr/lib/nodejs/elliptic/lib/elliptic/curve/mont.js
/usr/lib/nodejs/elliptic/lib/elliptic/curve/short.js
/usr/lib/nodejs/elliptic/lib/elliptic/ec/index.js
/usr/lib/nodejs/elliptic/lib/elliptic/ec/key.js
/usr/lib/nodejs/elliptic/lib/elliptic/ec/signature.js
/usr/lib/nodejs/elliptic/lib/elliptic/eddsa/index.js
/usr/lib/nodejs/elliptic/lib/elliptic/eddsa/key.js
/usr/lib/nodejs/elliptic/lib/elliptic/eddsa/signature.js
/usr/lib/nodejs/elliptic/lib/elliptic/precomputed/secp256k1.js
/usr/share/doc/node-elliptic/README.md.gz
/usr/share/doc/node-elliptic/changelog.Debian.gz
/usr/share/doc/node-elliptic/copyright

Changelog

2019-01-10 - Jonas Smedegaard <dr@jones.dk>
node-elliptic (6.4.1~dfsg-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Add git-buildpackage config:
+ Enable pristine-tar and signed tags.
+ Filter any .gitignore file.
* Update watch file:
+ Bump watch file format version to 4.
+ Use Github pattern.
+ Add usage comment.
+ Drop explicit repack
(implied by Files-Excluded: in copyight file when needed).
+ Drop explicit compression format
(better use pristine compression when repackaging is unneeded).
+ Use ~ (not +) as repack delimiter
(to leave room for eventual upstream re-release of fixed tarball).
* Update copyright info:
+ Use https protocol in file format URL.
+ Add myself to packaging Files section.
+ Fix mention reasons for repackaging.
+ Normalize Files-Excluded list.
* Update Vcs-* fields: Maintenance moved to Salsa.
* Relax to (build-)depend all unversioned:
Only recent enough releases exist in Debian.
* Wrap and sort control and debhelper hint files.
* Add DEP-3 patch header to patch.
* Stop build-depend on dh-buildinfo.
* Mark build-dependencies needed only for testsuite as such.
* Set Rules-Requires-Root: no.
* Declare compliance with Debian Policy 4.3.0.
* Add myself as uploader.
2017-05-02 - Pirate Praveen <praveen@debian.org>
node-elliptic (6.4.0+dfsg-1) unstable; urgency=low
* Initial release (Closes: #861639)

See Also

Package Description
node-emoji_1.8.1-1_all.deb simple emoji support for node.js
node-emojis-list_2.1.0-1_all.deb complete list of standard emojis
node-encodeurl_1.0.1-1_all.deb Encode URL to a percent-encoded form
node-encoding_0.1.12-2_all.deb Convert encodings, uses iconv by default and fallbacks to iconv-lite if needed
node-end-of-stream_1.4.1-1_all.deb Invoke a callback when a stream has completed or failed
node-enhanced-resolve_3.4.1-1_all.deb Offers a async require.resolve function
node-entities_1.1.1-1ubuntu1_all.deb Encode and decode XML/HTML entities with ease
node-err-code_1.1.2+dfsg-1_all.deb Create an error with a code
node-errno_0.1.4-1_all.deb libuv errno details exposed - Node.js module
node-error-ex_1.3.0-1_all.deb easy error subclassing and stack customization
node-errorhandler_1.5.0-1_all.deb error handler middleware - Node.js
node-errs_0.3.2-1_all.deb Simple error creation and passing utilities
node-es5-ext_0.10.30-1_all.deb ECMAScript extensions and shims
node-es5-shim_4.5.12-1_all.deb ECMAScript 5 compatibility shims for old JavaScript engines (Node.js)
node-es6-error_4.1.1-1_all.deb Easily-extendable error for use with ES6 classes
Advertisement
Advertisement