node-ejs_2.5.7-1_all.deb


Advertisement

Description

node-ejs - Embedded JavaScript templates

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-ejs_2.5.7-1_all.deb
Package name node-ejs
Package version 2.5.7
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/mde/ejs
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.61 KB
Installed size 47.00 KB
This module provides embedded JavaScript templates, like
- Control flow with <% %>
- Escaped output with <%= %> (escape function configurable)
- Unescaped raw output with <%- %>
- Newline-trim mode ('newline slurping') with -%> ending tag
- Whitespace-trim mode (slurp all whitespace) for control flow with <%_ _%>
- Custom delimiters (e.g., use <? ?> instead of <% %>)
- Includes
- Client-side support
- Static caching of intermediate JavaScript
- Static caching of templates
- Complies with the Express view system
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-ejs_2.5.7-1_all.deb 2.5.7 all Ubuntu Universe
node-ejs - - -

Requires

Name Value
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-ejs_2.5.7-1_all.deb
Source Package node-ejs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-ejs deb package:
    # sudo apt-get install node-ejs

Files

Path
/usr/lib/nodejs/ejs/package.json
/usr/lib/nodejs/ejs/lib/ejs.js
/usr/lib/nodejs/ejs/lib/utils.js
/usr/share/doc/node-ejs/README.md.gz
/usr/share/doc/node-ejs/changelog.Debian.gz
/usr/share/doc/node-ejs/copyright

Changelog

2017-10-10 - Pirate Praveen <praveen@debian.org>
node-ejs (2.5.7-1) unstable; urgency=medium
* Team upload
* New upstream release
2016-11-04 - Thorsten Alteholz <debian@alteholz.de>
node-ejs (2.5.2-1) unstable; urgency=medium
* new upstream version
2016-06-12 - Thorsten Alteholz <debian@alteholz.de>
node-ejs (2.4.2-1) unstable; urgency=medium
* Initial release

See Also

Package Description
node-electron-to-chromium_1.3.103-1_all.deb Provides a list of electron-to-chromium version mappings
node-elliptic_6.4.1~dfsg-1_all.deb fast elliptic curve cryptography in pure javascript
node-emoji_1.8.1-1_all.deb simple emoji support for node.js
node-emojis-list_2.1.0-1_all.deb complete list of standard emojis
node-encodeurl_1.0.1-1_all.deb Encode URL to a percent-encoded form
node-encoding_0.1.12-2_all.deb Convert encodings, uses iconv by default and fallbacks to iconv-lite if needed
node-end-of-stream_1.4.1-1_all.deb Invoke a callback when a stream has completed or failed
node-enhanced-resolve_3.4.1-1_all.deb Offers a async require.resolve function
node-entities_1.1.1-1ubuntu1_all.deb Encode and decode XML/HTML entities with ease
node-err-code_1.1.2+dfsg-1_all.deb Create an error with a code
node-errno_0.1.4-1_all.deb libuv errno details exposed - Node.js module
node-error-ex_1.3.0-1_all.deb easy error subclassing and stack customization
node-errorhandler_1.5.0-1_all.deb error handler middleware - Node.js
node-errs_0.3.2-1_all.deb Simple error creation and passing utilities
node-es5-ext_0.10.30-1_all.deb ECMAScript extensions and shims
Advertisement
Advertisement