node-duplexify_3.6.1-1_all.deb


Advertisement

Description

node-duplexify - Turn a writable and readable stream into a streams2 duplex stream

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-duplexify_3.6.1-1_all.deb
Package name node-duplexify
Package version 3.6.1
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/mafintosh/duplexify
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.40 KB
Installed size 22.00 KB
Similar to duplexer2 except it supports both streams2 and streams1 as input
and it allows you to set the readable and writable part asynchronously using
setReadable(stream) and setWritable(stream).
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-duplexify_3.6.1-1_all.deb 3.6.1 all Ubuntu Universe
node-duplexify - - -

Requires

Name Value
node-end-of-stream -
node-inherits -
node-readable-stream -
node-stream-shift -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-duplexify_3.6.1-1_all.deb
Source Package node-duplexify

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-duplexify deb package:
    # sudo apt-get install node-duplexify

Files

Path
/usr/lib/nodejs/duplexify/index.js
/usr/lib/nodejs/duplexify/package.json
/usr/share/doc/node-duplexify/README.md
/usr/share/doc/node-duplexify/changelog.Debian.gz
/usr/share/doc/node-duplexify/copyright

Changelog

2019-01-21 - Xavier Guimard <yadd@debian.org>
node-duplexify (3.6.1-1) unstable; urgency=medium
* Team upload
* New upstream version 3.6.1
2019-01-21 - Xavier Guimard <yadd@debian.org>
node-duplexify (3.5.0-2) unstable; urgency=medium
* Team upload
* Use readable-stream as required by upstream due to nodejs 10 changes
* Bump debhelper compatibility level to 11
* Declare compliance with policy 4.3.0
* Enable tape test during build
* Fix debian/copyright links
* Add upstream/metadata
* Update VCS fields to salsa
* Change section to javascript
* Ignore test if nocheck is set
2016-12-08 - Sruthi Chandran <srud@disroot.org>
node-duplexify (3.5.0-1) unstable; urgency=low
* Initial release (Closes: #847460)

See Also

Package Description
node-ebnf-parser_0.1.10+dfsg-3build2_all.deb parser for BNF and EBNF grammars used by jison
node-ecc-jsbn_0.1.1-1_all.deb ECC JS code based on JSBN
node-editor_1.0.0-1_all.deb Launch $EDITOR in your program
node-ejs_2.5.7-1_all.deb Embedded JavaScript templates
node-electron-to-chromium_1.3.103-1_all.deb Provides a list of electron-to-chromium version mappings
node-elliptic_6.4.1~dfsg-1_all.deb fast elliptic curve cryptography in pure javascript
node-emoji_1.8.1-1_all.deb simple emoji support for node.js
node-emojis-list_2.1.0-1_all.deb complete list of standard emojis
node-encodeurl_1.0.1-1_all.deb Encode URL to a percent-encoded form
node-encoding_0.1.12-2_all.deb Convert encodings, uses iconv by default and fallbacks to iconv-lite if needed
node-end-of-stream_1.4.1-1_all.deb Invoke a callback when a stream has completed or failed
node-enhanced-resolve_3.4.1-1_all.deb Offers a async require.resolve function
node-entities_1.1.1-1ubuntu1_all.deb Encode and decode XML/HTML entities with ease
node-err-code_1.1.2+dfsg-1_all.deb Create an error with a code
node-errno_0.1.4-1_all.deb libuv errno details exposed - Node.js module
Advertisement
Advertisement