node-doctrine_3.0.0-1_all.deb


Advertisement

Description

node-doctrine - JSDoc parser

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-doctrine_3.0.0-1_all.deb
Package name node-doctrine
Package version 3.0.0
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/eslint/doctrine
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.82 KB
Installed size 89.00 KB
Doctrine is a JSDoc parser, that parses documentation comments from JavaScript
(you need to pass in the comment, not a complete source file)
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-doctrine_3.0.0-1_all.deb 3.0.0 all Ubuntu Universe
node-doctrine - - -

Requires

Name Value
node-esutils >= 2.0.2
node-isarray >= 1.0.0
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-doctrine_3.0.0-1_all.deb
Source Package node-doctrine

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-doctrine deb package:
    # sudo apt-get install node-doctrine

Files

Path
/usr/lib/nodejs/doctrine/package.json
/usr/lib/nodejs/doctrine/lib/doctrine.js
/usr/lib/nodejs/doctrine/lib/typed.js
/usr/lib/nodejs/doctrine/lib/utility.js
/usr/share/doc/node-doctrine/README.md.gz
/usr/share/doc/node-doctrine/changelog.Debian.gz
/usr/share/doc/node-doctrine/copyright

Changelog

2018-11-13 - Julien Puydt <jpuydt@debian.org>
node-doctrine (3.0.0-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
- Use my debian.org address.
- Point Vcs-* fields to salsa. 
- Bump std-ver to 4.2.1. 
- Run upstream test suite in autopkgtest. 
2018-01-10 - Julien Puydt <julien.puydt@laposte.net>
node-doctrine (2.1.0-1) unstable; urgency=medium
* New upstream release.
2017-11-29 - Julien Puydt <julien.puydt@laposte.net>
node-doctrine (2.0.2-1) unstable; urgency=medium
* New upstream release.
* Add a patch to make upstream test suite run in autopkgtest.
* Run upstream test suite in autopkgtest.
2017-11-11 - Julien Puydt <julien.puydt@laposte.net>
node-doctrine (2.0.1-1) unstable; urgency=medium
* New upstream release.
* Bump d/watch to version 4 and std-ver to 4.1.1.
* Update d/copyright.
* Move from section web to section javascript.
2016-11-15 - Julien Puydt <julien.puydt@laposte.net>
node-doctrine (2.0.0-1) unstable; urgency=low
* Initial release (Closes: #840925)

See Also

Package Description
node-dom-serializer_0.1.0-1_all.deb render htmlparser2's DOM nodes to string
node-domain-browser_1.1.7-1_all.deb Node's domain module for the web browser
node-domelementtype_1.3.0-1_all.deb all the types of nodes in htmlparser2's dom
node-domhandler_2.3.0-1_all.deb htmlparser2 handler that turns pages into a dom
node-domino_2.1.2~dfsg-1_all.deb server-side DOM implementation based on Mozilla's dom.js
node-domutils_1.5.1-2_all.deb utilities for working with htmlparser2's DOM
node-dot-prop_4.1.1-1_all.deb updates a property from a nested object
node-dot_1.1.1-1_all.deb Concise and fast javascript templating
node-dryice_0.4.10-3_all.deb CommonJS/RequireJS packaging tool for browser scripts
node-duplexer3_0.1.4-4_all.deb Like duplexer but using streams3
node-duplexer_0.1.1-1_all.deb Creates a duplex stream
node-duplexify_3.6.1-1_all.deb Turn a writable and readable stream into a streams2 duplex stream
node-ebnf-parser_0.1.10+dfsg-3build2_all.deb parser for BNF and EBNF grammars used by jison
node-ecc-jsbn_0.1.1-1_all.deb ECC JS code based on JSBN
node-editor_1.0.0-1_all.deb Launch $EDITOR in your program
Advertisement
Advertisement