node-deep-eql_3.0.1-1_all.deb


Advertisement

Description

node-deep-eql - Improved deep equality testing for Node.js and the browser

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-deep-eql_3.0.1-1_all.deb
Package name node-deep-eql
Package version 3.0.1
Package release 1
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/chaijs/deep-eql#readme
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 10.48 KB
Installed size 43.00 KB
Deep Eql is a module which you can use to determine if two
objects are "deeply" equal - that is, rather than having
referential equality (a === b), this module checks an
object's keys recursively, until it finds primitives to
check for referential equality. For more on equality in JavaScript,
read the comparison operators article on mdn.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-deep-eql_3.0.1-1_all.deb 3.0.1 all Ubuntu Universe
node-deep-eql - - -

Requires

Name Value
node-type-detect >= 3.0.0
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-deep-eql_3.0.1-1_all.deb
Source Package node-deep-eql

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-deep-eql deb package:
    # sudo apt-get install node-deep-eql

Files

Path
/usr/lib/nodejs/deep-eql/deep-eql.js
/usr/lib/nodejs/deep-eql/index.js
/usr/lib/nodejs/deep-eql/package.json
/usr/share/doc/node-deep-eql/README.md.gz
/usr/share/doc/node-deep-eql/changelog.Debian.gz
/usr/share/doc/node-deep-eql/copyright

Changelog

2017-10-25 - Sruthi Chandran <srud@disroot.org>
node-deep-eql (3.0.1-1) unstable; urgency=medium
* New upstream release
2016-11-05 - Sruthi Chandran <srud@disroot.org>
node-deep-eql (2.0.0+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream release
2016-10-11 - Syam G Krishnan <sgk@riseup.net>
node-deep-eql (1.0.0-1) unstable; urgency=low
* Initial release (Closes: #840449)

See Also

Package Description
node-deep-equal_1.0.1-1_all.deb node's assert.deepEqual algorithm
node-deep-extend_0.4.1-1_all.deb Recursive object extending
node-deep-for-each_1.0.6+dfsg-1_all.deb Recursively iterates collection values (arrays and objects)
node-deep-is_0.1.3-1_all.deb node's assert.deepEqual algorithm except for NaN being equal to NaN
node-defaults_1.0.3-1_all.deb merge single level defaults over a config object
node-define-property_2.0.2-1_all.deb Define property on an object
node-defined_1.0.0-1_all.deb return the first argument that is `!== undefined`
node-deflate-js_0.2.3-1_all.deb DEFLATE implemented in JavaScript (works in browser and Node)
node-del_3.0.0-1_all.deb Delete files and folders
node-delayed-stream_0.0.5-1_all.deb Buffer stream events for later handling - module for Node.js
node-delegates_1.0.0-1_all.deb delegate methods and accessors to another property
node-delve_0.3.2-1_all.deb delve recursively into a value to retrieve a property
node-depd_1.1.2-1_all.deb mark a function or property as deprecated - Node.js module
node-deprecated_0.0.1-1_all.deb Tool for deprecating things
node-deps-sort_2.0.0-2_all.deb sort module depends for deterministic browserify bundles
Advertisement
Advertisement