node-compressible_2.0.15-3_all.deb


Advertisement

Description

node-compressible - checks whether a mime type is compressible - Node.js module

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-compressible_2.0.15-3_all.deb
Package name node-compressible
Package version 2.0.15
Package release 3
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/jshttp/compressible
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.50 KB
Installed size 20.00 KB
This module is useful for server software to check if a given mime type
represents data that is worth being compressed.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-compressible_2.0.15-3_all.deb 2.0.15 all Ubuntu Universe
node-compressible - - -

Requires

Name Value
node-mime-types -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-compressible_2.0.15-3_all.deb
Source Package node-compressible

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-compressible deb package:
    # sudo apt-get install node-compressible

Files

Path
/usr/lib/nodejs/compressible/index.js
/usr/lib/nodejs/compressible/package.json
/usr/share/doc/node-compressible/HISTORY.md.gz
/usr/share/doc/node-compressible/README.md
/usr/share/doc/node-compressible/changelog.Debian.gz
/usr/share/doc/node-compressible/copyright

Changelog

2018-11-02 - Bastien Roucariès <rouca@debian.org>
node-compressible (2.0.15-3) unstable; urgency=medium
* Team upload
* Fix lintian warnings
2018-11-01 - Bastien Roucariès <rouca@debian.org>
node-compressible (2.0.15-2) unstable; urgency=medium
* Run testsuite in CI
2018-11-01 - Bastien Roucariès <rouca@debian.org>
node-compressible (2.0.15-1) unstable; urgency=medium
* Team upload
* New upstream version
* Bump compat and policy
* Move to javascript section
* Improve testing
* patch package.json, we support recent mime-db
2014-10-10 - Leo Iannacone <l3on@ubuntu.com>
node-compressible (2.0.1-1) unstable; urgency=medium
* Imported Upstream version 2.0.1
* Bump Standards-Version 3.9.6
* debian/copyright: add new author
* debian/watch: fix dversionmangle
* debian/control: add dependency on node-mime-types
* debian/install: remove specification.json, no longer shipped in upstream
* debian/rules: install HISTORY.md as upstream changelog
* 0000-use_mime-db_from_mime-types.patch: use mime-db
from mime-types modules
* 0001-fix_upstream_test.patch: do not fail if new mime-db
does not have type required by the tests.
* Add autopkgtest suite
2014-06-18 - Leo Iannacone <l3on@ubuntu.com>
node-compressible (1.1.0-1) unstable; urgency=low
* Initial release (Closes: #751580)

See Also

Package Description
node-compression-webpack-plugin_1.1.10-2_all.deb Prepare compressed versions of assets
node-compression_1.7.3-2_all.deb express middleware for gzip/deflate compression - Node.js module
node-concat-map_0.0.1-1_all.deb concatenative mapdashery for Node.js
node-concat-stream_1.6.2-1_all.deb writable stream that concatenates strings
node-concat-with-sourcemaps_1.0.4-2_all.deb concatenate files and generate source maps
node-config-chain_1.1.11-1_all.deb Handle Configuration Once And For All
node-configstore_3.1.1-2_all.deb load and save config without having to think about where and how
node-connect-timeout_1.9.0-3_all.deb connect middleware for timing out HTTP requests - Node.js module
node-connect_3.6.7-1_all.deb extensible HTTP server framework - Node.js module
node-console-browserify_1.1.0+20161220gitf0a8898487-2_all.deb Emulate console for all the browsers
node-console-control-strings_1.1.0-1_all.deb cross-platform tested terminal/console command strings
node-console-group_0.3.3-1_all.deb basic console.group implementation for node
node-consolidate_0.15.1-1_all.deb Template engine consolidation library
node-constantinople_2.0.0-2_all.deb determine if an expression evaluates to a constant - Node.js module
node-constants-browserify_1.0.0+dfsg-6build1_all.deb Node's `constants` module for the browser
Advertisement
Advertisement