node-babel-plugin-transform-regenerator_6.26.0+dfsg-3build6_all.deb


Advertisement

Description

node-babel-plugin-transform-regenerator - Explode async and generator functions into a state machine

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-babel-plugin-transform-regenerator_6.26.0+dfsg-3build6_all.deb
Package name node-babel-plugin-transform-regenerator
Package version 6.26.0+dfsg
Package release 3build6
Package architecture all
Package type deb
Category universe/javascript
Homepage https://babeljs.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.93 KB
Installed size 21.00 KB
Babel is a JavaScript compiler to use next generation JavaScript, today.
ES2015 and beyond: Babel has support for the latest version of JavaScript
through syntax transformers. These plugins allow you to use new syntax, right
now without waiting for browser support.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-babel-plugin-transform-regenerator_6.26.0+dfsg-3build6_all.deb 6.26.0+dfsg all Ubuntu Universe
node-babel-plugin-transform-regenerator - - -

Requires

Name Value
node-regenerator-transform >= 0.9.8
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-babel-plugin-transform-regenerator_6.26.0+dfsg-3build6_all.deb
Source Package node-babel

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-babel-plugin-transform-regenerator deb package:
    # sudo apt-get install node-babel-plugin-transform-regenerator

Files

Path
/usr/lib/nodejs/babel-plugin-transform-regenerator/package.json
/usr/lib/nodejs/babel-plugin-transform-regenerator/lib/index.js
/usr/share/doc/node-babel-plugin-transform-regenerator/README.md
/usr/share/doc/node-babel-plugin-transform-regenerator/changelog.Debian.gz
/usr/share/doc/node-babel-plugin-transform-regenerator/copyright

Changelog

2018-02-19 - Gianfranco Costamagna <locutusofborg@debian.org>
node-babel (6.26.0+dfsg-3build6) bionic; urgency=medium
* No change rebuild with the bootstrapped stack, back in sync with Debian
2018-01-23 - Pirate Praveen <praveen@debian.org>
node-babel (6.26.0+dfsg-3) unstable; urgency=medium
* Add new binary node-babel-plugin-transform-proto-to-assign
2018-01-07 - Pirate Praveen <praveen@debian.org>
node-babel (6.26.0+dfsg-2) unstable; urgency=medium
* Provide babeljs-external-helpers command
2018-01-05 - Pirate Praveen <praveen@debian.org>
node-babel (6.26.0+dfsg-1) unstable; urgency=medium
* New upstream release
* Refresh patches
* Bump standards version
2017-12-15 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg1-3) unstable; urgency=medium
* Provide babeljs from node-babel-cli (as it provides /usr/bin/babeljs) 
2017-10-25 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg1-2) unstable; urgency=medium
* Drop node-babel-register dependency in node-babel-core (Closes: #876016)
2017-10-10 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg1-1) unstable; urgency=medium
* Remove files without copyright owner, make ftp masters happy. 
2017-10-08 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg-11) unstable; urgency=medium
* Add more binary packages
* Change /usr/bin/babel to /usr/bin/babeljs (Closes: #874420)
* Move to main section as babel can now build itself without using npm
* Add copyright to Google Inc for 
packages/babel-preset-es2015/test/fixtures/traceur/*
2017-09-26 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg-10) unstable; urgency=medium
* Add node-regexpu-core as dependency for node-babel-preset-es2015
* Enable require test for babel-preset-es2015 and node-babel-preset-latest
2017-09-22 - Pirate Praveen <praveen@debian.org>
node-babel (6.25.0+dfsg-9) unstable; urgency=medium
* Add new binary packages

See Also

Package Description
node-babel-plugin-transform-runtime_6.26.0+dfsg-3build6_all.deb Externalise references to helpers and builtins
node-babel-plugin-transform-strict-mode_6.26.0+dfsg-3build6_all.deb Enable strict mode for all files
node-babel-plugin-transform-vue-jsx_3.5.0+dfsg-1_all.deb Babel plugin for Vue 2.0 JSX
node-babel-polyfill_6.26.0+dfsg-3build6_all.deb Provides polyfills necessary for a full ES2015+ environment
node-babel-preset-airbnb_2.4.0-1_all.deb babel preset for transforming your JavaScript for Airbnb
node-babel-preset-env_1.6.0-1build4_all.deb Babel preset for each environment
node-babel-preset-es2015-loose_8.0.0-2_all.deb Babel preset for all es2015 plugins, with loose mode
node-babel-preset-es2015_6.26.0+dfsg-3build6_all.deb Babel preset for all es2015 plugins
node-babel-preset-es2016_6.26.0+dfsg-3build6_all.deb Babel preset for all es2016 plugins
node-babel-preset-es2017_6.26.0+dfsg-3build6_all.deb Babel preset for all es2017 plugins
node-babel-preset-es3_1.0.1-1_all.deb Preset for Babel's ES3 transformations
node-babel-preset-flow-vue_1.0.0-1_all.deb babel preset for flow support
node-babel-preset-flow_6.26.0+dfsg-3build6_all.deb Babel preset for all Flow plugins
node-babel-preset-latest_6.26.0+dfsg-3build6_all.deb Babel preset including es2015+
node-babel-preset-react_6.26.0+dfsg-3build6_all.deb Babel preset for all React plugins
Advertisement
Advertisement