node-babel-loader_7.1.5-1_all.deb


Advertisement

Description

node-babel-loader - babel module loader for webpack

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-babel-loader_7.1.5-1_all.deb
Package name node-babel-loader
Package version 7.1.5
Package release 1
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/babel/babel-loader
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 9.62 KB
Installed size 34.00 KB
This library is a babel loader module for webpack.
Webpack takes code targeted at node.js and makes it run in the browser.
Node.js comes with API of its own that is not available in the browsers.
Webpack exposes this code to programs that are unaware they are running in a
browser.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-babel-loader_7.1.5-1_all.deb 7.1.5 all Ubuntu Universe
node-babel-loader - - -

Requires

Name Value
node-babel-core >= 6.18.0
node-find-cache-dir >= 0.1.1
node-loader-utils >= 1.0.2
node-mkdirp >= 0.5
node-object-assign >= 4.0.1
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-babel-loader_7.1.5-1_all.deb
Source Package node-babel-loader

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-babel-loader deb package:
    # sudo apt-get install node-babel-loader

Files

Path
/usr/lib/nodejs/babel-loader/package.json
/usr/lib/nodejs/babel-loader/lib/fs-cache.js
/usr/lib/nodejs/babel-loader/lib/index.js
/usr/lib/nodejs/babel-loader/lib/resolve-rc.js
/usr/lib/nodejs/babel-loader/lib/utils/exists.js
/usr/lib/nodejs/babel-loader/lib/utils/read.js
/usr/lib/nodejs/babel-loader/lib/utils/relative.js
/usr/share/doc/node-babel-loader/README.md.gz
/usr/share/doc/node-babel-loader/changelog.Debian.gz
/usr/share/doc/node-babel-loader/copyright

Changelog

2018-12-26 - Daniel Ring <dring@wolfishly.me>
node-babel-loader (7.1.5-1) unstable; urgency=medium
* New upstream release
2017-12-13 - Daniel Ring <dring@wolfishly.me>
node-babel-loader (7.1.2-4) unstable; urgency=low
* Added node-babel-core to depends list and webpack to enhances list
2017-10-03 - Pirate Praveen <praveen@debian.org>
node-babel-loader (7.1.2-3) unstable; urgency=medium
* Team upload
* babel command is now babeljs
2017-09-26 - Daniel Ring <dring@wolfishly.me>
node-babel-loader (7.1.2-2) unstable; urgency=low
* Moved to main as all dependencies and build-deps are now in main
2017-09-13 - Daniel Ring <dring@wolfishly.me>
node-babel-loader (7.1.2-1) unstable; urgency=low
* Initial release (Closes: #845130)
* Fixed build process to use only packages in Debian

See Also

Package Description
node-babel-messages_6.26.0+dfsg-3build6_all.deb Collection of debug messages used by Babel
node-babel-plugin-add-module-exports_0.2.1-3_all.deb Babel plugin for default module.exports like babel version 5
node-babel-plugin-array-includes_2.0.3-1_all.deb Babel plugin to replace the array includes syntax
node-babel-plugin-external-helpers_6.26.0+dfsg-3build6_all.deb helper functions that’ll be placed at the top of the generated code
node-babel-plugin-precompile-charcodes_1.1.0-2_all.deb Convert character code getters into plain integers
node-babel-plugin-syntax-async-functions_6.26.0+dfsg-3build6_all.deb Allow parsing of async functions
node-babel-plugin-syntax-async-generators_6.26.0+dfsg-3build6_all.deb Allow parsing of async generators
node-babel-plugin-syntax-class-constructor-call_6.26.0+dfsg-3build6_all.deb Allow parsing of class constructor calls
node-babel-plugin-syntax-class-properties_6.26.0+dfsg-3build6_all.deb Allow parsing of class properties
node-babel-plugin-syntax-decorators_6.26.0+dfsg-3build6_all.deb Allow parsing of decorators
node-babel-plugin-syntax-do-expressions_6.26.0+dfsg-3build6_all.deb Allow parsing of do expressinos
node-babel-plugin-syntax-dynamic-import_6.26.0+dfsg-3build6_all.deb Allow parsing of import
node-babel-plugin-syntax-exponentiation-operator_6.26.0+dfsg-3build6_all.deb Allow parsing of the exponentiation operator
node-babel-plugin-syntax-export-extensions_6.26.0+dfsg-3build6_all.deb Allow parsing of export extensions
node-babel-plugin-syntax-flow_6.26.0+dfsg-3build6_all.deb Allow parsing of the flow syntax
Advertisement
Advertisement