node-async_0.8.0-3_all.deb


Advertisement

Description

node-async - functions and patterns for asynchronous code - Node.js

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-async_0.8.0-3_all.deb
Package name node-async
Package version 0.8.0
Package release 3
Package architecture all
Package type deb
Category universe/web
Homepage https://github.com/caolan/async
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.77 KB
Installed size 29.00 KB
Async is a utility module which provides straight-forward, powerful
functions for working with asynchronous Javascript.
Async provides around 20 functions that include the usual 'functional'
suspects (map, reduce, filter, forEach…) as well as some common
patterns for asynchronous control flow (parallel, series, waterfall…).
All these functions assume you follow the Node convention of providing
a single callback as the last argument of your async function.
This provides async for use with Node.js -
an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-async_0.8.0-3_all.deb 0.8.0 all Ubuntu Universe
node-async - - -

Requires

Name Value
libjs-async -
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-async_0.8.0-3_all.deb
Source Package node-async

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-async deb package:
    # sudo apt-get install node-async

Files

Path
/usr/lib/nodejs/async/index.js
/usr/lib/nodejs/async/package.json
/usr/share/doc/node-async/README.md.gz
/usr/share/doc/node-async/changelog.Debian.gz
/usr/share/doc/node-async/copyright

Changelog

2018-01-07 - Jonas Smedegaard <dr@jones.dk>
node-async (0.8.0-3) unstable; urgency=medium
* Use short-form dh sequencer (not cdbs).
Stop build-depend on cdbs.
* Add patch 1001 to modernize testsuite: Replace pre-0.12 Node.js
process.binding('evals') with require('vm') in testsuite.
* Run testsuite.
Build-depend on nodeunit.
2018-01-07 - Jonas Smedegaard <dr@jones.dk>
node-async (0.8.0-2) unstable; urgency=medium
* Modernize cdbs:
+ Drop upstream-tarball hints: Use gbp import-orig --uscan.
+ Do copyright-check in maintainer script (not during build).
+ Stop build-depend on devscripts.
* Modernize git-buildpackage config:
+ Avoid git- prefix.
+ Filter any .git* file.
* Update watch file:
+ Bump file format to version 4.
+ Use github pattern from documentation.
+ Set repacksuffix.
+ Add usage comment.
+ Use substitution strings.
* Update package relations:
+ Stop fallback-build-depend on yui-compressor: Unneeded since
squeeze.
+ Fix stop libjs-async bogus dependency on nodejs.
+ Fix have libjs-async recommend javascript-common.
+ Stop build-depend on dh-buildinfo.
* Stop resolve build-dependencies indirectly in rules file.
* Modernize Vcs-* fields:
+ Use protocol https (not http or git).
+ Use git (not cgit) in path.
+ Include .git suffix in path.
* Use package section javascript (not web).
* Improve short and long descriptions.
* Declare compliance with Debian Policy 4.1.3.
* Use dephelper compatibility level 9 (not 8).
* Fix deduplicate code: Have node-async symlink from and depend on
libjs-async.
* Fix install nodejs code into subdirectory.
Closes: Bug#772835. Thanks to Olliver Schinagl.
* Tighten rules file: Generalize resolving JavaScript source files.
* Update copyright info:
+ Use https protocol in file format URL.
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend coverage for myself.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
2014-05-02 - Jonas Smedegaard <dr@jones.dk>
node-async (0.8.0-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Bump standards-version to 3.9.5.
* Update Vcs-* fields: Packaging git moved to pkg-javascript area of
Alioth.
* Update copyright info:
+ Extend coverage for myself.
+ Extend copyright coverage for main upstream author.
* Fix use TLS in CDBS get-orig-source target, and update URL to not
use "v" prefix.
* Stop suppress uglified files from copyright check: No longer
included in upstream source.
* Build-depend on devscript (needed for copyright check).
* Install package.json.
2013-08-15 - Jonas Smedegaard <dr@jones.dk>
node-async (0.2.5-1) unstable; urgency=low
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Stop tracking md5sum of upstream tarball.
* Bump packaging license to GPL-3+, and extend copyrigt coverage for
myself to include current year.
* Have git-import-orig suppress upstream .gitignore file.
* List upstream issue tracker as preferred contact.
* Bump standards-version to 3.9.4.
* Unset executable bit on library files.
2012-12-13 - Jonas Smedegaard <dr@jones.dk>
node-async (0.1.22-2) unstable; urgency=low
* Fix build-depend on node-uglify (not libnode-uglify).
Closes: bug#695814. Thanks to Adam Conrad.
* Update watch and rules files to directly use github.com URL (not
githubredir.debian.net).
* Bump dephelper compatibility level to 8.
* Update copyright file:
+ Fix use pseudo-comment section to obey silly restrictions of
copyright format 1.0.
2012-06-01 - Jonas Smedegaard <dr@jones.dk>
node-async (0.1.22-1) unstable; urgency=low
* New upstream release.
+ Avoid double calling tasks in auto when one or more tasks are
synchronous.
* Extend copyright of packaging to cover 2012.

See Also

Package Description
node-asynckit_0.4.0-2_all.deb Minimal async jobs utility library, with streams support
node-auto-bind_1.2.0-1_all.deb Automatically bind methods to their class instance
node-autolinker_1.8.3+dfsg-1_all.deb Utility for automatically linking URLs, emails, etc. in text
node-autoprefixer_8.6.5-2_all.deb add vendor prefixes to CSS rules
node-autosize_4.0.2~dfsg1-3_all.deb script to automatically adjust textarea height to fit text - Javascript
node-aws-sign2_0.7.1-1_all.deb AWS signing in JavaScript
node-aws4_1.8.0-1_all.deb Signs and prepares requests using AWS Signature Version 4
node-axios_0.17.1+dfsg-1_all.deb Promise based HTTP client for the browser and node.js
node-babel-cli_6.26.0+dfsg-3build6_all.deb Babel command line
node-babel-code-frame_6.26.0+dfsg-3build6_all.deb generate errors that contain a code frame that point to source locations
node-babel-core_6.26.0+dfsg-3build6_all.deb Babel compiler core
node-babel-eslint_7.2.3-2_all.deb Custom parser for ESLint
node-babel-generator_6.26.0+dfsg-3build6_all.deb Turns an AST into code
node-babel-helper-bindify-decorators_6.26.0+dfsg-3build6_all.deb Helper function to bindify decorators
node-babel-helper-builder-binary-assignment-operator-visitor_6.26.0+dfsg-3build6_all.deb Helper function to build binary assignment operator visitors
Advertisement
Advertisement