node-assertive_3.0.1+ds-1_all.deb


Advertisement

Description

node-assertive - assertion library, designed for coffee-script

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename node-assertive_3.0.1+ds-1_all.deb
Package name node-assertive
Package version 3.0.1+ds
Package release 1
Package architecture all
Package type deb
Category universe/javascript
Homepage https://github.com/groupon/assertive
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 18.88 KB
Installed size 72.00 KB
Assertive aims to make the exact cause of breakage and intent of tests as fast
and easy to spot as possible, with much attention paid to both the colour and
alignment of expected and actual data, so you should be able to glean what you
need immediately.
It also tries to pre-empt false negative tests from ever happening, by
rigorously testing for correct assertion invocation and by avoiding to pick
names for assertions with a track record of being misinterpreted, not just by
people reading the code, but also by programmers writing them.
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-assertive_3.0.1+ds-1_all.deb 3.0.1+ds all Ubuntu Universe
node-assertive - - -

Requires

Name Value
node-lodash-packages >= 4.6.1
nodejs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package node-assertive_3.0.1+ds-1_all.deb
Source Package node-assertive

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-assertive deb package:
    # sudo apt-get install node-assertive

Files

Path
/usr/lib/nodejs/assertive/package.json
/usr/lib/nodejs/assertive/lib/assertive.js
/usr/lib/nodejs/assertive/lib/assertive.js.map
/usr/share/doc/node-assertive/README.md.gz
/usr/share/doc/node-assertive/changelog.Debian.gz
/usr/share/doc/node-assertive/copyright

Changelog

2018-10-31 - Bastien Roucariès <rouca@debian.org>
node-assertive (3.0.1+ds-1) unstable; urgency=medium
* Team upload
* New upstream version
* Bump policy: use Rules-Requires-Root: no
2018-05-18 - Bastien Roucariès <rouca@debian.org>
node-assertive (3.0.0+ds-4) unstable; urgency=medium
* Team upload
* Really fix node assertive
2018-05-18 - Bastien Roucariès <rouca@debian.org>
node-assertive (3.0.0+ds-3) unstable; urgency=medium
* Fix a typo in depends
2018-05-14 - Bastien Roucariès <rouca@debian.org>
node-assertive (3.0.0+ds-2) unstable; urgency=medium
* Fix depends thus cli
2018-05-13 - Bastien Roucariès <rouca@debian.org>
node-assertive (3.0.0+ds-1) unstable; urgency=medium
* Team upload
* New upstream version
* Repack in order to avoid generated file
* Bump compat and policy
2017-10-20 - Ross Gammon <rossgammon@debian.org>
node-assertive (2.1.1-1) unstable; urgency=low
* Initial release (Closes: #845036)

See Also

Package Description
node-ast-types_0.11.7-1_all.deb Esprima-compatible implementation of the Mozilla JS Parser API
node-ast-util_0.6.0-2_all.deb Utilities for AST transformers
node-astw_2.2.0-2build1_all.deb walk the ast with references to parent nodes
node-async-each_1.0.1-1_all.deb async parallel forEach / map function for JavaScript
node-async-stacktrace_0.0.2-3_all.deb Improve Node.js stacktraces and make it easier to handle errors
node-async_0.8.0-3_all.deb functions and patterns for asynchronous code - Node.js
node-asynckit_0.4.0-2_all.deb Minimal async jobs utility library, with streams support
node-auto-bind_1.2.0-1_all.deb Automatically bind methods to their class instance
node-autolinker_1.8.3+dfsg-1_all.deb Utility for automatically linking URLs, emails, etc. in text
node-autoprefixer_8.6.5-2_all.deb add vendor prefixes to CSS rules
node-autosize_4.0.2~dfsg1-3_all.deb script to automatically adjust textarea height to fit text - Javascript
node-aws-sign2_0.7.1-1_all.deb AWS signing in JavaScript
node-aws4_1.8.0-1_all.deb Signs and prepares requests using AWS Signature Version 4
node-axios_0.17.1+dfsg-1_all.deb Promise based HTTP client for the browser and node.js
node-babel-cli_6.26.0+dfsg-3build6_all.deb Babel command line
Advertisement
Advertisement