nigiri_1.4.0+git20160822+dfsg-4.1_all.deb


Advertisement

Description

nigiri - D-Bus-based IRC suite (terminal client)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename nigiri_1.4.0+git20160822+dfsg-4.1_all.deb
Package name nigiri
Package version 1.4.0+git20160822+dfsg
Package release 4.1
Package architecture all
Package type deb
Category universe/net
Homepage https://github.com/sushi-irc
License -
Maintainer Devid Antonio Filoni <d.filoni@ubuntu.com>
Download size 34.58 KB
Installed size 241.00 KB
The sushi IRC suite consists of a central daemon and several clients, which
communicate via DBus. DBus methods and signals are provided by the daemon to
abstract the IRC protocol. Clients can use these methods and signals to
easily interact with IRC.
nigiri is a terminal client for maki and is written in Python. It uses Urwid
to realize the interface and supports plugins.

Alternatives

Package Version Architecture Repository
nigiri_1.4.0+git20160822+dfsg-4.1_all.deb 1.4.0+git20160822+dfsg all Ubuntu Universe
nigiri - - -

Requires

Name Value
maki -
python-dbus -
python-gobject -
python-urwid >= 0.9.8
python-xdg -
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package nigiri_1.4.0+git20160822+dfsg-4.1_all.deb
Source Package sushi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nigiri deb package:
    # sudo apt-get install nigiri

Files

Path
/usr/bin/nigiri
/usr/share/doc/nigiri/changelog.Debian.gz
/usr/share/doc/nigiri/copyright
/usr/share/locale/ast/LC_MESSAGES/nigiri.mo
/usr/share/locale/da/LC_MESSAGES/nigiri.mo
/usr/share/locale/de/LC_MESSAGES/nigiri.mo
/usr/share/locale/en_AU/LC_MESSAGES/nigiri.mo
/usr/share/locale/en_GB/LC_MESSAGES/nigiri.mo
/usr/share/locale/es/LC_MESSAGES/nigiri.mo
/usr/share/locale/fi/LC_MESSAGES/nigiri.mo
/usr/share/locale/fr/LC_MESSAGES/nigiri.mo
/usr/share/locale/he/LC_MESSAGES/nigiri.mo
/usr/share/locale/id/LC_MESSAGES/nigiri.mo
/usr/share/locale/it/LC_MESSAGES/nigiri.mo
/usr/share/locale/nl/LC_MESSAGES/nigiri.mo
/usr/share/locale/pt_BR/LC_MESSAGES/nigiri.mo
/usr/share/locale/ro/LC_MESSAGES/nigiri.mo
/usr/share/locale/ru/LC_MESSAGES/nigiri.mo
/usr/share/locale/sv/LC_MESSAGES/nigiri.mo
/usr/share/locale/ta/LC_MESSAGES/nigiri.mo
/usr/share/locale/tr/LC_MESSAGES/nigiri.mo
/usr/share/man/man1/nigiri.1.gz
/usr/share/nigiri/commands.py
/usr/share/nigiri/config.py
/usr/share/nigiri/connection.py
/usr/share/nigiri/input_history.py
/usr/share/nigiri/main.py
/usr/share/nigiri/messages.py
/usr/share/nigiri/plugin_control.py
/usr/share/nigiri/signals.py
/usr/share/nigiri/sushi.py
/usr/share/nigiri/tabs.py
/usr/share/nigiri/typecheck.py
/usr/share/nigiri/extends/BoxAdapter.py
/usr/share/nigiri/extends/Edit.py
/usr/share/nigiri/extends/ListBox.py
/usr/share/nigiri/extends/__init__.py
/usr/share/nigiri/helper/__init__.py
/usr/share/nigiri/helper/code.py
/usr/share/nigiri/helper/dcc.py
/usr/share/nigiri/helper/escape.py
/usr/share/nigiri/helper/iowatch.py
/usr/share/nigiri/helper/log.py
/usr/share/nigiri/helper/markup.py
/usr/share/nigiri/helper/tabcompletion.py
/usr/share/nigiri/plugins/general_output.py
/usr/share/python/runtime.d/nigiri.rtupdate

Changelog

2018-05-09 - Peter Michael Green <plugwash@raspbian.org>
sushi (1.4.0+git20160822+dfsg-4.1) unstable; urgency=medium
* Non-maintainer upload
* Add patch to fix build with miniupnpc 2.0. Thanks to nanard for the
suggested fix (Closes: #889055)
2017-03-20 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.4.0+git20160822+dfsg-4) unstable; urgency=medium
* Revert following change introduced in 1.4.0+git20160822+dfsg-3, it
it not suitable during the freeze:
Fix package-uses-deprecated-debhelper-compat-version lintian warning
switching to debhelper 9.
2017-03-18 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.4.0+git20160822+dfsg-3) unstable; urgency=medium
* Fix FTBFS with bash as /bin/sh (Closes: #857772)
Thanks to Chris Lamb for fixing this.
* Fix package-uses-deprecated-debhelper-compat-version lintian warning
switching to debhelper 9.
* Fix empty-binary-package lintian warning
Thanks to Adrian Vondendriesch for fixing this.
* debian/control: both tekka and nigiri are now sushi deps (Closes: #836195)
* Fix spelling-error-in-description-synopsis lintian warning.
* Fix nigiri crashes:
- debian/patches/nigiri-00-fix-gobject-import.diff: fix GObject ImportError
- debian/patches/nigiri-01-fix-urwid-indexerror.diff: fix urwid
'IndexError: No widget at position 1' error
- debian/patches/nigiri-02-none-has-no-auto_scroll.diff: fix AttributeError
* debian/control: remove DM-Upload-Allowed field.
2016-08-22 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.4.0+git20160822+dfsg-1) unstable; urgency=medium
* New upstream git tarball (Closes: #811889)
- debian/control: require libglib2.0-dev >= 2.40 in Build-Depends field
* debian/rules: provide get-orig-source target.
* debian/rules: fix build with dpkg-buildpackage -A (Closes: #806659)
* debian/rules: pass LDFLAGS to waf, fixes hardening-no-relro lintian warn.
* debian/rules: fix hardening-no-bindnow lintian info.
* Fix a crash on maki start:
- debian/patches/maki-revert-3bb2b23.diff: revert upstream maki
commit 3bb2b23 and re-enable gupnp support as gupnp deadlock was fixed
time ago, see: https://bugzilla.gnome.org/show_bug.cgi?id=667494
- debian/control: add libgupnp-igd-1.0-dev to Build-Depends field
* debian/control: update Homepage field.
* debian/copyright: update file.
* Bump Standards-Version to 3.9.8.
2015-09-03 - Andrey Rahmatullin <wrar@debian.org>
sushi (1.4.0+dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Port from python-support to dh-python (Closes: #786204)
2012-06-09 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.4.0+dfsg-1) unstable; urgency=low
* New upstream release (Closes: #655964, #638661, #640420, #652783).
* Remove 01_deprecated-gnutls-2.12.diff patch, not needed anymore.
* Update debian/copyright file.
* Fix source-contains-waf-binary lintian error (Closes: #654507).
* Update debian/README.source file.
* debian/rules: remove generated waflib/*.pyc in override_dh_auto_clean
target.
* debian/rules: remove package-contains-empty-directory lintian info
workaround, not needed anymore.
* debian/control: adjust Build-Depends field according to upstream.
* Rename sushi-plugins package to chirashi and add sushi meta-package and
maki-plugins package. Thanks to Michael Kuhn
for this.
* debian/control: update Homepage field.
* Bump Standards-Version to 3.9.3.
[ Luca Falavigna ]
* Enable DM upload.
2011-04-25 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.3.0+dfsg-2) unstable; urgency=low
* Add 01_deprecated-gnutls-2.12.diff patch to replace deprecated
gnutls_certificate_verify_peers with gnutls_certificate_verify_peers2
function (Closes: #624081).
* Fix package-contains-empty-directory lintian info.
* Bump Standards-Version to 3.9.2.
2011-03-11 - Devid Antonio Filoni <d.filoni@ubuntu.com>
sushi (1.3.0+dfsg-1) unstable; urgency=low
* Initial release (Closes: #575571).

See Also

Package Description
nik4_1.6-5_amd64.deb Mapnik to image export
nikwi-data_0.0.20120213-4_all.deb platform game where your goal is to collect candies - game data
nikwi_0.0.20120213-4_amd64.deb platform game where your goal is to collect candies
nilfs-tools_2.2.7-1_amd64.deb Continuous Snapshotting Log-structured Filesystem
nim-doc_0.19.4-1_all.deb Nim programming language - documentation
nim_0.19.4-1_amd64.deb Nim programming language - compiler
ninix-aya_5.0.9-1_amd64.deb Interactive fake-AI Ukagaka-compatible desktop mascot program
ninja-build_1.8.2-1_amd64.deb small build system closest in spirit to Make
ninja-ide_2.3-2_all.deb integrated development environment (IDE) for Python
ninka-backend-excel_1.3.2-3_all.deb license identification tool for source code (Excel backend)
ninka-backend-sqlite_1.3.2-3_all.deb license identification tool for source code (SQLite backend)
ninka_1.3.2-3_amd64.deb license identification tool for source code
ninvaders_0.1.1-3build3_amd64.deb A space invaders-like game using ncurses
nip2_8.7.0-1_amd64.deb spreadsheet-like graphical image manipulation tool
nis_3.17.1-3build1_amd64.deb clients and daemons for the Network Information Service (NIS)
Advertisement
Advertisement