nghttp2-client_1.36.0-2_amd64.deb


Advertisement

Description

nghttp2-client - client implementing HTTP/2 protocol

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename nghttp2-client_1.36.0-2_amd64.deb
Package name nghttp2-client
Package version 1.36.0
Package release 2
Package architecture amd64
Package type deb
Category universe/httpd
Homepage https://nghttp2.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 150.23 KB
Installed size 550.00 KB
This is a command line client implementing the HTTP/2 protocol. It
gives access to many low-level and advanced aspects of the protocol
and therefore is useful for debugging.

Alternatives

Package Version Architecture Repository
nghttp2-client_1.36.0-2_i386.deb 1.36.0 i386 Ubuntu Universe
nghttp2-client - - -

Requires

Name Value
libc6 >= 2.14
libev4 >= 1:4.04
libgcc1 >= 1:3.0
libjansson4 >= 2.0.1
libjemalloc2 >= 5.0.0
libnghttp2-14 = 1.36.0-2
libssl1.1 >= 1.1.0
libstdc++6 >= 7
libxml2 >= 2.7.4
lsb-base -
zlib1g >= 1:1.1.4

Replaces

Name Value
nghttp2 << 1.3.4-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package nghttp2-client_1.36.0-2_amd64.deb
Source Package nghttp2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nghttp2-client deb package:
    # sudo apt-get install nghttp2-client

Files

Path
/usr/bin/h2load
/usr/bin/nghttp
/usr/share/doc/nghttp2-client/AUTHORS
/usr/share/doc/nghttp2-client/README.rst.gz
/usr/share/doc/nghttp2-client/changelog.Debian.gz
/usr/share/doc/nghttp2-client/copyright
/usr/share/man/man1/h2load.1.gz
/usr/share/man/man1/nghttp.1.gz

Changelog

2019-02-03 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.36.0-2) unstable; urgency=medium
* d/*: drop support for spdy (Closes: #920988)
2019-01-23 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.36.0-1) unstable; urgency=medium
* Packaging refresh (debhelper 12, std-ver 4.3.0)
* New upstream release 1.36.0
2018-12-14 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.35.1-1) unstable; urgency=medium
* New upstream version 1.35.1
2018-11-26 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.35.0-1) unstable; urgency=medium
* New upstream version 1.35.0
2018-10-11 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.34.0-1) unstable; urgency=medium
* Imported upstream version 1.34.0
2018-09-07 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.33.0-1) unstable; urgency=medium
* Imported upstream version 1.33.0
2018-09-01 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.32.1-1) unstable; urgency=medium
* Imported upstream version 1.32.1
* Update debian control with "cme fix dpkg-control"
2018-05-19 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.32.0-1) unstable; urgency=medium
* Imported upstream version 1.32.0
2018-04-21 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.31.1-1) unstable; urgency=medium
* Imported upstream version 1.31.1 (fixes CVE-2018-1000168)
2018-03-06 - Tomasz Buchert <tomasz@debian.org>
nghttp2 (1.31.0-1) unstable; urgency=medium
* Imported upstream version 1.31.0
* Update symbols of libnghttp2

See Also

Package Description
nghttp2-proxy_1.36.0-2_amd64.deb reverse proxy implementing HTTP/2 protocol
nghttp2-server_1.36.0-2_amd64.deb server implementing HTTP/2 protocol
nghttp2_1.36.0-2_all.deb server, proxy and client implementing HTTP/2
nginx-extras_1.15.9-0ubuntu1_amd64.deb nginx web/proxy server (extended version)
nginx-full_1.15.9-0ubuntu1_amd64.deb nginx web/proxy server (standard version)
nginx-light_1.15.9-0ubuntu1_amd64.deb nginx web/proxy server (basic version)
ngircd_25-2_amd64.deb lightweight Internet Relay Chat server
nglister_1.0.2_all.deb Downloads information from NNTP server
ngraph-gtk-addin-import-ps_6.08.00-1.1_all.deb import-ps addin of Ngraph-gtk
ngraph-gtk-addin-spellcheck_6.08.00-1.1_all.deb spell check addin of Ngraph-gtk
ngraph-gtk-addin-tex-equation_6.08.00-1.1_all.deb tex-equation addin of Ngraph-gtk
ngraph-gtk-addins-base_6.08.00-1.1_amd64.deb addins of Ngraph-gtk - base programs
ngraph-gtk-addins_6.08.00-1.1_all.deb addin collection of Ngraph-gtk
ngraph-gtk-doc_6.08.00-1.1_all.deb documents of Ngraph-gtk
ngraph-gtk-plugin-ruby_6.08.00-1.1_amd64.deb Ruby plugin for Ngraph-gtk
Advertisement
Advertisement