netmask_2.4.4-1_amd64.deb


Advertisement

Description

netmask - helps determine network masks

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename netmask_2.4.4-1_amd64.deb
Package name netmask
Package version 2.4.4
Package release 1
Package architecture amd64
Package type deb
Category universe/net
Homepage https://github.com/tlby/netmask
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 23.55 KB
Installed size 54.00 KB
This is a tiny program handy if you work with firewalls or routers
occasionally (possibly using this as a helper for shell scripts).  It can
determine the smallest set of network masks to specify a range of hosts.
It can also convert between common IP netmask and address formats.

Alternatives

Package Version Architecture Repository
netmask_2.4.4-1_i386.deb 2.4.4 i386 Ubuntu Universe
netmask - - -

Requires

Name Value
libc6 >= 2.7

Download

Type URL
Mirror archive.ubuntu.com
Binary Package netmask_2.4.4-1_amd64.deb
Source Package netmask

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install netmask deb package:
    # sudo apt-get install netmask

Files

Path
/usr/bin/netmask
/usr/share/doc/netmask/README
/usr/share/doc/netmask/changelog.Debian.gz
/usr/share/doc/netmask/copyright
/usr/share/info/netmask.info.gz
/usr/share/man/man1/netmask.1.gz

Changelog

2019-02-05 - Guilhem Moulin <guilhem@debian.org>
netmask (2.4.4-1) unstable; urgency=medium
[ Robert Stone ]
* New upstream release.
[ Guilhem Moulin ]
* d/upstream/signing-key.asc: Minimize upstream's OpenPGP certificate.
* d/control: Bump Standards-Version to 4.3.0 (no changes necessary).
* d/control, d/combat: Bump debhelper compatibility level to 12, hence
remove dh-autoreconf to Build-Depends.
2018-06-05 - Guilhem Moulin <guilhem@debian.org>
netmask (2.4.3-3) unstable; urgency=low
* debian/control:
+ Bump Standards-Version to 4.1.4 (no changes necessary).
+ Migrate Vcs-Browser and Vcs-Git from Alioth to Salsa.
2017-07-08 - Guilhem Moulin <guilhem@debian.org>
netmask (2.4.3-2) unstable; urgency=low
* debian/rules: Add 'hardening=+bindnow,+pie' to DEB_BUILD_MAINT_OPTIONS to
compile ELF executables as PIEs and allow the PLT to be marked read-only.
* debian/control:
+ Bump Standards-Version to 4.0.0 (no changes necessary).
+ Upgrade Vcs-Git URI from git:// to https://.
2015-10-05 - Guilhem Moulin <guilhem@guilhem.org>
netmask (2.4.3-1) unstable; urgency=low
[ Robert Stone ]
* New upstream release.  (Closes: #802884.)
[ Guilhem Moulin ]
* debian/patches:
+ Make the build reproducible: setting --version twice no longer prints
the build timestamp.
* debian/control:
+ Change 'Vcs-Git' and 'Vcs-Browser' fields to use collab-maint.
+ Set 'Multi-Arch: foreign'.
* debian/patches:
+ Remove 'Add foreign to AM_INIT_AUTOMAKE macro' patch, applied upstream.
* Fix debian/watch file.
2015-09-29 - Guilhem Moulin <guilhem@guilhem.org>
netmask (2.4.2-1) unstable; urgency=low
[ Robert Stone ]
* New upstream release.  (Closes: #79512.)
[ Guilhem Moulin ]
* New maintainer.  (Closes: #784185.)
* debian/compat: bump debhelper compatibility level from 4 to 9.
* debian/source/format: 3.0 (quilt)
* debian/control:
+ Bump Standards-Version to 3.9.6 (no changes necessary).
+ Add 'Homepage', 'Vcs-Git', 'Vcs-Browser' fields.
+ Add 'dh-autoreconf' and 'texinfo' to Build-Depends.
* debian/copyright: convert to machine-readable format (1.0).
* debian/gbp.conf: add file.
* debian/patches:
+ netmask.texi: Add the missing '@direntry' to the info document.
+ Add foreign to AM_INIT_AUTOMAKE macro.
* Remove debian.{dirs,info}, which are taken care of by the upstream build
system.
* debian/watch: add file.
* debian/upstream/metadata: add file.
* debian/upstream/signing-key.asc: add keyfile used to sign upstream release
tags.
2010-04-24 - Luis Uribe <acme@eviled.org>
netmask (2.3.12) unstable; urgency=low
* Include patches directly in source because it's a native package
* debian/control
- Bump debian standards version to 3.8.4 (No changes)
* Switch to dpkg-source 3.0 (native) format
2009-11-18 - Luis Uribe <acme@eviled.org>
netmask (2.3.11) unstable; urgency=low
* Adding quilt for manage patches
* debian/control
- Bump debian standards version to 3.8.3 (No changes)
- Add dpkg (>= 1.15.4) | install-info and ${misc:Depends} to Depends:
* README.source
- Add file
* debian/compat
- Update to 5
* debian/copyright
- Change GPL2 symlink. Makes lintian happy.
* debian/rules
- Remove config.sub and config.guess in the clean target and copy the files
just before the "./configure" call.
2008-07-05 - Luis Uribe <acme@eviled.org>
netmask (2.3.10) unstable; urgency=low
* debian/rules
- Correct debian-rules-ignores-make-clean-error lintian warning.
* debian/control
- Bump debian standards version to 3.7.3 (No changes)
* debian/copyright
- Rewrite the Copyright notice.
2007-02-23 - Luis Uribe <acme@eviled.org>
netmask (2.3.9) unstable; urgency=low
* New maintainer (Closes: #389664)
* debian/rules
Remove commented dh_* commands

See Also

Package Description
netmate_0.2.0-9_amd64.deb netdude clone that shows pcap dump lines in network header style
netmaze_0.81+jpg0.82-16_amd64.deb 3-D Multiplayer Combat Game
netpanzer-data_0.8.7+ds-2_all.deb data files for the netPanzer game
netpanzer_0.8.7+ds-2_amd64.deb online multiplayer tactical warfare game
netpbm_10.0-15.3build1_amd64.deb Graphics conversion tools between image formats
netperfmeter-plotting_1.8.0-1_all.deb Network Performance Meter (plotting program)
netperfmeter_1.8.0-1_amd64.deb Network Performance Meter (measurement program)
netpipe-lam_3.7.2-7.4build3_amd64.deb Network performance tool using LAM MPI
netpipe-mpich2_3.7.2-7.4build3_amd64.deb Network performance tool using MPICH2 MPI
netpipe-openmpi_3.7.2-7.4build3_amd64.deb Network performance tool using OpenMPI
netpipe-pvm_3.7.2-7.4build3_amd64.deb Network performance tool using PVM
netpipe-tcp_3.7.2-7.4build3_amd64.deb Network performance tool using the TCP protocol
netpipes_4.2-8build1_amd64.deb manipulate BSD TCP/IP stream sockets
netplan_1.10.1-6_amd64.deb network server for `plan'
netplug_1.2.9.2-3_amd64.deb network link monitor daemon
Advertisement
Advertisement