needrestart-session_0.3-6_all.deb


Advertisement

Description

needrestart-session - check for processes need to be restarted in user sessions

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename needrestart-session_0.3-6_all.deb
Package name needrestart-session
Package version 0.3
Package release 6
Package architecture all
Package type deb
Category universe/admin
Homepage https://github.com/liske/needrestart-session
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 14.75 KB
Installed size 124.00 KB
needrestart checks which processes need to be restarted after library upgrades.
needrestart-session implements a notification of user sessions about their
obsolete processes after system upgrades.

Alternatives

Package Version Architecture Repository
needrestart-session_0.3-6_all.deb 0.3 all Ubuntu Universe
needrestart-session - - -

Requires

Name Value
adduser -
libnet-dbus-perl -
libproc-processtable-perl -
libwx-perl -
needrestart >= 2.0
perl:any -
policykit-1 -
wmctrl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package needrestart-session_0.3-6_all.deb
Source Package needrestart-session

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install needrestart-session deb package:
    # sudo apt-get install needrestart-session

Files

Path
/etc/dbus-1/system.d/net.ibh.NeedRestart.System.conf
/etc/needrestart/notify.d/300-needrestart-session
/etc/xdg/autostart/needrestart-dbus-session.desktop
/usr/bin/needrestart-session
/usr/lib/needrestart-session/needrestart-dbus-session
/usr/lib/needrestart-session/needrestart-dbus-system
/usr/lib/needrestart-session/needrestart-x11
/usr/share/applications/needrestart-session.desktop
/usr/share/applications/needrestart.desktop
/usr/share/dbus-1/system-services/net.ibh.NeedRestart.System.service
/usr/share/doc/needrestart-session/README.md
/usr/share/doc/needrestart-session/changelog.Debian.gz
/usr/share/doc/needrestart-session/copyright
/usr/share/lintian/overrides/needrestart-session
/usr/share/man/man1/needrestart-session.1.gz
/usr/share/needrestart-session/needrestart.svg
/usr/share/needrestart-session/needrestart.xpm

Changelog

2018-10-12 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-6) unstable; urgency=medium
* Bump Standards-Version to 4.2.1.
* Fix wrong redirection.
Closes: #908268
2017-07-27 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-5) unstable; urgency=low
* Acknowledge NMU. Thanks Paul!
* Bump debian/compat to level 10.
* Bump Standards-Version to 4.0.0 (no changes required).
2017-03-14 - Paul Wise <pabs@debian.org>
needrestart-session (0.3-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix path to needrestart, now shows same results (Closes: #787291)
* Don't fork before system(), fixes crash on double-click (Closes: #857703)
2017-03-10 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-4) unstable; urgency=high
* Add dependency on adduser and add/delete new system user needrestart-dbus.
Closes: #855788, #857077
2016-12-23 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-3) unstable; urgency=medium
* Bump Standards-Version to 3.9.8 (no changes required).
2015-04-29 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-2) unstable; urgency=low
* Upload to unstable.
2015-01-30 - Patrick Matthäi <pmatthaei@debian.org>
needrestart-session (0.3-1) experimental; urgency=low
* Initial release.
Closes: #776628

See Also

Package Description
needrestart_3.4-1_all.deb check which daemons need to be restarted after library upgrades
neko-dev_2.2.0-2build2_amd64.deb Lightweight virtual machine - headers
neko_2.2.0-2build2_amd64.deb Lightweight virtual machine - compiler and tools
nekobee_0.1.8~repack1-1_amd64.deb Simple single-oscillator DSSI plugin
nemiver_0.9.6-1.2_amd64.deb Standalone graphical debugger for GNOME
nemo-data_3.8.5-1build1_all.deb File manager and graphical shell for Cinnamon (data files)
nemo-extension-fma_3.4-2_amd64.deb Nemo extension to allow user-defined file-manager actions
nemo-fileroller_3.8.0-2_amd64.deb File Roller integration for Nemo
nemo-gtkhash_1.2-1_amd64.deb nemo extension for computing checksums and more using gtkhash
nemo-keyboard_0.99.0+git20130524+73edacd-0ubuntu2_all.deb pure QML keyboard for the Maliit framework
nemo-nextcloud_2.5.1-2_all.deb Nextcloud integration for Nemo
nemo-owncloud_2.5.1.10973+dfsg-1_all.deb ownCloud integration for Nemo
nemo-python_3.8.0-2_amd64.deb Python bindings for nemo components
nemo_3.8.5-1build1_amd64.deb File manager and graphical shell for Cinnamon
neo4j-client_2.2.0-1build1_amd64.deb Command line shell for the Neo4j graph database
Advertisement
Advertisement