nanopolish_0.11.0-2_amd64.deb


Advertisement

Description

nanopolish - consensus caller for nanopore sequencing data

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename nanopolish_0.11.0-2_amd64.deb
Package name nanopolish
Package version 0.11.0
Package release 2
Package architecture amd64
Package type deb
Category universe/science
Homepage https://github.com/jts/nanopolish
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.11 MB
Installed size 9.56 MB
Nanopolish uses a signal-level hidden Markov model for consensus calling
of nanopore genome sequencing data. It can perform signal-level analysis
of Oxford Nanopore sequencing data. Nanopolish can calculate an improved
consensus sequence for a draft genome assembly, detect base
modifications, call SNPs and indels with respect to a reference genome
and more.

Alternatives

Package Version Architecture Repository
nanopolish_0.11.0-2_i386.deb 0.11.0 i386 Ubuntu Universe
nanopolish - - -

Requires

Name Value
libc6 >= 2.27
libgcc1 >= 1:3.3.1
libgomp1 >= 4.9
libhdf5-103 -
libhts2 >= 1.4.1
libstdc++6 >= 5.2
python:any -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package nanopolish_0.11.0-2_amd64.deb
Source Package nanopolish

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nanopolish deb package:
    # sudo apt-get install nanopolish

Files

Path
/usr/bin/nanopolish
/usr/lib/nanopolish/calculate_methylation_frequency.py
/usr/lib/nanopolish/consensus-preprocess.pl
/usr/lib/nanopolish/consensus.make
/usr/lib/nanopolish/convert_all_models.py
/usr/lib/nanopolish/convert_model_to_header.py
/usr/lib/nanopolish/dropmodel.py
/usr/lib/nanopolish/extract_reads_aligned_to_region.py
/usr/lib/nanopolish/import_ont_model.py
/usr/lib/nanopolish/import_ont_models_from_dir.sh
/usr/lib/nanopolish/nanopolish_makerange.py
/usr/lib/nanopolish/nanopolish_merge.py
/usr/lib/nanopolish/nanopolish_test
/usr/lib/nanopolish/reestimate_polya_emissions.py
/usr/share/doc/nanopolish/README.Debian
/usr/share/doc/nanopolish/README.md.gz
/usr/share/doc/nanopolish/changelog.Debian.gz
/usr/share/doc/nanopolish/copyright
/usr/share/doc/nanopolish/examples/data/LomanLabz_PC_Ecoli_K12_R7.3_2549_1_ch8_file30_strand.fast5
/usr/share/man/man1/nanopolish.1.gz
/usr/share/python/runtime.d/nanopolish.rtupdate

Changelog

2019-01-27 - Andreas Tille <tille@debian.org>
nanopolish (0.11.0-2) unstable; urgency=medium
* Team upload.
[ Matthias Klose ]
* Fix autopkg test.
* Fix autopkg test dependency.
[ Andreas Tille ]
* Secure URI in copyright format
* Remove trailing whitespace in debian/copyright
2019-01-24 - Andreas Tille <tille@debian.org>
nanopolish (0.11.0-1) unstable; urgency=medium
* Team upload.
* Recommends: python-pysam, python-biopython
* debhelper 12
* Standards-Version: 4.3.0
* Fix permissions
* Fix path for Python interpreter
* Better care for Python scripts
2018-09-13 - Andreas Tille <tille@debian.org>
nanopolish (0.10.2-1) unstable; urgency=medium
* Team upload.
* New upstream version
* debhelper 11
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.2.1
* Fix path for Perl interpreter
* Enhance long description
2018-02-17 - Afif Elghraoui <afif@debian.org>
nanopolish (0.9.0-1) unstable; urgency=medium
* New upstream version
* Refresh patches
* Bump upstream copyright year
* Bump minimum required fast5 version
* Include upstream patch to fix HDF5 errors appearing in autopkgtest
2018-02-04 - Afif Elghraoui <afif@debian.org>
nanopolish (0.8.5-2) unstable; urgency=low
* Remove dependency on nonexistent package sse-support [i386]
2018-02-04 - Afif Elghraoui <afif@debian.org>
nanopolish (0.8.5-1) unstable; urgency=medium
* New upstream version
* d/control:
+ Add sse-support to Build-Depends for i386
+ Remove explicit declaration of x32
* Bump Standards-Version to 4.1.3
* Drop patches applied upstream
* Drop useless patch
* Bump copyright years
2017-11-11 - Afif Elghraoui <afif@debian.org>
nanopolish (0.8.4-1) unstable; urgency=medium
[ Steffen Moeller ]
* upstream/metadata RRID->SciCrunch
[ Afif Elghraoui ]
* New upstream version
* Bump fast5 minimum version
* Update and refine patch stack
* Improve handling of external dependencies and build flags
* d/rules
+ Remove redundant LDFLAGS setting
+ Don't override upstream optimization flags with default -O2
* Bump Standards-Version to 4.1.1
2017-09-19 - Andreas Tille <tille@debian.org>
nanopolish (0.8.1-2) unstable; urgency=medium
* Team upload.
* Hack around broken clean target which tries to build dependencies from
external sources
* DEP3
* Fix path tp hdf5 lib on i386 (thanks for the hint to Christian Seiler
<christian@iwakd.de>)
* Restrict Architectures: any-amd64 any-i386 x32
since immintrin.h is a x86/amd64 specific header for intrinsics not
available on other architectures (Thanks for the hint to Gert Wollny
<gw.fossdev@gmail.com>)
* Depends: sse-support [any-i386] (thanks for the hint to Christian Seiler
<christian@iwakd.de>)
2017-09-14 - Steffen Moeller <moeller@debian.org>
nanopolish (0.8.1-1) unstable; urgency=medium
[ Steffen Moeller ]
* Team upload
* New upstream version (Closes: #853568)
- bumped dependency on fast5 to 0.6.2
- established compatibility with gcc/g++ 7
- needed some extra persuasion to not download
eigen library.
- added link-time optimisation
* debian/upstream/metadata: Added references to registries
[ Andreas Tille ]
* debhelper 10
* Standards-Version: 4.1.0 (no changes needed)
2016-08-12 - Afif Elghraoui <afif@debian.org>
nanopolish (0.5.0-1) unstable; urgency=medium
* Imported Upstream version 0.5.0
- Refresh and update patches
- Add build dependency on libeigen3
- Fix "clean" target
* Update email address and copyright year
* Fix compatibility with fast5 0.5.6

See Also

Package Description
nant_0.92~rc1+dfsg-6_all.deb build tool similar to Ant
nas-bin_1.9.4-6_amd64.deb Network Audio System - client binaries
nas-doc_1.9.4-6_all.deb Network Audio System - extra documentation
nas_1.9.4-6_amd64.deb Network Audio System - local server
nasm_2.14-1_amd64.deb General-purpose x86 assembler
naspro-bridges_0.5.1-2_amd64.deb collection of bridges to LV2
nast-ier_20101212+dfsg1-2_amd64.deb NAST-based DNA alignment tool
nast_0.2.0-7build1_amd64.deb packet sniffer and lan analyzer
nasty_0.6-3_amd64.deb tool which helps you to recover your GPG passphrase
nat-rtsp-dkms_0.7+4.18-0.1_all.deb Connection tracking and NAT support for RTSP
nat-traverse_0.7-1_all.deb NAT gateway traversal utility
natbraille-doc_2.0rc3-8_all.deb Documentation for natbraille
natbraille_2.0rc3-8_all.deb French braille typesetting program
natlog_2.01.01-1_amd64.deb Source-natting firewall logging utility
natpmp-utils_20150609-7_all.deb transitional package
Advertisement
Advertisement