mps-youtube_0.2.7.1-2ubuntu1_all.deb


Advertisement

Description

mps-youtube - Terminal based YouTube jukebox with playlist management

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mps-youtube_0.2.7.1-2ubuntu1_all.deb
Package name mps-youtube
Package version 0.2.7.1
Package release 2ubuntu1
Package architecture all
Package type deb
Category universe/utils
Homepage https://github.com/np1/mps-youtube
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 54.00 KB
Installed size 238.00 KB
This project is a terminal based YouTube client with an interactive text
interface and in-built help. It can be used to search YouTube, create local
playlists to queue your favourite content, play audio or video (launched in
external player) and can download YouTube content in various formats (mp4,
flv, webm, ogg, m4a, m4v and 3gp).

Alternatives

Package Version Architecture Repository
mps-youtube_0.2.7.1-2ubuntu1_all.deb 0.2.7.1 all Ubuntu Universe
mps-youtube - - -

Requires

Name Value
ffmpeg -
mpv -
python3-pafy >= 0.5.1
python3-pkg-resources -
python3:any >= 3.3.2-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mps-youtube_0.2.7.1-2ubuntu1_all.deb
Source Package mps-youtube

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mps-youtube deb package:
    # sudo apt-get install mps-youtube

Files

Path
/usr/bin/mpsyt
/usr/lib/python3/dist-packages/mps_youtube/__init__.py
/usr/lib/python3/dist-packages/mps_youtube/c.py
/usr/lib/python3/dist-packages/mps_youtube/cache.py
/usr/lib/python3/dist-packages/mps_youtube/config.py
/usr/lib/python3/dist-packages/mps_youtube/content.py
/usr/lib/python3/dist-packages/mps_youtube/g.py
/usr/lib/python3/dist-packages/mps_youtube/helptext.py
/usr/lib/python3/dist-packages/mps_youtube/history.py
/usr/lib/python3/dist-packages/mps_youtube/init.py
/usr/lib/python3/dist-packages/mps_youtube/main.py
/usr/lib/python3/dist-packages/mps_youtube/mpris.py
/usr/lib/python3/dist-packages/mps_youtube/paths.py
/usr/lib/python3/dist-packages/mps_youtube/player.py
/usr/lib/python3/dist-packages/mps_youtube/playlist.py
/usr/lib/python3/dist-packages/mps_youtube/playlists.py
/usr/lib/python3/dist-packages/mps_youtube/screen.py
/usr/lib/python3/dist-packages/mps_youtube/streams.py
/usr/lib/python3/dist-packages/mps_youtube/terminalsize.py
/usr/lib/python3/dist-packages/mps_youtube/util.py
/usr/lib/python3/dist-packages/mps_youtube-0.2.7.1.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/mps_youtube-0.2.7.1.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/mps_youtube-0.2.7.1.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/mps_youtube-0.2.7.1.egg-info/requires.txt
/usr/lib/python3/dist-packages/mps_youtube-0.2.7.1.egg-info/top_level.txt
/usr/lib/python3/dist-packages/mps_youtube/commands/__init__.py
/usr/lib/python3/dist-packages/mps_youtube/commands/album_search.py
/usr/lib/python3/dist-packages/mps_youtube/commands/config.py
/usr/lib/python3/dist-packages/mps_youtube/commands/download.py
/usr/lib/python3/dist-packages/mps_youtube/commands/local_playlist.py
/usr/lib/python3/dist-packages/mps_youtube/commands/misc.py
/usr/lib/python3/dist-packages/mps_youtube/commands/play.py
/usr/lib/python3/dist-packages/mps_youtube/commands/search.py
/usr/lib/python3/dist-packages/mps_youtube/commands/songlist.py
/usr/share/applications/mps-youtube.desktop
/usr/share/doc/mps-youtube/changelog.Debian.gz
/usr/share/doc/mps-youtube/copyright
/usr/share/man/man1/mpsyt.1.gz

Changelog

2017-06-26 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
mps-youtube (0.2.7.1-2ubuntu1) artful; urgency=medium
* Disable tests with Python 3.6 as well as 3.5. 
2016-10-19 - Zlatan Todoric <zlatan@debian.org>
mps-youtube (0.2.7.1-2) unstable; urgency=medium
* remove mplayer2 and libav-tools from Depends (Closes:#841182)
* add python3-gi and python3-dbus to Recommends for mpris2 support
* upstream pafy (Closes:#825169)
* change in maintainers email address
2016-07-04 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.7.1-1) unstable; urgency=medium
* New upstream release
* Bumped Standards-Version. No changes required
* debian/rules: disabled all tests as they require access to network
* debian/copyright: updated years
* debian/control: bumped version dependency on python3-pafy
2015-10-28 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.5-5) unstable; urgency=medium
* debian/control: replace python-notify with libnotify4 
* debian/control: remove X-Python3-Version (not needed)
* mpsyt.1: manpage rewritten to point to excellent built-in help
2015-10-25 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.5-4) unstable; urgency=medium
* Fixing FTBFS be adding pafy to Build-Depends (Closes:#802102)
2015-06-04 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.5-3) unstable; urgency=low
* debian/upstream: added upstream key
* debian/watch: updated for gpg release scans 
* debian/control: corrected dependency name from avconv to libav-tools
* debian/control: make mpv first choice instead of mplayer2
* debian/control: remove python3, we have ${python3:Depends}
2015-06-03 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.5-2) unstable; urgency=medium
* debian/mpsyt.1: correct the minus sign so lintian stops complaining 
* debian/control: add python3-pkg-resources to Depends
2015-06-01 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.2.5-1) unstable; urgency=medium
* New upstream release
* debian/control: Depends on ffmpeg | libav-tools
* debian/control: Recommends added python-notify and xclip
* debian/control: bump standards to 3.9.6; no changes needed
* debian/control: Architecture change from any to all
* Switch to Python 3, Python 2 dropped upstream
* changed all dependencies to Python 3 variants
* Updated to latest upstream for Youtube APIv3 (Closes:#785704)
* Small manpage tweak
* debian/rules: using now pybuild
2014-09-28 - Zlatan Todoric <zlatan@riseup.net>
mps-youtube (0.01.46-3) unstable; urgency=low
* debian/control: added python-setuptools to Build-Depends (Closes:#761607)
Thanks to Santiago Torres Batan on suggestion
* Change in maintainers email address
2014-07-06 - Zlatan Todoric <zlatan.todoric@gmail.com>
mps-youtube (0.01.46-2) unstable; urgency=low
* debian/control: removing virtual package as dependency, added mplayer2

See Also

Package Description
mpt-status_1.2.0-8build1_amd64.deb get RAID status out of mpt (and other) HW RAID controllers
mptp_0.2.4-1_amd64.deb single-locus species delimitation
mpv_0.29.1-1ubuntu1_amd64.deb video player based on MPlayer/mplayer2
mrb_0.3_all.deb Manage incremental data snapshots with make/rsync
mrbayes-doc_3.2.6+dfsg-2ubuntu2_all.deb Bayesian Inference of Phylogeny - manual
mrbayes-mpi_3.2.6+dfsg-2ubuntu2_amd64.deb Bayesian Inference of Phylogeny - mpi version
mrbayes_3.2.6+dfsg-2ubuntu2_amd64.deb Bayesian Inference of Phylogeny
mrboom_4.7-1_amd64.deb 8 player Bomberman
mrd6_0.9.6-13_amd64.deb IPv6 Multicast Routing Daemon
mrename_1.2-13_all.deb tool for easy and automatic renaming of many files
mriconvert_2.1.0-3_amd64.deb medical image file conversion utility
mricron-data_0.20140804.1~dfsg.1-3_all.deb data files for MRIcron
mricron-doc_0.20140804.1~dfsg.1-3_all.deb data files for MRIcron
mricron_0.20140804.1~dfsg.1-3_amd64.deb magnetic resonance image conversion, viewing and analysis
mrmpi-doc_1.0~20140404-2build1_all.deb Implements MapReduce operation on top of standard MPI message - doc
Advertisement
Advertisement