mpeg3-utils_1.8.dfsg-2.1_amd64.deb


Advertisement

Description

mpeg3-utils - MPEG streams decoding library

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mpeg3-utils_1.8.dfsg-2.1_amd64.deb
Package name mpeg3-utils
Package version 1.8.dfsg
Package release 2.1
Package architecture amd64
Package type deb
Category universe/utils
Homepage http://heroines.sourceforge.net/libmpeg3.php
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.09 KB
Installed size 62.00 KB
LibMPEG3 is a versatile and high-performance library capable
of decoding both audio and video from many different MPEG formats.
This package includes several utilities for working with MPEG2 streams.

Alternatives

Package Version Architecture Repository
mpeg3-utils_1.8.dfsg-2.1_i386.deb 1.8.dfsg i386 Ubuntu Universe
mpeg3-utils - - -

Requires

Name Value
libc6 >= 2.14
libmpeg3-2 >= 1.8.dfsg

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mpeg3-utils_1.8.dfsg-2.1_amd64.deb
Source Package libmpeg3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mpeg3-utils deb package:
    # sudo apt-get install mpeg3-utils

Files

Path
/usr/bin/mpeg3cat
/usr/bin/mpeg3dump
/usr/bin/mpeg3peek
/usr/bin/mpeg3toc
/usr/share/doc/mpeg3-utils/README.Debian
/usr/share/doc/mpeg3-utils/changelog.Debian.gz
/usr/share/doc/mpeg3-utils/copyright

Changelog

2017-11-06 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libmpeg3 (1.8.dfsg-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Promote Petter Reinholdtsen as Maintainer, remove David Martínez
Moreno (Closes: #845290)
[ Helmut Grohne ]
* Fix FTCBFS: (Closes: #876253)
+ Let dh_auto_build pass cross compilers to make.
+ Fix the debian-build-rules.patch.
2014-06-06 - Petter Reinholdtsen <pere@debian.org>
libmpeg3 (1.8.dfsg-2) unstable; urgency=low
* Add patch header-comment-fix.patch to fix a typo in the
mpeg3protos.h header.
* Move header files to /usr/include/mpeg3/ to group them together and
become compatible with Fedora which already place them there.  Adjust
pkg-config file to reflect the change.
2014-06-02 - Petter Reinholdtsen <pere@debian.org>
libmpeg3 (1.8.dfsg-1) unstable; urgency=low
* Update to debhelper 9 support.
* Move source patches to debian/patches/ and package format to 3.0
(quilt).
* Update upstream source to version 1.8 (Closes: #430770).
- Split relevant parts of the patch used in 1.5.4-5.1 info new
patches alpha-largefile.patch and debian-build-rules.patch
- Drop patches to fix bugs #287422 and #729275, as these problems
are fixed differently upstream.
- Change shared library major number from 1 to 2, as the new library have
a new API and ABI.
- No longer have typo in Makefile (Closes: #374504).
- Repack upstream tarball without mpeg3css.c and the a52dec library.
Instructions for how to do this is in debian/rules.
* Add patch prototype-free.patch to make sure stdlib.h is included
before free() is used.
* Change encoding of debian/copyright to UTF-8.
* Update standards-version from 3.6.2.2 to 3.9.5.
* Add missing dependency on ${misc:Depends}.  Thank you lintian.
* Adjust copyright file to document upstream copyright 2003-2008.
* Change debian/rules to use dh_prep instead of the obsolete
dh_clean -k.  Thank you, lintian.
* Enable hardening flags during build and linking.
* New patch fix-format-security-error.patch to make code buildable
with hardening enabled.
* Add homepage URL to control file (Closes: #749469).
* Reorder shared library linking rule to work with the --as-needed
linker flag (Closes: #633333).  Patch from Sebastian Carneiro and
Ubuntu.
* Use ${binary:Version} when depending on library from dev package,
instead of the obsolete ${Source-Version}. Thank you, lintian.
* New patch fix-video-alpha.patch lifted from the Cinelerra project
fixing pixel conversion macros, making sure the default alpha level
is max, not zero.
* New patch handle-hdv-m2t.patch lifted from the Cinelerra project
adding code to recognize *.m2t as MPEG files.
* Add Vcs-* headers to control file pointing to the collab-maint git
repository.
* New patch fix-format-strings.patch to correct format string problems
reported by the compiler because hardening was enabled.
* Add new patch compiler-warnings.patch to enable more compiler
warnings.
* Add new patch missing-include.patch to include system header files
where they were missing.
* Add patch fix-fake-css.patch to fix inconsistent function signature.
* Add patch missing-prototypes.patch to include prototypes before
function calls.
* Add pkgconfig file for libmpeg3 to ease detection and linking.
* Add missing rules targets build-arch and build-indep.  Thanks
lintian for the reminder.
* Add myself as uploader.
2014-04-26 - Johannes Brandstätter <jbrandst@2ds.eu>
libmpeg3 (1.5.4-5.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix stack overflow in read_toc. (Closes: #729275)
2006-02-03 - David Martínez Moreno <ender@debian.org>
libmpeg3 (1.5.4-5) unstable; urgency=low
* Fixed syntax in Makefile for compatibility with new make. Thanks, Daniel
Schepler (closes: #350689).
* Acknowledge NMU from Steve (closes: #287422).
* debian/control: Bumped Standards-Version to 3.6.2.2.
* debian/copyright: Updated FSF's address.

See Also

Package Description
mpegdemux_0.1.4-4_amd64.deb MPEG1/2 system stream demultiplexer
mpg123-el_1.58-1_all.deb front-end to mpg321/ogg321 media players for Emacs
mpg123_1.25.10-2_amd64.deb MPEG layer 1/2/3 audio player
mpg321_0.3.2-3ubuntu1_amd64.deb Simple and lightweight command line MP3 player
mpgrafic_0.3.18-1_amd64.deb MPI version of N-body initial conditions grafic package
mpgtx_1.3.1-6build1_amd64.deb toolbox to manipulate MPEG files (video, system, and audio)
mpi-default-bin_1.13_amd64.deb Standard MPI runtime programs (metapackage)
mpi-default-dev_1.13_amd64.deb Standard MPI development files (metapackage)
mpich-doc_3.3-3_all.deb Documentation for MPICH
mpich_3.3-3_amd64.deb Implementation of the MPI Message Passing Interface standard
mpikmeans-tools_1.5+dfsg-7_amd64.deb Standalone applications for MPIKmeans
mplayer-doc_1.3.0-8build3_all.deb documentation for MPlayer
mplayer-gui_1.3.0-8build3_amd64.deb movie player for Unix-like systems (GUI variant)
mplayer_1.3.0-8build3_amd64.deb movie player for Unix-like systems
mplinuxman_1.5-0ubuntu2_amd64.deb mp3 player manager for mpman F50/F60
Advertisement
Advertisement