mpd-sima_0.14.4-2_all.deb


Advertisement

Description

mpd-sima - Automagically add titles to MPD playlist

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mpd-sima_0.14.4-2_all.deb
Package name mpd-sima
Package version 0.14.4
Package release 2
Package architecture all
Package type deb
Category universe/sound
Homepage http://kaliko.me/code/mpd-sima
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 58.23 KB
Installed size 280.00 KB
MPD_Sima is a Python script meant to feed your MPD playlist with tracks
from artists similar to your currently playing track, provided that these
artists are found in MPD library. Similar artists are fetched from last.fm.
MPD_sima can queue track, top track or whole album for similar artists.
This client allows you to never run out of music when your playlist
queue is getting short.

Alternatives

Package Version Architecture Repository
mpd-sima_0.14.4-2_all.deb 0.14.4 all Ubuntu Universe
mpd-sima - - -

Requires

Name Value
adduser -
lsb-base -
python3-musicpd >= 0.4.1
python3-requests >= 2.0.2
python3:any >= 3.3.2-2~

Provides

Name Value
mpd-client -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mpd-sima_0.14.4-2_all.deb
Source Package mpd-sima

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mpd-sima deb package:
    # sudo apt-get install mpd-sima

Files

Path
/etc/mpd-sima.cfg
/etc/default/mpd-sima
/etc/init.d/mpd-sima
/etc/logrotate.d/mpd-sima
/lib/systemd/system/mpd-sima.service
/usr/bin/mpd-sima
/usr/bin/simadb_cli
/usr/lib/python3/dist-packages/MPD_sima-0.14.4.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/MPD_sima-0.14.4.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/MPD_sima-0.14.4.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/MPD_sima-0.14.4.egg-info/requires.txt
/usr/lib/python3/dist-packages/MPD_sima-0.14.4.egg-info/top_level.txt
/usr/lib/python3/dist-packages/sima/__init__.py
/usr/lib/python3/dist-packages/sima/client.py
/usr/lib/python3/dist-packages/sima/core.py
/usr/lib/python3/dist-packages/sima/info.py
/usr/lib/python3/dist-packages/sima/launch.py
/usr/lib/python3/dist-packages/sima/lib/__init__.py
/usr/lib/python3/dist-packages/sima/lib/cache.py
/usr/lib/python3/dist-packages/sima/lib/daemon.py
/usr/lib/python3/dist-packages/sima/lib/http.py
/usr/lib/python3/dist-packages/sima/lib/logger.py
/usr/lib/python3/dist-packages/sima/lib/meta.py
/usr/lib/python3/dist-packages/sima/lib/player.py
/usr/lib/python3/dist-packages/sima/lib/plugin.py
/usr/lib/python3/dist-packages/sima/lib/simadb.py
/usr/lib/python3/dist-packages/sima/lib/simaecho.py
/usr/lib/python3/dist-packages/sima/lib/simafm.py
/usr/lib/python3/dist-packages/sima/lib/simastr.py
/usr/lib/python3/dist-packages/sima/lib/track.py
/usr/lib/python3/dist-packages/sima/lib/webserv.py
/usr/lib/python3/dist-packages/sima/plugins/__init__.py
/usr/lib/python3/dist-packages/sima/plugins/contrib/__init__.py
/usr/lib/python3/dist-packages/sima/plugins/contrib/placeholder.py
/usr/lib/python3/dist-packages/sima/plugins/core/__init__.py
/usr/lib/python3/dist-packages/sima/plugins/core/history.py
/usr/lib/python3/dist-packages/sima/plugins/core/mpdoptions.py
/usr/lib/python3/dist-packages/sima/plugins/core/uniq.py
/usr/lib/python3/dist-packages/sima/plugins/internal/__init__.py
/usr/lib/python3/dist-packages/sima/plugins/internal/crop.py
/usr/lib/python3/dist-packages/sima/plugins/internal/echonest.py
/usr/lib/python3/dist-packages/sima/plugins/internal/lastfm.py
/usr/lib/python3/dist-packages/sima/plugins/internal/random.py
/usr/lib/python3/dist-packages/sima/utils/__init__.py
/usr/lib/python3/dist-packages/sima/utils/config.py
/usr/lib/python3/dist-packages/sima/utils/filelock.py
/usr/lib/python3/dist-packages/sima/utils/leven.py
/usr/lib/python3/dist-packages/sima/utils/startopt.py
/usr/lib/python3/dist-packages/sima/utils/utils.py
/usr/share/bash-completion/completions/mpd-sima.sh
/usr/share/doc/mpd-sima/NEWS.Debian.gz
/usr/share/doc/mpd-sima/README.Debian
/usr/share/doc/mpd-sima/changelog.Debian.gz
/usr/share/doc/mpd-sima/copyright
/usr/share/doc/mpd-sima/examples/album_mode.cfg
/usr/share/doc/mpd-sima/examples/all_settings.cfg.gz
/usr/share/man/man1/mpd-sima.1.gz
/usr/share/man/man1/simadb_cli.1.gz
/usr/share/man/man5/mpd_sima.cfg.5.gz

Changelog

2018-04-27 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.14.4-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
* d/control: Fix wrong Vcs-*
[ Felipe Sateler ]
* Change maintainer address to debian-multimedia@lists.debian.org
[ Geoffroy Youri Berret ]
* Fixed Vcs-browser address (salsa migration)
* Update Build-Depends and switch to dh 10
* Bumped Standards-Version to 4.1.4, no changes needed
* Remove explicit call to dh systemd.
* Switch to https in debian/watch
* Bump uscan version and simplified watch file
2017-08-24 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.14.4-1) unstable; urgency=medium
* New upstream version 0.14.4
* Fixed MPD client to work with MPD >= 0.20 (Closes: #854962)
2016-06-14 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.14.1-2) unstable; urgency=medium
* Fixed wrong path value for stat overrides. (Closes: #825561)
* Bumped Standards-Version to 3.9.8, no changes needed
* Add missing systemd service file documentation key
* Fixed insecure vcs-field uri
2016-01-02 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.14.1-1) unstable; urgency=medium
* Imported Upstream version 0.14.1 (Closes: #803957)
* Create database with mpd-sima user (Fixed piuparts error)
* Add optional EnvironmentFile to systemd service file (Closes: #801136)
* Fixed Random plugin name in configuration
2015-01-28 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.13.1-1) unstable; urgency=low
* Upstream moved to python3, major package refactoring
* Migrate to dh-python
* Bumped Standards-Version to 3.9.6, no changes nedeed
* Bumped compat level to 9
* Add pgpsigurlmangle for uscan
* Depends on musicpd and requests
* Updated copyright
* Add service file (systemd)
2013-05-21 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.10.0-2) unstable; urgency=low
* Set package priority to optional.
2013-03-07 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.10.0-1) experimental; urgency=low
* Add weak dependencies on MPD in init script (Closes: #687426)
* Set minimum MPD version in Suggests field
* New upstream version 0.10.0 (LP: #1056738)
* Bumped Standards-Version to 3.9.4.0
* Adjust Build-Depends
* init script ensure creation of /run/mpd-sima
2012-05-21 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.9.2-2) unstable; urgency=low
* Bumped python-mpd version (needed for idle MPD command)
* Fixed unwanted config file creation in postinst script (Closes: #673793)
2012-02-27 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.9.2-1) unstable; urgency=low
* New Upstream version 0.9.2
* Default similarity is now 15%
* Add "Enhances" field to control file
* Create database during installation (Closes: #637192)
* Fixed short name license in copyright file.
* Add missing status command to init script.
* Use symlinks instead of shell wrappers in /usr/bin
* Manuals are no longuer built with the package
Upstream provides them.
* Bumped Standards-Version to 3.9.3
Update copyright Format field with proper URL
2011-08-08 - Geoffroy Youri Berret <efrim@azylum.org>
mpd-sima (0.8.0-2) unstable; urgency=low
* Fix a typo in init script (Closes: #636595)

See Also

Package Description
mpd_0.21.4-1build1_amd64.deb Music Player Daemon
mpdas_0.4.5-1_amd64.deb AudioScrobbler client for MPD
mpdcon.app_1.1.99-5build8_amd64.deb MPD controller for GNUstep
mpdcron_0.3+git20161228-3_amd64.deb add scrobbler, rating, play counts and other functionalities to MPD
mpdris2_0.7+git20181226-1_all.deb media player interface (MPRIS2) bridge for MPD
mpdscribble_0.22-6_amd64.deb Last.fm reporting client for mpd
mpdtoys_0.25_all.deb small command line tools and toys for MPD
mpeg2dec_0.5.1-8_amd64.deb Simple libmpeg2 video decoder application
mpeg3-utils_1.8.dfsg-2.1_amd64.deb MPEG streams decoding library
mpegdemux_0.1.4-4_amd64.deb MPEG1/2 system stream demultiplexer
mpg123-el_1.58-1_all.deb front-end to mpg321/ogg321 media players for Emacs
mpg123_1.25.10-2_amd64.deb MPEG layer 1/2/3 audio player
mpg321_0.3.2-3ubuntu1_amd64.deb Simple and lightweight command line MP3 player
mpgrafic_0.3.18-1_amd64.deb MPI version of N-body initial conditions grafic package
mpgtx_1.3.1-6build1_amd64.deb toolbox to manipulate MPEG files (video, system, and audio)
Advertisement
Advertisement