morse-simulator_1.4-5_amd64.deb


Advertisement

Description

morse-simulator - Multi-OpenRobot Simulation Engine

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename morse-simulator_1.4-5_amd64.deb
Package name morse-simulator
Package version 1.4
Package release 5
Package architecture amd64
Package type deb
Category universe/science
Homepage http://morse-simulator.github.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 41.39 KB
Installed size 114.00 KB
List of morse features:
* Versatile simulator for generic mobile robots simulation
(single or multi robots),
* Realistic and dynamic environments (interaction with other agents like
humans or objects),
* Based on well known and widely adopted open source projects (Blender for 3D
rendering + UI, Bullet for physics simulation, dedicated robotic
middlewares for communications + robot hardware support),
* Seamless workflow: since the simulator rely on Blender for both modeling
and the real time 3D engine, creating and modifying a simulated scene is
straightforward.
* Entirely scriptable in Python,
* Adaptable to various level of simulation realism (for instance the
simulation of exteroceptive sensors like cameras or a direct access to
higher level representations of the world, like labeled artifacts),
* Currently compatible with ROS, YARP and the LAAS OpenRobots robotics
frameworks,
* Easy to integrate to other environments via a simple socket interface,
* Fully open source, BSD license.

Alternatives

Package Version Architecture Repository
morse-simulator_1.4-5_i386.deb 1.4 i386 Ubuntu Universe
morse-simulator - - -

Requires

Name Value
blender >= 2.65
morse-simulator-data -
python3-morse-simulator = 1.4-5
python3-numpy -
python3:any >= 3.3~

Conflicts

Name Value
morse -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package morse-simulator_1.4-5_amd64.deb
Source Package morse-simulator

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install morse-simulator deb package:
    # sudo apt-get install morse-simulator

Files

Path
/usr/bin/morse
/usr/bin/morse_inspector
/usr/bin/morse_sync
/usr/bin/morseexec
/usr/bin/morsesim
/usr/bin/multinode_server
/usr/share/doc/morse-simulator/AUTHORS
/usr/share/doc/morse-simulator/CITATION
/usr/share/doc/morse-simulator/README.md
/usr/share/doc/morse-simulator/RELEASE_NOTES.gz
/usr/share/doc/morse-simulator/changelog.Debian.gz
/usr/share/doc/morse-simulator/copyright
/usr/share/man/man1/morse-add.1.gz
/usr/share/man/man1/morse-check.1.gz
/usr/share/man/man1/morse-create.1.gz
/usr/share/man/man1/morse-edit.1.gz
/usr/share/man/man1/morse-import.1.gz
/usr/share/man/man1/morse-rm.1.gz
/usr/share/man/man1/morse-run.1.gz
/usr/share/man/man1/morse.1.gz
/usr/share/man/man1/morse_sync.1.gz
/usr/share/man/man1/morseexec.1.gz
/usr/share/man/man1/multinode_server.1.gz

Changelog

2019-02-22 - Andreas Tille <tille@debian.org>
morse-simulator (1.4-5) unstable; urgency=medium
* Team upload.
[ Micha David Rosenbaum ]
* Fix the FTBFS by replacing pngmath with imgmath Sphinx module.
(Closes: #921897)
[ Andreas Tille ]
* cme fix dpkg-control
* debhelper 11
* Document skip upstream build time test
* Secure URI in d/copyright
* Add debian/gbp.conf: pristine-tar = False
2019-01-05 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.4-4) unstable; urgency=medium
* Rename the variable to build with python 3.7
(Closes: #904343)
2018-04-15 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.4-3) unstable; urgency=medium
* Fix the FTBFS by adding the version.py file from usptream
(Closes: #853557)
* Package moved on salsa
* Standards-Version updated to 4.1.3
* Move to compat mode 8
* Fix priority-extra-is-replaced-by-priority-optional
* Explicit python3-setuptools as dep
* Rename morse => morsesim to avoid a conflict
For now, it still contains a symlink from morse to morseim
I will remove it later.
(Closes: #861028)
* Disable the sphinx ext vimeo & gallery until
https://github.com/morse-simulator/morse/issues/792 is fixed
[ Séverin Lemaignan ]
* Relax the need for Sphinx 1.3 as the original issue (#792711) has been
fixed upstream
2016-02-17 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.4-2) unstable; urgency=medium
* Fix a bad dependency (numpy)
* Update the minimal version of Blender (2.64)
* Update the minimal version of Python (3.3)
[ Séverin Lemaignan ]
* Moved to github
* Update of the homepage
* Update of the VCS field
2016-02-16 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.4-1) unstable; urgency=medium
* New upstream release
* Add numpy as dependency
* Add --fail-missing to dh_install
2015-08-17 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.3-1) unstable; urgency=medium
* New upstream release
2015-08-24 - Dmitry Shachnev <mitya57@debian.org>
morse-simulator (1.2.2-1.1) unstable; urgency=medium
* Non-maintainer upload, with maintainer's permission.
* Update morse-theme for Sphinx 1.3 (closes: #792711).
- Bump python3-sphinx build-dependency.
2015-04-27 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.2.2-1) unstable; urgency=medium
* Upload to unstable
2014-12-30 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.2.2-1~exp1) experimental; urgency=medium
* New upstream release
* Standards-Version updated to 3.9.6
2014-12-21 - Sylvestre Ledru <sylvestre@debian.org>
morse-simulator (1.2.1-2) unstable; urgency=medium
[ Tobias Hansen ]
* Allow running with Blender 2.72. (Closes: #771132)

See Also

Package Description
morse-x_20060903-0ubuntu2_amd64.deb morse "practicing" tool for X
morse2ascii_0.2+dfsg-3_amd64.deb tool for decoding the morse codes from a PCM WAV file
morse_2.5-1build1_amd64.deb training program about morse-code for aspiring radio hams
morsegen_0.2.1-1_amd64.deb convert text file to ASCII morse code
morty_0.2.0-1_amd64.deb Privacy aware web content sanitizer proxy as a service
moserial_3.0.12-0ubuntu2_amd64.deb Gtk-based serial terminal for the GNOME desktop
mosh_1.3.2-2.1build1_amd64.deb Mobile shell that supports roaming and intelligent local echo
mosquitto-auth-plugin_0.1.2-1build1_amd64.deb Authentication plugin for Mosquitto with multiple back-ends
mosquitto-clients_1.5.7-1_amd64.deb Mosquitto command line MQTT clients
mosquitto-dev_1.5.7-1_all.deb Development files for Mosquitto
mosquitto_1.5.7-1_amd64.deb MQTT version 3.1/3.1.1 compatible message broker
most_5.0.0a-4_amd64.deb Pager program similar to more and less
mothur_1.41.21-1_amd64.deb sequence analysis suite for research on microbiota
motion_4.1.1-1.1build1_amd64.deb V4L capture program supporting motion detection
mountpy_0.8.1build1_amd64.deb script for quick mounting of removable devices
Advertisement
Advertisement