moonshot-gss-eap_1.0.1-6_amd64.deb


Advertisement

Description

moonshot-gss-eap - Moonshot Federated Authentication - authentication mechanism

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename moonshot-gss-eap_1.0.1-6_amd64.deb
Package name moonshot-gss-eap
Package version 1.0.1
Package release 6
Package architecture amd64
Package type deb
Category universe/net
Homepage http://www.project-moonshot.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 175.54 KB
Installed size 532.00 KB
Project moonshot provides federated authentication using EAP, RADIUS
and SAML to applications beyond the web platform. This package
contains the client and server plugins to perform authentication.

Alternatives

Package Version Architecture Repository
moonshot-gss-eap_1.0.1-6_i386.deb 1.0.1 i386 Ubuntu Universe
moonshot-gss-eap - - -

Requires

Name Value
libc6 >= 2.17
libcom-err2 >= 1.43.9
libgcc1 >= 1:3.0
libgssapi-krb5-2 >= 1.11+dfsg
libjansson4 >= 2.0.1
libk5crypto3 >= 1.9+dfsg~beta1
libkrb5-3 >= 1.7dfsg
libmoonshot1 >= 1.0.3
libradsec0 >= 0.0.5-5
libsaml10 -
libshibresolver2 -
libshibsp8 >= 3.0.3+dfsg1
libssl1.1 >= 1.1.0
libstdc++6 >= 5.2
libxerces-c3.2 -
libxmltooling8 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package moonshot-gss-eap_1.0.1-6_amd64.deb
Source Package moonshot-gss-eap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install moonshot-gss-eap deb package:
    # sudo apt-get install moonshot-gss-eap

Files

Path
/etc/gss/mech.d/moonshot-gss-eap.conf
/usr/include/gssapi/gssapi_eap.h
/usr/lib/x86_64-linux-gnu/gss/mech_eap.so
/usr/share/doc/moonshot-gss-eap/TODO.Debian
/usr/share/doc/moonshot-gss-eap/changelog.Debian.gz
/usr/share/doc/moonshot-gss-eap/copyright

Changelog

2019-02-11 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-6) unstable; urgency=medium
* Disable TLS1.3 in our client because it doesn't work currently.
2019-01-02 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-5) unstable; urgency=medium
* New test suite; currently only tests .gss_eap_id but not moonshot-ui
* Depend on new libradsec to deal with openssl 1.1.1
2018-12-23 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-4) unstable; urgency=medium
* Force building against libssl-dev not libssl1.0-dev; now that
Shibboleth depends on ssl 1.1, we can too.
* Don't include xmltooling datetime.h as it no longer exists, Closes: #916223
* Upload to unstable
2017-11-08 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-3) experimental; urgency=medium
* Fix warning redefinition of __bitwise, Closes: #866712
2017-11-07 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-2) experimental; urgency=medium
* I thought that libssl-dev|libssl1.0-dev would be enough to let the software build.  However because of libxmltooling-dev, libssl1.0-dev must come first.
2017-10-30 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (1.0.1-1) experimental; urgency=medium
* New upstream version
* supports openssl 1.1.0, Closes: #848680
* standards-version  4.1.1
* No longer create /usr/etc/gss/mech; that was never desired in Debian but could be triggered by modern libgssapi-krb5-2
2017-07-31 - Painless Security <build@painless-security.com>
moonshot-gss-eap (1.0.1-0) unstable; urgency=medium
* Fixed https://bugs.launchpad.net/moonshot/+bug/1707679
2017-07-24 - Painless Security <build@painless-security.com>
moonshot-gss-eap (1.0.0-0) unstable; urgency=medium
* Fixed https://bugs.launchpad.net/moonshot/+bug/1705714.
Refactored a static object whose destructor was responsible for
de-initializing the ShibResolver library.
2016-12-19 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (0.9.5-3) unstable; urgency=medium
* Build depend against openssl 1.0, Closes: #828440
2016-08-22 - Sam Hartman <hartmans@debian.org>
moonshot-gss-eap (0.9.5-2) unstable; urgency=medium
* Fix FTBFS with gcc-6: auto_ptr is deprecated.  First, -Wdeprecated
should not cause an error for package builds.  Second, use unique_ptr,
Closes: #831187
* Upgrade standards version to 3.9.8 (no changes needed)

See Also

Package Description
moonshot-ui-dev_1.1.0+libsecret~1ubuntu1_amd64.deb Moonshot Identity Development Files
moonshot-ui_1.1.0+libsecret~1ubuntu1_amd64.deb Moonshot Identity Selector
moosic_1.5.6-1_all.deb Daemon/client combo to easily queue music files for playing
mopac7-bin_1.15-6ubuntu3_amd64.deb Semi-empirical Quantum Chemistry Library (binaries)
mopidy-alsamixer_1.1.1-1_all.deb Mopidy extension for extension for ALSA volume control
mopidy-beets_3.1.0-1_all.deb Mopidy extension for playing music from Beets' web plugin
mopidy-dirble_1.3.0-3_all.deb Mopidy extension for browsing Dirble's radio station directory
mopidy-dleyna_1.2.2-1_all.deb Mopidy extension for playing music from Digital Media Servers
mopidy-doc_2.2.2-1_all.deb music server with support for MPD/HTTP clients - documentation
mopidy-internetarchive_2.0.3-1_all.deb Mopidy extension for playing music from the Internet Archive
mopidy-local-sqlite_1.0.0-2_all.deb Mopidy extension for keeping your local library in SQLite
mopidy-mpris_2.0.0-1_all.deb Mopidy extension for controlling playback through MPRIS
mopidy-podcast-itunes_2.0.0-3_all.deb Mopidy extension for searching and browsing iTunes podcasts
mopidy-podcast_2.0.3-1_all.deb Mopidy extension for searching and browsing podcasts
mopidy-scrobbler_1.2.0-1_all.deb Mopidy extension for scrobbling music to Last.fm
Advertisement
Advertisement