moon-lander_1.0-7_amd64.deb


Advertisement

Description

moon-lander - game based on the classic moon lander

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename moon-lander_1.0-7_amd64.deb
Package name moon-lander
Package version 1.0
Package release 7
Package architecture amd64
Package type deb
Category universe/games
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 21.97 KB
Installed size 60.00 KB
Moonlander is a fun and enjoyable modern graphical version (with
sound) of the classic moonlander game.  The objective is to land
your rocketship safely using a limited amount of fuel while
fighting gravity.

Alternatives

Package Version Architecture Repository
moon-lander_1.0-7_i386.deb 1.0 i386 Ubuntu Universe
moon-lander - - -

Requires

Name Value
libc6 >= 2.4
libsdl-image1.2 >= 1.2.10
libsdl-mixer1.2 -
libsdl1.2debian >= 1.2.11
moon-lander-data -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package moon-lander_1.0-7_amd64.deb
Source Package moon-lander

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install moon-lander deb package:
    # sudo apt-get install moon-lander

Files

Path
/usr/games/moon-lander
/usr/share/applications/moon-lander.desktop
/usr/share/doc/moon-lander/README.txt.gz
/usr/share/doc/moon-lander/changelog.Debian.gz
/usr/share/doc/moon-lander/copyright
/usr/share/man/man6/moon-lander.6.gz
/usr/share/pixmaps/moon-lander.xpm

Changelog

2017-12-10 - Jeremy Bicha <jbicha@debian.org>
moon-lander (1:1.0-7) unstable; urgency=medium
* QA upload.
* Add fix-crashes-at-startup.patch:
- Add patch from Artur Rona
2017-10-12 - Adam Borowski <kilobyte@angband.pl>
moon-lander (1:1.0-6) unstable; urgency=medium
* QA upload.
* Set maintainer to the QA team.
* Make the data package M-A:foreign.
* Remove the menu file -- there's already a .desktop.
2013-06-25 - Joe Nahmias <jello@debian.org>
moon-lander (1:1.0-5) unstable; urgency=low
* ack NMU
* Switch to dpkg-source 3.0 (quilt) format
* split up patches and add DEP3 headers
* bump debhelper compat -> 9
* bump std-ver to 3.9.4, no changes
* minimize d/rules using dh(1)
* make lintian happy and remove reference to BSD common-license file
since it's already fully included in the copyright file
* fix short description to satisfy lintian
* fix handling of LDFLAGS for relro hardening
* Add desktop menu file, thanks Daniel Dickinson, closes: #478927.
* fix all gcc warnings, closes: #688585.
* remove versioning from libsdl1.2-dev build-dep as even squeeze
(oldstable) satisfies it
2011-12-03 - Meike Reichle <meike@debian.org>
moon-lander (1:1.0-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix "FTBFS with binutils-gold", added missing link to libm 
(Thanks to Paul Merrill ) (Closes: #555753)
* Urgency set to medium, rc Bug fix
2007-08-10 - Joe Nahmias <jello@debian.org>
moon-lander (1:1.0-4) unstable; urgency=low
* Add remaining fuel to score, closes: #347240.
* When choosing a background, skip anything other than a regular file,
closes: #418019.
* moon-lander-data: recommend moon-lander.
* moon-lander-data: remove obsolete conflict, it's not even available in
oldstable (sarge).
* Don't build moon-lander-data in binary-arch target, closes: #304115.
* Update menu section to comply with new policy: Arcade => Action.
2004-07-05 - Joe Nahmias <jello@debian.org>
moon-lander (1:1.0-3) unstable; urgency=low
* Split game data into separate arch-indep pkg, closes: #233416.
2003-09-28 - Joe Nahmias <joe@nahmias.net>
moon-lander (1:1.0-2) unstable; urgency=low
* XPM files are text -- No need to uu{en,de}code.  Thanks Roger Ward!
- debian/control: Build-deps -= sharutils.
- debian/rules: remove references to uudecode.
* debian/control(Std-Ver): 3.6.1.0
* debian/control: Updated maintainer address.
2003-03-10 - Joe Nahmias <joe@nahmias.net>
moon-lander (1:1.0-1) unstable; urgency=low
* New upstream version.
* debian/control:
- New maintainer, closes: #182984.
- Standards-Version ==> 3.5.8.0.
- Build-deps: added sharutils for uudecode.
* debian/rules: added CFLAGS handling for std-ver compliance.
* New files:
- debian/compat: set to 4.
- debian/moon-lander.xpm.uue: icon for menu.
- Makefile.Debian: rewrite of upstream's borked makefile for Debian.
2001-10-30 - Peter Joseph <kneecaps@debian.org>
moon-lander (1:0.9.0-6) unstable; urgency=low
* Rebuild to fix dynamically linked libXxf86dga (closes: #117309)
2001-10-25 - Peter Joseph <kneecaps@debian.org>
moon-lander (1:0.9.0-5) unstable; urgency=low
* Rebuilt against new SDL packages (closes: #116462)
* Changed build-deps to reflect above needs

See Also

Package Description
moonshot-gss-eap_1.0.1-6_amd64.deb Moonshot Federated Authentication - authentication mechanism
moonshot-ui-dev_1.1.0+libsecret~1ubuntu1_amd64.deb Moonshot Identity Development Files
moonshot-ui_1.1.0+libsecret~1ubuntu1_amd64.deb Moonshot Identity Selector
moosic_1.5.6-1_all.deb Daemon/client combo to easily queue music files for playing
mopac7-bin_1.15-6ubuntu3_amd64.deb Semi-empirical Quantum Chemistry Library (binaries)
mopidy-alsamixer_1.1.1-1_all.deb Mopidy extension for extension for ALSA volume control
mopidy-beets_3.1.0-1_all.deb Mopidy extension for playing music from Beets' web plugin
mopidy-dirble_1.3.0-3_all.deb Mopidy extension for browsing Dirble's radio station directory
mopidy-dleyna_1.2.2-1_all.deb Mopidy extension for playing music from Digital Media Servers
mopidy-doc_2.2.2-1_all.deb music server with support for MPD/HTTP clients - documentation
mopidy-internetarchive_2.0.3-1_all.deb Mopidy extension for playing music from the Internet Archive
mopidy-local-sqlite_1.0.0-2_all.deb Mopidy extension for keeping your local library in SQLite
mopidy-mpris_2.0.0-1_all.deb Mopidy extension for controlling playback through MPRIS
mopidy-podcast-itunes_2.0.0-3_all.deb Mopidy extension for searching and browsing iTunes podcasts
mopidy-podcast_2.0.3-1_all.deb Mopidy extension for searching and browsing podcasts
Advertisement
Advertisement